summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-16 07:37:26 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-16 07:37:26 +0200
commit81d5706e70c1c385102b85732e71860e36742ee9 (patch)
tree37fd06ef5117399bbf2b845c3c2d50b38aa61d9a
parent85a8b34c22124be3b673a209d160f433693dd640 (diff)
php-Smarty: 3.1.25
-rw-r--r--php-Smarty-upstream.patch67
-rw-r--r--php-Smarty.spec15
2 files changed, 7 insertions, 75 deletions
diff --git a/php-Smarty-upstream.patch b/php-Smarty-upstream.patch
deleted file mode 100644
index e8a0184..0000000
--- a/php-Smarty-upstream.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 0434f34bdddef36bdfca3bc1f58a5ef87d94669e Mon Sep 17 00:00:00 2001
-From: Uwe Tews <uwe.tews@googlemail.com>
-Date: Sun, 24 May 2015 18:37:53 +0200
-Subject: [PATCH] - bugfix if condition string 'neq' broken due to a typo
- https://github.com/smarty-php/smarty/issues/42
-
----
- change_log.txt | 2 ++
- lexer/smarty_internal_templatelexer.plex | 2 +-
- lexer/smarty_internal_templateparser.y | 2 +-
- libs/Smarty.class.php | 2 +-
- libs/sysplugins/smarty_internal_templatelexer.php | 2 +-
- libs/sysplugins/smarty_internal_templateparser.php | 2 +-
- 6 files changed, 7 insertions(+), 5 deletions(-)
-
-diff --git a/lexer/smarty_internal_templatelexer.plex b/lexer/smarty_internal_templatelexer.plex
-index 56b7b8d..ef5a8dd 100644
---- a/lexer/smarty_internal_templatelexer.plex
-+++ b/lexer/smarty_internal_templatelexer.plex
-@@ -293,7 +293,7 @@ class Smarty_Internal_Templatelexer
- literal = ~literal~
- strip = ~strip~
- lop = ~\s*(([!=][=]{1,2})|([<][=>]?)|([>][=]?)|[&|]{2})\s*~
-- tlop = ~\s+(eq|ne|neg|gt|ge|gte|lt|le|lte|mod|and|or|xor|(is\s+(not\s+)?(odd|even|div)\s+by))\s+~
-+ tlop = ~\s+(eq|ne|neq|gt|ge|gte|lt|le|lte|mod|and|or|xor|(is\s+(not\s+)?(odd|even|div)\s+by))\s+~
- scond = ~\s+is\s+(not\s+)?(odd|even)~
- isin = ~\s+is\s+in\s+~
- as = ~\s+as\s+~
-diff --git a/lexer/smarty_internal_templateparser.y b/lexer/smarty_internal_templateparser.y
-index 78bf90a..1e515e3 100644
---- a/lexer/smarty_internal_templateparser.y
-+++ b/lexer/smarty_internal_templateparser.y
-@@ -1237,7 +1237,7 @@ lop(res) ::= TLOGOP(o). {
- 'isoddby' => array('op' => ' / ', 'pre' => '(1 & '),
- 'isnotoddby' => array('op' => ' / ', 'pre' => '!(1 & '),
- );
-- $op = strtolower(str_replace(' ', '', o));
-+ $op = strtolower(preg_replace('/\s*/', '', o));
- res = $lops[$op];
- }
-
-diff --git a/libs/sysplugins/smarty_internal_templatelexer.php b/libs/sysplugins/smarty_internal_templatelexer.php
-index 8fb21ab..f440a00 100644
---- a/libs/sysplugins/smarty_internal_templatelexer.php
-+++ b/libs/sysplugins/smarty_internal_templatelexer.php
-@@ -505,7 +505,7 @@ function yy_r2_12()
- public function yylex3()
- {
- if (!isset($this->yy_global_pattern3)) {
-- $this->yy_global_pattern3 = "/\G(\\s*" . $this->rdel . ")|\G([\"])|\G('[^'\\\\]*(?:\\\\.[^'\\\\]*)*')|\G([$]smarty\\.block\\.(child|parent))|\G([$][0-9]*[a-zA-Z_]\\w*)|\G([$])|\G(\\s+is\\s+in\\s+)|\G(\\s+as\\s+)|\G(\\s+to\\s+)|\G(\\s+step\\s+)|\G(\\s+instanceof\\s+)|\G(\\s*(([!=][=]{1,2})|([<][=>]?)|([>][=]?)|[&|]{2})\\s*)|\G(\\s+(eq|ne|neg|gt|ge|gte|lt|le|lte|mod|and|or|xor|(is\\s+(not\\s+)?(odd|even|div)\\s+by))\\s+)|\G(\\s+is\\s+(not\\s+)?(odd|even))|\G(([!]\\s*)|(not\\s+))|\G([(](int(eger)?|bool(ean)?|float|double|real|string|binary|array|object)[)]\\s*)|\G(\\s*[(]\\s*)|\G(\\s*[)])|\G(\\[\\s*)|\G(\\s*\\])|\G(\\s*[-][>]\\s*)|\G(\\s*[=][>]\\s*)|\G(\\s*[=]\\s*)|\G(([+]|[-]){2})|\G(\\s*([+]|[-])\\s*)|\G(\\s*([*]{1,2}|[%\/^&]|[<>]{2})\\s*)|\G([@])|\G([#])|\G(\\s+[0-9]*[a-zA-Z_][a-zA-Z0-9_\-:]*\\s*[=]\\s*)|\G(([0-9]*[a-zA-Z_]\\w*)?(\\\\[0-9]*[a-zA-Z_]\\w*)+)|\G([0-9]*[a-zA-Z_]\\w*)|\G(\\d+)|\G([`])|\G([|])|\G([.])|\G(\\s*[,]\\s*)|\G(\\s*[;]\\s*)|\G([:]{2})|\G(\\s*[:]\\s*)|\G(\\s*[?]\\s*)|\G(0[xX][0-9a-fA-F]+)|\G(\\s+)|\G(" . $this->ldel . "\\s*)|\G([\S\s])/isS";
-+ $this->yy_global_pattern3 = "/\G(\\s*" . $this->rdel . ")|\G([\"])|\G('[^'\\\\]*(?:\\\\.[^'\\\\]*)*')|\G([$]smarty\\.block\\.(child|parent))|\G([$][0-9]*[a-zA-Z_]\\w*)|\G([$])|\G(\\s+is\\s+in\\s+)|\G(\\s+as\\s+)|\G(\\s+to\\s+)|\G(\\s+step\\s+)|\G(\\s+instanceof\\s+)|\G(\\s*(([!=][=]{1,2})|([<][=>]?)|([>][=]?)|[&|]{2})\\s*)|\G(\\s+(eq|ne|neq|gt|ge|gte|lt|le|lte|mod|and|or|xor|(is\\s+(not\\s+)?(odd|even|div)\\s+by))\\s+)|\G(\\s+is\\s+(not\\s+)?(odd|even))|\G(([!]\\s*)|(not\\s+))|\G([(](int(eger)?|bool(ean)?|float|double|real|string|binary|array|object)[)]\\s*)|\G(\\s*[(]\\s*)|\G(\\s*[)])|\G(\\[\\s*)|\G(\\s*\\])|\G(\\s*[-][>]\\s*)|\G(\\s*[=][>]\\s*)|\G(\\s*[=]\\s*)|\G(([+]|[-]){2})|\G(\\s*([+]|[-])\\s*)|\G(\\s*([*]{1,2}|[%\/^&]|[<>]{2})\\s*)|\G([@])|\G([#])|\G(\\s+[0-9]*[a-zA-Z_][a-zA-Z0-9_\-:]*\\s*[=]\\s*)|\G(([0-9]*[a-zA-Z_]\\w*)?(\\\\[0-9]*[a-zA-Z_]\\w*)+)|\G([0-9]*[a-zA-Z_]\\w*)|\G(\\d+)|\G([`])|\G([|])|\G([.])|\G(\\s*[,]\\s*)|\G(\\s*[;]\\s*)|\G([:]{2})|\G(\\s*[:]\\s*)|\G(\\s*[?]\\s*)|\G(0[xX][0-9a-fA-F]+)|\G(\\s+)|\G(" . $this->ldel . "\\s*)|\G([\S\s])/isS";
- }
- if ($this->counter >= strlen($this->data)) {
- return false; // end of input
-diff --git a/libs/sysplugins/smarty_internal_templateparser.php b/libs/sysplugins/smarty_internal_templateparser.php
-index b09c53c..af748ba 100644
---- a/libs/sysplugins/smarty_internal_templateparser.php
-+++ b/libs/sysplugins/smarty_internal_templateparser.php
-@@ -2202,7 +2202,7 @@ function yy_r174()
- 'isnotevenby' => array('op' => ' / ', 'pre' => '(1 & '),
- 'isoddby' => array('op' => ' / ', 'pre' => '(1 & '),
- 'isnotoddby' => array('op' => ' / ', 'pre' => '!(1 & '),);
-- $op = strtolower(str_replace(' ', '', $this->yystack[$this->yyidx + 0]->minor));
-+ $op = strtolower(preg_replace('/\s*/', '', $this->yystack[$this->yyidx + 0]->minor));
- $this->_retvalue = $lops[$op];
- }
-
diff --git a/php-Smarty.spec b/php-Smarty.spec
index cce4154..eee58f6 100644
--- a/php-Smarty.spec
+++ b/php-Smarty.spec
@@ -8,23 +8,20 @@
# Please preserve changelog entries
#
-%global gh_commit b58771e31b11c721f6aa8e574e16e4058f9edc5f
+%global gh_commit 58616d6ee598674b682f8a2b81352ec4da7100c7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner smarty-php
%global gh_project smarty
Name: php-Smarty
Summary: Template/Presentation Framework for PHP
-Version: 3.1.24
-Release: 2%{?dist}
+Version: 3.1.25
+Release: 1%{?dist}
URL: http://www.smarty.net
License: LGPLv2+
Group: Development/Libraries
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}.tar.gz
-
-# https://github.com/smarty-php/smarty/issues/42
-Patch0: %{name}-upstream.patch
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -55,7 +52,6 @@ high-performance, scalability, security and future growth.
%prep
%setup -qn %{gh_project}-%{gh_commit}
-%patch0 -p1
%build
# empty build section, nothing required
@@ -84,6 +80,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
+* Tue Jun 16 2015 Remi Collet <remi@fedoraproject.org> - 3.1.25-1
+- update to 3.1.25
+
* Sun May 24 2015 Remi Collet <remi@fedoraproject.org> - 3.1.24-2
- upstream patch for 'neq' regression
https://github.com/smarty-php/smarty/issues/42