summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-08-08 08:34:10 +0200
committerRemi Collet <fedora@famillecollet.com>2016-08-08 08:34:10 +0200
commit682bc2611e54cc6dc110737295f4d75817b75694 (patch)
treea473d3c780c4d95d2d9a5d61ec5557e4c6fa40e8
parente61bc428a15727dfc2f3cf0356afa41bfbfb8379 (diff)
php-Smarty: 3.1.30
-rw-r--r--composer.json43
-rw-r--r--php-Smarty.spec9
2 files changed, 49 insertions, 3 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..2a1a43a
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,43 @@
+{
+ "name": "smarty/smarty",
+ "type": "library",
+ "description": "Smarty - the compiling PHP template engine",
+ "keywords": ["templating"],
+ "homepage": "http://www.smarty.net",
+ "license": "LGPL-3.0",
+ "authors": [
+ {
+ "name": "Monte Ohrt",
+ "email": "monte@ohrt.com"
+ },
+ {
+ "name": "Uwe Tews",
+ "email": "uwe.tews@googlemail.com"
+ },
+ {
+ "name": "Rodney Rehm",
+ "email": "rodney.rehm@medialize.de"
+ }
+ ],
+ "support": {
+ "irc": "irc://irc.freenode.org/smarty",
+ "issues": "https://github.com/smarty-php/smarty/issues",
+ "forum": "http://www.smarty.net/forums/"
+ },
+ "require": {
+ "php": ">=5.2"
+ },
+ "autoload": {
+ "classmap": [
+ "libs/Smarty.class.php",
+ "libs/SmartyBC.class.php",
+ "libs/sysplugins/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.1.x-dev"
+ }
+ }
+
+}
diff --git a/php-Smarty.spec b/php-Smarty.spec
index 0032f0a..95e89ab 100644
--- a/php-Smarty.spec
+++ b/php-Smarty.spec
@@ -8,14 +8,14 @@
# Please preserve changelog entries
#
-%global gh_commit 35480f10e7ce9b0fdaf23d3799d7b79463919b1e
+%global gh_commit ed2b7f1146cfda13df1eea8a5f707a1b771b6e7e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner smarty-php
%global gh_project smarty
Name: php-Smarty
Summary: Template/Presentation Framework for PHP
-Version: 3.1.29
+Version: 3.1.30
Release: 1%{?dist}
URL: http://www.smarty.net
@@ -30,7 +30,7 @@ BuildRequires: php-cli
# From composer.json
Requires: php(language) >= 5.2.0
-# From phpcompatinfo report for 3.1.28
+# From phpcompatinfo report for 3.1.30
Requires: php-ctype
Requires: php-date
Requires: php-mbstring
@@ -99,6 +99,9 @@ version_compare(Smarty::SMARTY_VERSION, "%{version}", "=") or exit(1);
%changelog
+* Mon Aug 8 2016 Remi Collet <remi@remirepo.net> - 3.1.30-1
+- update to 3.1.30
+
* Sat Dec 26 2015 Remi Collet <remi@fedoraproject.org> - 3.1.29-1
- update to 3.1.29