summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-08-27 15:30:31 +0200
committerRemi Collet <remi@remirepo.net>2018-08-27 15:30:31 +0200
commit20d9784e4e303c8e5ab7cab69080570c74cadfe1 (patch)
tree97bfd92626c6ae1a96945af5cf59224bd71928af
parentae981cfb685681ae9e61919651055e03b8dada48 (diff)
v3.1.32
-rw-r--r--composer.json6
-rw-r--r--php-Smarty.spec16
2 files changed, 7 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 2a1a43a..5064c8c 100644
--- a/composer.json
+++ b/composer.json
@@ -28,11 +28,7 @@
"php": ">=5.2"
},
"autoload": {
- "classmap": [
- "libs/Smarty.class.php",
- "libs/SmartyBC.class.php",
- "libs/sysplugins/"
- ]
+ "files": ["libs/bootstrap.php"]
},
"extra": {
"branch-alias": {
diff --git a/php-Smarty.spec b/php-Smarty.spec
index a554760..32dadcf 100644
--- a/php-Smarty.spec
+++ b/php-Smarty.spec
@@ -8,14 +8,14 @@
# Please preserve changelog entries
#
-%global gh_commit c7d42e4a327c402897dd587871434888fde1e7a9
+%global gh_commit ac9d4b587e5bf53381e21881820a9830765cb459
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner smarty-php
%global gh_project smarty
Name: php-Smarty
Summary: Template/Presentation Framework for PHP
-Version: 3.1.31
+Version: 3.1.32
Release: 1%{?dist}
URL: http://www.smarty.net
@@ -23,7 +23,6 @@ License: LGPLv2+
Group: Development/Libraries
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# For tests
BuildRequires: php-cli
@@ -57,6 +56,7 @@ Autoloader: %{_datadir}/php/Smarty/autoload.php
%setup -qn %{gh_project}-%{gh_commit}
ln -s bootstrap.php libs/autoload.php
+rm libs/*.lnk
%build
@@ -64,17 +64,11 @@ ln -s bootstrap.php libs/autoload.php
%install
-rm -rf %{buildroot}
-
# install smarty libs
install -d %{buildroot}%{_datadir}/php/Smarty
cp -a libs/* %{buildroot}%{_datadir}/php/Smarty/
-%clean
-rm -rf %{buildroot}
-
-
%check
: Test autoloader and version
php -r '
@@ -85,7 +79,6 @@ version_compare(Smarty::SMARTY_VERSION, "%{version}", "=") or exit(1);
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README *.txt
@@ -93,6 +86,9 @@ version_compare(Smarty::SMARTY_VERSION, "%{version}", "=") or exit(1);
%changelog
+* Mon Aug 27 2018 Remi Collet <remi@remirepo.net> - 3.1.32-1
+- update to 3.1.32
+
* Thu Dec 15 2016 Remi Collet <remi@remirepo.net> - 3.1.31-1
- update to 3.1.31