summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-08-31 08:04:57 +0200
committerRemi Collet <fedora@famillecollet.com>2014-08-31 08:04:57 +0200
commit41a0a163c32c209fd6f5583a1e675602fb4ad964 (patch)
tree4af232a5b91c29c92afc113d292a7d6beb07d9f6
parentae15b96865400cb4864325572dac7c44189ba84d (diff)
php-Raven: 0.9.1 (backport)
-rw-r--r--155.patch26
-rw-r--r--php-Raven.spec28
2 files changed, 15 insertions, 39 deletions
diff --git a/155.patch b/155.patch
deleted file mode 100644
index 31d1ca4..0000000
--- a/155.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From bffc917a976f4d2d945c6e631b38dc7e15557b63 Mon Sep 17 00:00:00 2001
-From: Shawn Iwinski <shawn.iwinski@gmail.com>
-Date: Sat, 7 Jun 2014 11:48:37 -0400
-Subject: [PATCH] Fix Raven_Tests_ClientTest::testGetAuthHeader
-
----
- test/Raven/Tests/ClientTest.php | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/test/Raven/Tests/ClientTest.php b/test/Raven/Tests/ClientTest.php
-index dbbc8dd..0a300a4 100644
---- a/test/Raven/Tests/ClientTest.php
-+++ b/test/Raven/Tests/ClientTest.php
-@@ -509,7 +509,8 @@ public function testGetAuthHeader() {
- $timestamp = '1234341324.340000';
-
- $expected = "Sentry sentry_timestamp={$timestamp}, sentry_client={$clientstring}, " .
-- "sentry_version=4, sentry_key=publickey, sentry_secret=secretkey";
-+ "sentry_version=" . Dummy_Raven_Client::PROTOCOL . ", " .
-+ "sentry_key=publickey, sentry_secret=secretkey";
-
- $this->assertEquals($expected, $client->get_auth_header($timestamp, 'raven-php/test', 'publickey', 'secretkey'));
- }
---
-1.9.3
-
diff --git a/php-Raven.spec b/php-Raven.spec
index e6d130b..59509b0 100644
--- a/php-Raven.spec
+++ b/php-Raven.spec
@@ -8,10 +8,11 @@
#
# Please preserve the changelog entries
#
+
%global github_owner getsentry
%global github_name raven-php
-%global github_version 0.9.0
-%global github_commit 1177f1c51110454f3a5bcca88aec3fa30e40e277
+%global github_version 0.9.1
+%global github_commit c6184b057d597f1449f30f2caec5d9ad07ddc4af
%global lib_name Raven
@@ -33,9 +34,6 @@ Group: Development/Libraries
License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{version}-%{github_commit}.tar.gz
-# Fix Raven_Tests_ClientTest::testGetAuthHeader
-# https://github.com/getsentry/raven-php/pull/155
-Patch0: %{url}/pull/155.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -43,7 +41,7 @@ BuildArch: noarch
# For tests: composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-phpunit-PHPUnit >= %{phpunit_min_ver}
-# For tests: phpcompatinfo (computed from version 0.9.0)
+# For tests: phpcompatinfo (computed from version 0.9.1)
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-mbstring
@@ -57,7 +55,7 @@ BuildRequires: php-zlib
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 0.9.0)
+# phpcompatinfo (computed from version 0.9.1)
Requires: php-curl
Requires: php-date
Requires: php-mbstring
@@ -77,8 +75,6 @@ Provides: php-composer(raven/raven) = %{version}
%prep
%setup -qn %{github_name}-%{github_commit}
-%patch0 -p1
-
# Update autoloader require in bin and test bootstrap
sed "/require.*Autoloader/s:.*:require_once 'Raven/Autoloader.php';:" \
-i bin/raven \
@@ -90,11 +86,11 @@ sed "/require.*Autoloader/s:.*:require_once 'Raven/Autoloader.php';:" \
%install
-mkdir -p %{buildroot}%{_datadir}/php
+mkdir -pm 0755 %{buildroot}%{_datadir}/php
cp -rp lib/* %{buildroot}%{_datadir}/php/
-mkdir -p %{buildroot}%{_bindir}
-install -pm 755 bin/raven %{buildroot}%{_bindir}/
+mkdir -pm 0755 %{buildroot}%{_bindir}
+install -pm 0755 bin/raven %{buildroot}%{_bindir}/
%check
@@ -110,12 +106,18 @@ sed 's/colors\s*=\s*"true"/colors="false"/' phpunit.xml.dist > phpunit.xml
%files
%defattr(-,root,root,-)
-%doc LICENSE AUTHORS *.rst composer.json
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc AUTHORS *.rst composer.json
%{_datadir}/php/%{lib_name}
%{_bindir}/raven
%changelog
+* Sun Aug 31 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 0.9.1-1
+- Updated to 0.9.1 (BZ #1134284)
+- %%license usage
+
* Sun Jun 8 2014 Remi Collet <remi@fedoraproject.org> 0.9.0-1
- backport 0.9.0 for remi repo