summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-04 08:38:43 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-04 08:38:43 +0100
commit95fa3771acdc0af3185acd068670071d5711e264 (patch)
tree6f33c9a0fb926dd8ee199279dd4f25c2ceaa06f5
parent97a3fa574a4df7c68d2ce6c3fae600fb8c6abb10 (diff)
php-Pimple: backport
-rw-r--r--Makefile10
-rw-r--r--php-Pimple.spec5
2 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-Pimple.spec b/php-Pimple.spec
index 2225eab..6f06c7c 100644
--- a/php-Pimple.spec
+++ b/php-Pimple.spec
@@ -12,6 +12,7 @@ URL: http://pimple.sensiolabs.org
Source0: https://github.com/fabpot/%{libname}/archive/v%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Test requires
BuildRequires: php-common >= %{php_min_ver}
@@ -59,6 +60,7 @@ cp -pr tests/* %{buildroot}%{_datadir}/tests/%{name}/
%files
+%defattr(-,root,root,-)
%doc LICENSE README.rst composer.json
%{_datadir}/php/%{libname}
%dir %{_datadir}/tests
@@ -66,6 +68,9 @@ cp -pr tests/* %{buildroot}%{_datadir}/tests/%{name}/
%changelog
+* Mon Dec 3 2012 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
+- backport for remi repo.
+
* Sun Dec 2 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0.0-2
- Removed "5.3" from summary and description
- Changed update tests' require path to use standard PHP include_path