summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-25 19:36:02 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-25 19:36:02 +0100
commit79ca29f993e310cf9f39649fb12658baf26dd526 (patch)
treebc1a2718cc88656077c4c51a3d833677b6fa7dd5 /Makefile
parent63fb5e939c5143a1c0704cedfcec416f369c5cd4 (diff)
php-PhpOption: backport
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed