summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-19 17:49:39 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-19 17:49:39 +0100
commita0e042ddf337cec4ed50c679fc2b22e464e16605 (patch)
tree6968515a18055745df91849bae639978f07e0c8e
parent395f2fc7fc7e4010b46e5b7219d1633b5d251313 (diff)
php-PhpCollection: backport for remi repo
-rw-r--r--Makefile10
-rw-r--r--php-PhpCollection.spec5
2 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-PhpCollection.spec b/php-PhpCollection.spec
index 8d00708..4b20e08 100644
--- a/php-PhpCollection.spec
+++ b/php-PhpCollection.spec
@@ -23,6 +23,7 @@ URL: http://jmsyst.com/libs/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-strip.sh
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Test build requires
BuildRequires: php(language) >= %{php_min_ver}
@@ -99,11 +100,15 @@ cp -rp src/%{lib_name} %{buildroot}%{_datadir}/php/
%files
+%defattr(-,root,root,-)
%doc LICENSE README.md composer.json
%{_datadir}/php/%{lib_name}
%changelog
+* Tue Mar 19 2013 Remi Collet <remi@fedoraproject.org> 0.2.0-2
+- backport 0.2.0 for remi repo.
+
* Mon Mar 18 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 0.2.0-2
- Added %%{name}-strip.sh as Source1