summaryrefslogtreecommitdiffstats
path: root/php-PHPParser.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-20 17:26:10 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-20 17:26:10 +0200
commitd6c518435b666d46ee0f8f2db57b67aa2f3d2ddd (patch)
tree9bd83a7845f497f24e26cb62a70bb78175387ffb /php-PHPParser.spec
parent740010e39e2d29511ed2f88594d7a488ed1f7f0d (diff)
php-PHPParser: 1.4.1
Diffstat (limited to 'php-PHPParser.spec')
-rw-r--r--php-PHPParser.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/php-PHPParser.spec b/php-PHPParser.spec
index 63be0e6..b569c46 100644
--- a/php-PHPParser.spec
+++ b/php-PHPParser.spec
@@ -11,8 +11,8 @@
%global github_owner nikic
%global github_name PHP-Parser
-%global github_version 1.4.0
-%global github_commit 196f177cfefa0f1f7166c0a05d8255889be12418
+%global github_version 1.4.1
+%global github_commit f78af2c9c86107aa1a34cd1dbb5bbe9eeb0d9f51
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global lib_name PhpParser
@@ -41,7 +41,7 @@ BuildArch: noarch
# For tests
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: %{_bindir}/phpunit
-# For tests: phpcompatinfo (computed from version 1.4.0)
+# For tests: phpcompatinfo (computed from version 1.4.1)
BuildRequires: php-filter
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -52,12 +52,11 @@ BuildRequires: php-xmlwriter
# composer.json
Requires: php(language) >= %{php_min_ver}
Requires: php-tokenizer
-# phpcompatinfo (computed from version 1.4.0)
+# phpcompatinfo (computed from version 1.4.1)
Requires: php-cli
Requires: php-filter
Requires: php-pcre
Requires: php-spl
-Requires: php-tokenizer
Requires: php-xmlreader
Requires: php-xmlwriter
@@ -69,6 +68,9 @@ Provides: php-composer(nikic/php-parser) = %{version}
%description
A PHP parser written in PHP to simplify static analysis and code manipulation.
+To use this library, you just have to add, in your project:
+ require_once '%{_datadir}/php/%{lib_name}/autoload.php';
+
%prep
%setup -q -n %{github_name}-%{github_short}
@@ -110,6 +112,9 @@ install -Dpm 755 bin/php-parse.php %{buildroot}%{_bindir}/php-parse
%changelog
+* Sun Sep 20 2015 Remi Collet <remi@fedoraproject.org> - 1.4.1-1
+- update to 1.4.1
+
* Sun Aug 9 2015 Remi Collet <remi@fedoraproject.org> - 1.4.0-1
- update to 1.4.0
- add a simple autoload.php