summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-08 17:05:58 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-08 17:05:58 +0100
commit6ae69f53c5604a8e99cad4ab2c0b89aa3e251fcf (patch)
treea0201a84601a750f525e754c4fdcf59a1744f488
parentb3d03d6927c4c716aed1b5c2aa3c44a2bc461bef (diff)
php-PHPParser: backport
-rw-r--r--Makefile4
-rw-r--r--php-PHPParser.spec18
2 files changed, 12 insertions, 10 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-PHPParser.spec b/php-PHPParser.spec
index 71c0b43..dcb2e59 100644
--- a/php-PHPParser.spec
+++ b/php-PHPParser.spec
@@ -13,36 +13,29 @@ License: BSD
URL: https://github.com/nikic/%{github_name}
Source0: %{url}/archive/v%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Test build requires
-BuildRequires: php-common >= %{php_min_ver}
+BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
# Test build requires: phpci
BuildRequires: php-ctype
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-tokenizer
-%if 0%{?fedora}
BuildRequires: php-filter
BuildRequires: php-xmlreader
BuildRequires: php-xmlwriter
-%else
-BuildRequires: php-xml
-%endif
-Requires: php-common >= %{php_min_ver}
+Requires: php(language) >= %{php_min_ver}
# phpci requires
Requires: php-ctype
Requires: php-pcre
Requires: php-spl
Requires: php-tokenizer
-%if 0%{?fedora}
Requires: php-filter
Requires: php-xmlreader
Requires: php-xmlwriter
-%else
-Requires: php-xml
-%endif
%description
A PHP parser written in PHP to simplify static analysis and code manipulation.
@@ -97,15 +90,20 @@ cp -rp test/* %{buildroot}%{_datadir}/tests/%{name}/
%files
+%defattr(-,root,root,-)
%doc LICENSE *.md doc grammar composer.json
%{_datadir}/php/%{lib_name}
%files test
+%defattr(-,root,root,-)
%dir %{_datadir}/tests
%{_datadir}/tests/%{name}
%changelog
+* Tue Jan 8 2013 Remi Collet <remi@fedoraproject.org> 0.9.3-2
+- backport 0.9.3 for remi repo.
+
* Mon Dec 31 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 0.9.3-2
- Added php_min_ver
- Fixed requires for php_min_ver and non-Fedora