summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-09-26 13:01:42 +0200
committerRemi Collet <fedora@famillecollet.com>2014-09-26 13:01:42 +0200
commitfeb26b42551a5b89324fc403d397bc3c3e88b51e (patch)
tree543a40854d9709a153df57582a0ceeeaa81b64bf
parent0510b87f003b5462d12d1bfec771082d13da3450 (diff)
php-PHPMailer: 5.2.9
-rw-r--r--PHPMailer-path.patch10
-rw-r--r--php-PHPMailer.spec9
2 files changed, 11 insertions, 8 deletions
diff --git a/PHPMailer-path.patch b/PHPMailer-path.patch
index 8710029..4aac9e7 100644
--- a/PHPMailer-path.patch
+++ b/PHPMailer-path.patch
@@ -1,7 +1,7 @@
diff -up ./class.phpmailer.php.rpm ./class.phpmailer.php
---- ./class.phpmailer.php.rpm 2014-08-11 16:53:52.616058389 +0200
-+++ ./class.phpmailer.php 2014-08-11 17:14:27.562681744 +0200
-@@ -1170,6 +1170,7 @@ class PHPMailer
+--- ./class.phpmailer.php.rpm 2014-09-25 18:36:22.000000000 +0200
++++ ./class.phpmailer.php 2014-09-26 12:58:08.790951530 +0200
+@@ -1191,6 +1191,7 @@ class PHPMailer
public function getSMTPInstance()
{
if (!is_object($this->smtp)) {
@@ -9,10 +9,10 @@ diff -up ./class.phpmailer.php.rpm ./class.phpmailer.php
$this->smtp = new SMTP;
}
return $this->smtp;
-@@ -1394,7 +1395,7 @@ class PHPMailer
+@@ -1415,7 +1416,7 @@ class PHPMailer
);
if (empty($lang_path)) {
- //Calculate an absolute path so it can work if CWD is not here
+ // Calculate an absolute path so it can work if CWD is not here
- $lang_path = dirname(__FILE__). DIRECTORY_SEPARATOR . 'language'. DIRECTORY_SEPARATOR;
+ $lang_path = '/usr/share/PHPMailer/language/';
}
diff --git a/php-PHPMailer.spec b/php-PHPMailer.spec
index 22477a8..f9f599b 100644
--- a/php-PHPMailer.spec
+++ b/php-PHPMailer.spec
@@ -1,12 +1,12 @@
-%global github_user Synchro
+%global github_user PHPMailer
%global github_app PHPMailer
-%global github_tag d3802c597bff8f6c2ccfa3eab2a511aa01b8d68f
+%global github_tag b56c9b684923153112e5b72d23182b469aa44070
%global arch_name %{github_app}-%{github_tag}
Name: php-PHPMailer
Summary: PHP email transport class with a lot of features
-Version: 5.2.8
+Version: 5.2.9
Release: 1%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
@@ -123,6 +123,9 @@ rm -rf "${RPM_BUILD_ROOT}"
%changelog
+* Fri Sep 26 2014 Remi Collet <remi@fedoraproject.org> - 5.2.9-1
+- update to 5.2.9
+
* Mon Aug 11 2014 Remi Collet <remi@fedoraproject.org> - 5.2.8-1
- update to 5.2.8
- provide php-composer(phpmailer/phpmailer)