summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-12-09 16:02:29 +0100
committerRemi Collet <fedora@famillecollet.com>2016-12-09 16:02:29 +0100
commitec66b4c1b91ea3e5b8945ed723301253285bbd06 (patch)
treeb389862dd539030b529ac4a4769b93d607b22309
parent9b872d7b3447b0f927eb4a52c7f0b7c11a0a7c5b (diff)
php-PHPMailer: 5.2.17
-rw-r--r--PHPMailer-path.patch12
-rw-r--r--php-PHPMailer.spec14
2 files changed, 14 insertions, 12 deletions
diff --git a/PHPMailer-path.patch b/PHPMailer-path.patch
index 4aac9e7..59a0ca5 100644
--- a/PHPMailer-path.patch
+++ b/PHPMailer-path.patch
@@ -1,7 +1,7 @@
diff -up ./class.phpmailer.php.rpm ./class.phpmailer.php
---- ./class.phpmailer.php.rpm 2014-09-25 18:36:22.000000000 +0200
-+++ ./class.phpmailer.php 2014-09-26 12:58:08.790951530 +0200
-@@ -1191,6 +1191,7 @@ class PHPMailer
+--- ./class.phpmailer.php.rpm 2016-12-09 11:03:48.000000000 +0100
++++ ./class.phpmailer.php 2016-12-09 15:03:58.489947280 +0100
+@@ -1475,6 +1475,7 @@ class PHPMailer
public function getSMTPInstance()
{
if (!is_object($this->smtp)) {
@@ -9,12 +9,12 @@ diff -up ./class.phpmailer.php.rpm ./class.phpmailer.php
$this->smtp = new SMTP;
}
return $this->smtp;
-@@ -1415,7 +1416,7 @@ class PHPMailer
+@@ -1730,7 +1731,7 @@ class PHPMailer
);
if (empty($lang_path)) {
// Calculate an absolute path so it can work if CWD is not here
- $lang_path = dirname(__FILE__). DIRECTORY_SEPARATOR . 'language'. DIRECTORY_SEPARATOR;
+ $lang_path = '/usr/share/PHPMailer/language/';
}
- $foundlang = true;
- $lang_file = $lang_path . 'phpmailer.lang-' . $langcode . '.php';
+ //Validate $langcode
+ if (!preg_match('/^[a-z]{2}(?:_[a-zA-Z]{2})?$/', $langcode)) {
diff --git a/php-PHPMailer.spec b/php-PHPMailer.spec
index 21d321a..2fdbd9e 100644
--- a/php-PHPMailer.spec
+++ b/php-PHPMailer.spec
@@ -9,15 +9,15 @@
#
%global github_user PHPMailer
%global github_app PHPMailer
-%global github_tag 1d85f9ef3ecfc42bbc4f3c70d5e37ca9a65f629a
+%global github_tag 208913c6042967ba404f4bfa0819bf5bef79dbec
%global github_short %(c=%{github_tag}; echo ${c:0:7})
%global arch_name %{github_app}-%{github_tag}
Name: php-PHPMailer
Summary: PHP email transport class with a lot of features
-Version: 5.2.16
-Release: 2%{?dist}
+Version: 5.2.17
+Release: 1%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://phpmailer.worxware.com/
@@ -80,8 +80,6 @@ Full Featured Email Transfer Class for PHP. PHPMailer features:
%patch0 -p1 -b .rpm
-rm docs/generatedocs.sh
-
#-------------------------------------------------------------------------------
%build
@@ -146,14 +144,18 @@ rm -rf "${RPM_BUILD_ROOT}"
%defattr(-, root, root, -)
%{!?_licensedir:%global license %%doc}
%license LICENSE
-%doc docs/* README.md changelog.md
%doc examples
+%doc composer.json
%{_datadir}/php/PHPMailer
%dir %{_datadir}/PHPMailer
%dir %{_datadir}/PHPMailer/language
%changelog
+* Fri Dec 9 2016 Remi Collet <remi@fedoraproject.org> - 5.2.17-1
+- update to 5.2.17
+- drop documentation removed by upstream
+
* Sat Jun 25 2016 Johan Cwiklinski <johan AT x-tnd DOT be> - 5.2.16-2
- add a check on version