summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-27 16:01:11 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-27 16:01:11 +0100
commit273ff4b35519ae01851f98a16d0daeaf9ea96eb2 (patch)
tree1d074ce4773ca2482987b495ff2af5ce1f5996ce
parentf904a3f15456b29edc30d8320ce2723f88be38c2 (diff)
php-PHPMailer: 5.2.4
-rw-r--r--PHPMailer-5.2.1-php53.patch105
-rw-r--r--PHPMailer_5.2.1.tgzbin192045 -> 0 bytes
-rw-r--r--php-PHPMailer.spec66
3 files changed, 32 insertions, 139 deletions
diff --git a/PHPMailer-5.2.1-php53.patch b/PHPMailer-5.2.1-php53.patch
deleted file mode 100644
index 2a0d339..0000000
--- a/PHPMailer-5.2.1-php53.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-diff -up PHPMailer_5.2.1/docs/use_gmail.txt.orig PHPMailer_5.2.1/docs/use_gmail.txt
---- PHPMailer_5.2.1/docs/use_gmail.txt.orig 2012-03-20 18:59:04.665629722 +0100
-+++ PHPMailer_5.2.1/docs/use_gmail.txt 2012-03-20 19:00:29.325624132 +0100
-@@ -8,7 +8,7 @@ include("class.smtp.php"); // note, this
- $mail = new PHPMailer();
-
- $body = $mail->getFile('contents.html');
--$body = eregi_replace("[\]",'',$body);
-+$body = preg_replace("[\]",'',$body);
-
- $mail->IsSMTP();
- $mail->SMTPAuth = true; // enable SMTP authentication
-diff -up PHPMailer_5.2.1/examples/test_mail_basic.php.orig PHPMailer_5.2.1/examples/test_mail_basic.php
---- PHPMailer_5.2.1/examples/test_mail_basic.php.orig 2012-03-20 18:59:33.545627815 +0100
-+++ PHPMailer_5.2.1/examples/test_mail_basic.php 2012-03-20 19:00:29.341624132 +0100
-@@ -11,7 +11,7 @@ require_once('../class.phpmailer.php');
- $mail = new PHPMailer(); // defaults to using php "mail()"
-
- $body = file_get_contents('contents.html');
--$body = eregi_replace("[\]",'',$body);
-+$body = preg_replace("[\]",'',$body);
-
- $mail->AddReplyTo("name@yourdomain.com","First Last");
-
-diff -up PHPMailer_5.2.1/examples/test_pop_before_smtp_basic.php.orig PHPMailer_5.2.1/examples/test_pop_before_smtp_basic.php
---- PHPMailer_5.2.1/examples/test_pop_before_smtp_basic.php.orig 2012-03-20 18:59:12.433629208 +0100
-+++ PHPMailer_5.2.1/examples/test_pop_before_smtp_basic.php 2012-03-20 19:00:29.334624132 +0100
-@@ -14,7 +14,7 @@ $pop->Authorise('pop3.yourdomain.com', 1
- $mail = new PHPMailer();
-
- $body = file_get_contents('contents.html');
--$body = eregi_replace("[\]",'',$body);
-+$body = preg_replace("[\]",'',$body);
-
- $mail->IsSMTP();
- $mail->SMTPDebug = 2;
-diff -up PHPMailer_5.2.1/examples/test_sendmail_basic.php.orig PHPMailer_5.2.1/examples/test_sendmail_basic.php
---- PHPMailer_5.2.1/examples/test_sendmail_basic.php.orig 2012-03-20 18:59:26.719628266 +0100
-+++ PHPMailer_5.2.1/examples/test_sendmail_basic.php 2012-03-20 19:00:29.341624132 +0100
-@@ -13,7 +13,7 @@ $mail = new PHPMailer(); //
- $mail->IsSendmail(); // telling the class to use SendMail transport
-
- $body = file_get_contents('contents.html');
--$body = eregi_replace("[\]",'',$body);
-+$body = preg_replace("[\]",'',$body);
-
- $mail->AddReplyTo("name@yourdomain.com","First Last");
-
-diff -up PHPMailer_5.2.1/examples/test_smtp_basic_no_auth.php.orig PHPMailer_5.2.1/examples/test_smtp_basic_no_auth.php
---- PHPMailer_5.2.1/examples/test_smtp_basic_no_auth.php.orig 2012-03-20 18:59:48.193626848 +0100
-+++ PHPMailer_5.2.1/examples/test_smtp_basic_no_auth.php 2012-03-20 19:00:29.342624132 +0100
-@@ -17,7 +17,7 @@ require_once('../class.phpmailer.php');
- $mail = new PHPMailer();
-
- $body = file_get_contents('contents.html');
--$body = eregi_replace("[\]",'',$body);
-+$body = preg_replace("[\]",'',$body);
-
- $mail->IsSMTP(); // telling the class to use SMTP
- $mail->Host = "mail.yourdomain.com"; // SMTP server
-diff -up PHPMailer_5.2.1/examples/test_smtp_basic.php.orig PHPMailer_5.2.1/examples/test_smtp_basic.php
---- PHPMailer_5.2.1/examples/test_smtp_basic.php.orig 2012-03-20 18:59:41.282627305 +0100
-+++ PHPMailer_5.2.1/examples/test_smtp_basic.php 2012-03-20 19:00:29.342624132 +0100
-@@ -17,7 +17,7 @@ require_once('../class.phpmailer.php');
- $mail = new PHPMailer();
-
- $body = file_get_contents('contents.html');
--$body = eregi_replace("[\]",'',$body);
-+$body = preg_replace("[\]",'',$body);
-
- $mail->IsSMTP(); // telling the class to use SMTP
- $mail->Host = "mail.yourdomain.com"; // SMTP server
-diff -up PHPMailer_5.2.1/examples/test_smtp_gmail_basic.php.orig PHPMailer_5.2.1/examples/test_smtp_gmail_basic.php
---- PHPMailer_5.2.1/examples/test_smtp_gmail_basic.php.orig 2012-03-20 18:59:19.688628730 +0100
-+++ PHPMailer_5.2.1/examples/test_smtp_gmail_basic.php 2012-03-20 19:00:29.341624132 +0100
-@@ -17,7 +17,7 @@ require_once('../class.phpmailer.php');
- $mail = new PHPMailer();
-
- $body = file_get_contents('contents.html');
--$body = eregi_replace("[\]",'',$body);
-+$body = preg_replace("[\]",'',$body);
-
- $mail->IsSMTP(); // telling the class to use SMTP
- $mail->Host = "mail.yourdomain.com"; // SMTP server
-diff -up PHPMailer_5.2.1/test_script/index.php.orig PHPMailer_5.2.1/test_script/index.php
---- PHPMailer_5.2.1/test_script/index.php.orig 2012-03-20 19:00:03.270625851 +0100
-+++ PHPMailer_5.2.1/test_script/index.php 2012-03-20 19:00:29.343624132 +0100
-@@ -51,7 +51,7 @@ if ( $_POST['submit'] == "Submit" ) {
-
- if ( $_POST['Message'] == '' ) {
- $body = $mail->getFile('contents.html');
-- $body = eregi_replace("[\]",'',$body);
-+ $body = preg_replace("[\]",'',$body);
- } else {
- $body = $_POST['Message'];
- }
-@@ -196,7 +196,7 @@ $mail = new PHPMailer();
- <?php
- if ( $_POST['Message'] == '' ) {
- echo '$body = $mail->getFile(\'contents.html\');' . "\n";
-- echo '$body = eregi_replace("[\]",\'\',$body);' . "\n";
-+ echo '$body = preg_replace("[\]",\'\',$body);' . "\n";
- } else {
- echo '$body = ' . $_POST['Message'] . "\n";
- }
diff --git a/PHPMailer_5.2.1.tgz b/PHPMailer_5.2.1.tgz
deleted file mode 100644
index bdcdba1..0000000
--- a/PHPMailer_5.2.1.tgz
+++ /dev/null
Binary files differ
diff --git a/php-PHPMailer.spec b/php-PHPMailer.spec
index 891c6f0..f7df75e 100644
--- a/php-PHPMailer.spec
+++ b/php-PHPMailer.spec
@@ -1,16 +1,16 @@
-Name: php-PHPMailer
-Summary: PHP email transport class with a lot of features
-Version: 5.2.2
-Release: 1%{?dist}
-License: LGPLv2+
-Group: System Environment/Libraries
-Source0: http://phpmailer.apache-extras.org.codespot.com/files/PHPMailer_%{version}.tgz
-URL: http://phpmailer.worxware.com/
+Name: php-PHPMailer
+Summary: PHP email transport class with a lot of features
+Version: 5.2.4
+Release: 1%{?dist}
+License: LGPLv2+
+Group: System Environment/Libraries
+Source0: http://phpmailer.apache-extras.org.codespot.com/files/PHPMailer_%{version}.tgz
+URL: http://phpmailer.worxware.com/
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-Buildarch: noarch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+Buildarch: noarch
-Requires: php-mbstring
+Requires: php-mbstring
%description
@@ -58,8 +58,8 @@ lang-go.js"
for file in $NONUTF
do
- iconv -f iso-8859-1 -t utf-8 $file > $file.utf
- mv $file.utf $file
+ iconv -f iso-8859-1 -t utf-8 $file > $file.utf
+ mv $file.utf $file
done
popd
@@ -68,15 +68,14 @@ popd
%build
#-------------------------------------------------------------------------------
-# Make sure all file lines are \n terminated.
+# Make sure all file lines are \n terminated.
find . -type f -exec sed -i -e 's/[\r\t ]*$//' '{}' ';'
-# Change default language path.
+# Change default language path.
-sed -i -e \
- "/function SetLanguage/s#'language/'#'%{_datadir}/PHPMailer/language/'#" \
- class.phpmailer.php
+sed -e "/function SetLanguage/s#'language/'#'%{_datadir}/PHPMailer/language/'#" \
+ -i class.phpmailer.php
#-------------------------------------------------------------------------------
@@ -85,32 +84,29 @@ sed -i -e \
rm -rf "${RPM_BUILD_ROOT}"
-# install directories.
+# install directories.
install -p -d -m 755 "${RPM_BUILD_ROOT}/%{_datadir}/php/PHPMailer/"
install -p -d -m 755 "${RPM_BUILD_ROOT}/%{_datadir}/PHPMailer/language/"
-# Install class files.
+# Install class files.
-install -p -m 644 \
- class.phpmailer.php "${RPM_BUILD_ROOT}/%{_datadir}/php/PHPMailer/"
-install -p -m 644 class.smtp.php "${RPM_BUILD_ROOT}/%{_datadir}/php/PHPMailer/"
-install -p -m 644 class.pop3.php "${RPM_BUILD_ROOT}/%{_datadir}/php/PHPMailer/"
+install -p -m 644 class.phpmailer.php ${RPM_BUILD_ROOT}/%{_datadir}/php/PHPMailer/
+install -p -m 644 class.smtp.php ${RPM_BUILD_ROOT}/%{_datadir}/php/PHPMailer/
+install -p -m 644 class.pop3.php ${RPM_BUILD_ROOT}/%{_datadir}/php/PHPMailer/
+# Install language files (these are not gettextized).
-# Install language files (these are not gettextized).
+install -p -m 644 language/*.php ${RPM_BUILD_ROOT}/%{_datadir}/PHPMailer/language
-install -p -m 644 language/*.php \
- "${RPM_BUILD_ROOT}/%{_datadir}/PHPMailer/language"
-
-# Tag language files.
+# Tag language files.
(
- cd "${RPM_BUILD_ROOT}"
- find ".%{_datadir}/PHPMailer/language" -name "phpmailer.lang-*.php" |
- sed -e 's/^\.//' \
- -e 's#^.*/phpmailer\.lang-\(.*\)\.php$#%lang(\1) &#'
+ cd "${RPM_BUILD_ROOT}"
+ find ".%{_datadir}/PHPMailer/language" -name "phpmailer.lang-*.php" |
+ sed -e 's/^\.//' \
+ -e 's#^.*/phpmailer\.lang-\(.*\)\.php$#%lang(\1) &#'
) > files.list
@@ -124,7 +120,6 @@ rm -rf "${RPM_BUILD_ROOT}"
#-------------------------------------------------------------------------------
%files -f files.list
#-------------------------------------------------------------------------------
-
%defattr(-, root, root, -)
%doc docs/* README LICENSE changelog.txt
%doc examples
@@ -134,6 +129,9 @@ rm -rf "${RPM_BUILD_ROOT}"
%changelog
+* Wed Mar 27 2013 Remi Collet <RPMS@FamilleCollet.com> - 5.2.4-1
+- Update to 5.2.4
+
* Mon Dec 24 2012 Remi Collet <RPMS@FamilleCollet.com> - 5.2.2-1
- Update to 5.2.2, rebuild for remi repository