summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-25 18:56:15 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-25 18:56:15 +0100
commit50b2464ed2408b92e07fa9cef1799fa5d50385c4 (patch)
tree92d44a8943fbf4a68da456a8f127a7e18febcbe7 /Makefile
parentad5e0ac8ce9f4d0b71811af3ccfa6c10c2c0bc21 (diff)
php-Metadata: backport
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed