summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-19 17:55:27 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-19 17:55:27 +0100
commitffec025b1b448e93b69ab2ca1ff74a95301e6c1b (patch)
tree8e0d40b6f1893f3ad246620d5f79d91551e29473
parenta90b064525619dd4bb9c4cd99aea9467effe8fbf (diff)
php-JMSParser: backport for remi repo
-rw-r--r--Makefile10
-rw-r--r--php-JMSParser.spec5
2 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-JMSParser.spec b/php-JMSParser.spec
index 76af1c0..69f4e5e 100644
--- a/php-JMSParser.spec
+++ b/php-JMSParser.spec
@@ -21,6 +21,7 @@ URL: http://jmsyst.com/libs/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-strip.sh
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Test build requires
BuildRequires: php(language) >= %{php_min_ver}
@@ -77,12 +78,16 @@ cp -rp src/JMS/Parser %{buildroot}%{_datadir}/php/JMS/
%files
+%defattr(-,root,root,-)
%doc LICENSE README.md composer.json
%dir %{_datadir}/php/JMS
%{_datadir}/php/JMS/Parser
%changelog
+* Tue Mar 19 2013 Remi Collet <remi@fedoraproject.org> 1.0.0-3
+- backport 1.0.0 for remi repo.
+
* Mon Mar 18 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.0.0-3
- Added %%{name}-strip.sh as Source1