summaryrefslogtreecommitdiffstats
path: root/php-Faker.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-Faker.spec')
-rw-r--r--php-Faker.spec38
1 files changed, 18 insertions, 20 deletions
diff --git a/php-Faker.spec b/php-Faker.spec
index c98163f..d9b5fc5 100644
--- a/php-Faker.spec
+++ b/php-Faker.spec
@@ -12,13 +12,13 @@
%global github_owner fzaninotto
%global github_name Faker
-%global github_version 1.7.1
-%global github_commit d3ed4cc37051c1ca52d22d76b437d14809fc7e0d
+%global github_version 1.8.0
+%global github_commit f72816b43e74063c8b10357394b6bba8cb1c10de
%global composer_vendor fzaninotto
%global composer_project faker
-# "php": "^5.3.3|^7.0"
+# "php": "^5.3.3 || ^7.0"
%global php_min_ver 5.3.3
# Build using "--without tests" to disable tests
@@ -28,23 +28,16 @@
Name: php-%{github_name}
Version: %{github_version}
-Release: 7%{?dist}
+Release: 1%{?dist}
Summary: A PHP library that generates fake data
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
-# https://github.com/fzaninotto/Faker/pull/1348
-# https://patch-diff.githubusercontent.com/raw/fzaninotto/Faker/pull/1348.patch
-Patch0: %{name}-github-pull-request-1348.patch
-# https://github.com/fzaninotto/Faker/pull/1365
-# https://patch-diff.githubusercontent.com/raw/fzaninotto/Faker/pull/1365.patch
-Patch1: %{name}-github-pull-request-1365.patch
-
# remirepo:3
# For test build on all available arch
-#global debug_package %{nil}
+#global debug_package %%{nil}
#global __debug_install_post /bin/true
BuildArch: noarch
# Tests
@@ -53,12 +46,14 @@ BuildArch: noarch
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-intl
-## phpcompatinfo (computed from version 1.6.0)
+## phpcompatinfo (computed from version 1.8.0)
BuildRequires: php-ctype
BuildRequires: php-curl
BuildRequires: php-date
BuildRequires: php-dom
+BuildRequires: php-filter
BuildRequires: php-hash
+BuildRequires: php-iconv
BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
@@ -70,11 +65,12 @@ BuildRequires: php-fedora-autoloader-devel
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.6.0)
+# phpcompatinfo (computed from version 1.8.0)
Requires: php-curl
Requires: php-date
Requires: php-dom
Requires: php-hash
+Requires: php-iconv
Requires: php-json
Requires: php-mbstring
Requires: php-pcre
@@ -84,7 +80,7 @@ Requires: php-spl
Requires: php-composer(fedora/autoloader)
# php-{COMPOSER_VENDOR}-{COMPOSER_PROJECT}
-Provides: php-%{composer_vendor}-%{composer_project} = %{version}-%{release}
+Provides: php-%{composer_vendor}-%{composer_project} = %{version}-%{release}
# Composer
Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
@@ -110,8 +106,6 @@ Optional:
%prep
%setup -qn %{github_name}-%{github_commit}
-%patch0 -p1
-%patch1 -p1
%if 0%{?el6}
# For old PHPUnit
@@ -127,10 +121,8 @@ cat <<'AUTOLOAD' | tee src/Faker/autoload.php
* Autoloader for %{name} and its' dependencies
* (created by %{name}-%{version}-%{release}).
*/
-
require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Faker\\', __DIR__);
-
AUTOLOAD
@@ -149,7 +141,10 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{phpdir}/Faker/autoload.php';
+
\Fedora\Autoloader\Autoload::addPsr4('Faker\\Test\\', dirname(__DIR__).'/test/Faker');
+
+class_alias('PHPUnit_Framework_TestCase', 'PHPUnit\\Framework\\TestCase');
EOF
# Skip flakey test that randomly fails even after patch from
@@ -161,7 +156,7 @@ sed 's/function testFixedSeedWithMaximumTimestamp/function SKIP_testFixedSeedWit
-i test/Faker/Provider/DateTimeTest.php
ret=0
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php70 php71 php72 php73 php74; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
@@ -181,6 +176,9 @@ exit $ret
%changelog
+* Sun Jun 16 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.8.0-1
+- Update to 1.8.0 (RHBZ #1481901)
+
* Thu Feb 14 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.7.1-7
- Fix FTBFS by skipping flakey test (RHBZ #1605437 / RHBZ #1675661)
- Reference patches locally