summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-Faker.spec7
1 files changed, 7 insertions, 0 deletions
diff --git a/php-Faker.spec b/php-Faker.spec
index d71f8f4..cd488f6 100644
--- a/php-Faker.spec
+++ b/php-Faker.spec
@@ -154,6 +154,13 @@ EOF
sed 's/function testFixedSeedWithMaximumTimestamp/function SKIP_testFixedSeedWithMaximumTimestamp/' \
-i test/Faker/Provider/DateTimeTest.php
+if php -r 'exit(PHP_INT_SIZE<8 ? 0 : 1);'
+then
+ # strtotime(): Epoch doesn't fit in a PHP integer
+ rm test/Faker/Provider/ro_RO/PersonTest.php
+ rm test/Faker/Provider/fi_FI/PersonTest.php
+fi
+
ret=0
for cmd in php php73 php74 php80; do
if which $cmd; then