summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-19 07:24:08 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-19 07:24:08 +0100
commitf2282557822422bf40c080d68ff84f486ffb2254 (patch)
treeda4809e8c7b2f76ea1e2a772e7a435baaf95b89f
parentae9e34ccc27ff902a678d37cf491f02619ab54b8 (diff)
php-Faker: backport
-rw-r--r--Makefile10
-rw-r--r--php-Faker.spec9
2 files changed, 17 insertions, 2 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-Faker.spec b/php-Faker.spec
index bd93b72..043e899 100644
--- a/php-Faker.spec
+++ b/php-Faker.spec
@@ -11,9 +11,10 @@ License: MIT
URL: https://github.com/fzaninotto/%{libname}
Source0: %{url}/archive/v%{version}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Test build requires
-BuildRequires: php-common >= %{php_min_ver}
+BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
# Test build requires: phpci
Requires: php-date
@@ -22,7 +23,7 @@ Requires: php-pcre
Requires: php-reflection
Requires: php-spl
-Requires: php-common >= %{php_min_ver}
+Requires: php(language) >= %{php_min_ver}
Requires: php-pear(pear.doctrine-project.org/DoctrineCommon)
# phpci requires
Requires: php-date
@@ -64,11 +65,15 @@ cp -rp src/%{libname} %{buildroot}%{_datadir}/php/
%files
+%defattr(-,root,root,-)
%doc LICENSE CHANGELOG readme.md composer.json
%{_datadir}/php/%{libname}
%changelog
+* Wed Dec 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.1.0-2
+- backport 1.1.0 for remi repo.
+
* Sun Dec 9 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.0-2
- Added php-pear(pear.doctrine-project.org/DoctrineCommon) require