summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-06-12 07:43:58 +0200
committerRemi Collet <fedora@famillecollet.com>2013-06-12 07:43:58 +0200
commite8ad94da581118a7c44b5cc8f1e73adbf9b6910e (patch)
treebd46ab2293227fd1d47d608c25650dedc1c712a4
parentc66cb2d1accc010c5b629fb5b959473eddb5c7dd (diff)
php-Faker: 1.2.0 (backport)
-rw-r--r--php-Faker.spec51
1 files changed, 37 insertions, 14 deletions
diff --git a/php-Faker.spec b/php-Faker.spec
index d4cbdf8..0e3dc70 100644
--- a/php-Faker.spec
+++ b/php-Faker.spec
@@ -1,15 +1,19 @@
-%global libname Faker
-%global php_min_ver 5.3.3
+%global github_owner fzaninotto
+%global github_name Faker
+%global github_version 1.2.0
+%global github_commit 4ad4bc4b5c8d3c0f3cf55d2fedc2f65b313ec62f
-Name: php-%{libname}
-Version: 1.1.0
-Release: 2%{?dist}
+%global php_min_ver 5.3.3
+
+Name: php-%{github_name}
+Version: %{github_version}
+Release: 1%{?dist}
Summary: A PHP library that generates fake data
Group: Development/Libraries
License: MIT
-URL: https://github.com/fzaninotto/%{libname}
-Source0: %{url}/archive/v%{version}.tar.gz
+URL: https://github.com/%{github_owner}/%{github_name}
+Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -28,6 +32,7 @@ Requires: php-pear(pear.doctrine-project.org/DoctrineCommon)
# phpci requires
Requires: php-date
Requires: php-hash
+Requires: php-mbstring
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
@@ -44,11 +49,17 @@ Faker is heavily inspired by Perl's Data::Faker
%prep
-%setup -q -n %{libname}-%{version}
+%setup -q -n %{github_name}-%{github_commit}
-# Remove executable bit from all PHP files
-# https://github.com/fzaninotto/Faker/pull/84
-find . -name '*.php' | xargs chmod a-x
+# Create tests' bootstrap
+( cat <<'AUTOLOAD'
+<?php
+spl_autoload_register(function ($class) {
+ $src = str_replace('\\', '/', $class).'.php';
+ @include_once $src;
+});
+AUTOLOAD
+) > phpunit.bootstrap.php
%build
@@ -57,20 +68,32 @@ find . -name '*.php' | xargs chmod a-x
%install
mkdir -p -m 755 %{buildroot}%{_datadir}/php
-cp -rp src/%{libname} %{buildroot}%{_datadir}/php/
+cp -rp src/%{github_name} %{buildroot}%{_datadir}/php/
%check
-%{_bindir}/phpunit -d date.timezone="UTC" .
+%{_bindir}/phpunit \
+ -d include_path="./src:./test:.:%{pear_phpdir}" \
+ -d date.timezone="UTC" \
+ --bootstrap ./phpunit.bootstrap.php \
+ .
%files
%defattr(-,root,root,-)
%doc LICENSE CHANGELOG readme.md composer.json
-%{_datadir}/php/%{libname}
+%{_datadir}/php/%{github_name}
%changelog
+* Wed Jun 12 2013 Remi Collet <RPMS@FamilleCollet.com> - 1.2.0-1
+- backport 1.2.0 for remi repo.
+
+* Mon Jun 10 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.2.0-1
+- Updated to 1.2.0
+- Added php-mbstring require
+- Updates per new Fedora packaging guidelines for Git repos
+
* Wed Dec 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.1.0-2
- backport 1.1.0 for remi repo.