summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-29 14:12:40 +0100
committerRemi Collet <remi@remirepo.net>2017-11-29 14:12:40 +0100
commit3bfea45a34664dd4f0464321daacc313b8e8d62b (patch)
tree989b44cfc63fd58e30f7cf9d689cb5edc2cdf1f3
parent4a5e8aba9e0a47e06d41530ce49a02a1b16361a6 (diff)
run full test suite on all arches
add patch for 32-bits from https://github.com/fzaninotto/Faker/pull/1348 add patch for big endian from https://github.com/fzaninotto/Faker/pull/1365 fix dependencies
-rw-r--r--1365.patch (renamed from php-Faker-bigendian.patch)13
-rw-r--r--php-Faker.spec14
2 files changed, 21 insertions, 6 deletions
diff --git a/php-Faker-bigendian.patch b/1365.patch
index 39eb713..cd1f506 100644
--- a/php-Faker-bigendian.patch
+++ b/1365.patch
@@ -1,8 +1,17 @@
+From ce3a0239c47289c8c371a67a8d7acf90ef6be7c4 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Wed, 29 Nov 2017 14:02:19 +0100
+Subject: [PATCH] skip test failing on bigendian
+
+---
+ test/Faker/Provider/UuidTest.php | 3 +++
+ 1 file changed, 3 insertions(+)
+
diff --git a/test/Faker/Provider/UuidTest.php b/test/Faker/Provider/UuidTest.php
-index ebd4ae4..5c639ca 100644
+index ebd4ae4c6..5c639cacc 100644
--- a/test/Faker/Provider/UuidTest.php
+++ b/test/Faker/Provider/UuidTest.php
-@@ -16,6 +16,9 @@ class UuidTest extends TestCase
+@@ -16,6 +16,9 @@ public function testUuidReturnsUuid()
public function testUuidExpectedSeed()
{
diff --git a/php-Faker.spec b/php-Faker.spec
index b9c4432..c0f25ce 100644
--- a/php-Faker.spec
+++ b/php-Faker.spec
@@ -37,9 +37,7 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
Patch0: https://patch-diff.githubusercontent.com/raw/fzaninotto/Faker/pull/1348.patch
-# Skip test failing on big endian as upstream doesn't care
-# see https://github.com/fzaninotto/Faker/issues/1346
-Patch1: %{name}-bigendian.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/fzaninotto/Faker/pull/1365.patch
# remirepo:3
# For test build on all available arch
@@ -56,8 +54,9 @@ BuildRequires: php-intl
BuildRequires: php-ctype
BuildRequires: php-curl
BuildRequires: php-date
-BuildRequires: php-filter
+BuildRequires: php-dom
BuildRequires: php-hash
+BuildRequires: php-json
BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-reflection
@@ -71,7 +70,9 @@ Requires: php(language) >= %{php_min_ver}
# phpcompatinfo (computed from version 1.6.0)
Requires: php-curl
Requires: php-date
+Requires: php-dom
Requires: php-hash
+Requires: php-json
Requires: php-mbstring
Requires: php-pcre
Requires: php-reflection
@@ -173,6 +174,11 @@ exit $ret
%changelog
* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 1.7.1-3
- run full test suite on all arches
+- add patch for 32-bits from
+ https://github.com/fzaninotto/Faker/pull/1348
+- add patch for big endian from
+ https://github.com/fzaninotto/Faker/pull/1365
+- fix dependencies
* Fri Nov 10 2017 Remi Collet <remi@remirepo.net> - 1.7.1-2
- fix skip result condition