summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-28 16:05:34 +0100
committerRemi Collet <remi@remirepo.net>2017-11-28 16:05:34 +0100
commit1ab207eebf4780984490d0aeb0ded203bd458731 (patch)
treed62d8058f138998618cf5bcf2d2288d66ab00daf
parenta95b69259b711355044f485c5c936e5ae4eb17d4 (diff)
test...
-rw-r--r--php-Faker.spec23
1 files changed, 12 insertions, 11 deletions
diff --git a/php-Faker.spec b/php-Faker.spec
index 3c8f650..b9c4432 100644
--- a/php-Faker.spec
+++ b/php-Faker.spec
@@ -28,7 +28,7 @@
Name: php-%{github_name}
Version: %{github_version}
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: A PHP library that generates fake data
Group: Development/Libraries
@@ -36,6 +36,11 @@ License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+Patch0: https://patch-diff.githubusercontent.com/raw/fzaninotto/Faker/pull/1348.patch
+# Skip test failing on big endian as upstream doesn't care
+# see https://github.com/fzaninotto/Faker/issues/1346
+Patch1: %{name}-bigendian.patch
+
# remirepo:3
# For test build on all available arch
#global debug_package %{nil}
@@ -101,6 +106,8 @@ Optional:
%prep
%setup -qn %{github_name}-%{github_commit}
+%patch0 -p1
+%patch1 -p1
%if 0%{?el6}
# For old PHPUnit
@@ -143,22 +150,13 @@ require_once '%{buildroot}%{phpdir}/Faker/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('Faker\\Test\\', dirname(__DIR__).'/test/Faker');
EOF
-%ifarch ppc64 s390x
-# see https://github.com/fzaninotto/Faker/issues/1346
-rm -f test/Faker/Provider/UuidTest.php
-%endif
-
ret=0
for cmd in php php56 php70 php71 php72; do
if which $cmd; then
$cmd %{_bindir}/phpunit --verbose || ret=1
fi
done
-if [ $(php -r 'echo PHP_INT_SIZE;') -lt 8 ]; then
- : ignore test suite results https://github.com/fzaninotto/Faker/issues/1347
-else
- exit $ret
-fi
+exit $ret
%else
: Tests skipped
%endif
@@ -173,6 +171,9 @@ fi
%changelog
+* Tue Nov 28 2017 Remi Collet <remi@remirepo.net> - 1.7.1-3
+- run full test suite on all arches
+
* Fri Nov 10 2017 Remi Collet <remi@remirepo.net> - 1.7.1-2
- fix skip result condition