summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-14 08:26:55 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-14 08:26:55 +0200
commita624d7684883d59f1894ebf77af9fdde58371a50 (patch)
treea11c90659bfd36071546caf189f9da989fe7776d
parentde201ec028d7332f21eea770b58d6bb98f956879 (diff)
php-Assetic: sync with fedora
-rw-r--r--php-Assetic.spec25
1 files changed, 16 insertions, 9 deletions
diff --git a/php-Assetic.spec b/php-Assetic.spec
index bafb275..88af5dd 100644
--- a/php-Assetic.spec
+++ b/php-Assetic.spec
@@ -74,7 +74,7 @@
Name: php-Assetic
Version: %{github_version}
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Asset Management for PHP
Group: Development/Libraries
@@ -241,14 +241,15 @@ if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Compo
$fedoraClassLoader->addPrefix('Assetic\\', dirname(__DIR__));
require_once __DIR__.'/functions.php';
-// Required dependencies
-require_once '%{phpdir}/Symfony/Component/Process/autoload.php';
-
-// Optional dependencies
-@include_once '%{phpdir}/Leafo/ScssPhp/autoload.php';
-@include_once '%{phpdir}/lessphp/lessc.inc.php';
-@include_once '%{phpdir}/Patchwork/JSqueeze.php';
-@include_once '%{phpdir}/Twig/autoload.php';
+foreach (array(
+ '%{phpdir}/Symfony/Component/Process/autoload.php' => true,
+ '%{phpdir}/Leafo/ScssPhp/autoload.php' => false,
+ '%{phpdir}/lessphp/lessc.inc.php' => false,
+ '%{phpdir}/Patchwork/JSqueeze.php' => false,
+ '%{phpdir}/Twig/autoload.php' => false,
+ ) as $dep => $mandatory) {
+ if ($mandatory || file_exists($dep)) require_once($dep);
+}
return $fedoraClassLoader;
AUTOLOAD
@@ -302,6 +303,12 @@ rm -rf %{buildroot}
%changelog
+* Wed Apr 13 2016 James Hogarth <james.hogarth@gmail.com> - 1.3.2-3
+- Change to using array() in autoloader to be php5.3 compatible for el6
+
+* Wed Apr 13 2016 James Hogarth <james.hogarth@gmail.com> - 1.3.2-2
+- Check if file exists and then require in the Fedora autoloader (RHBZ #1326825)
+
* Sat Mar 26 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.2-1
- Updated to 1.3.2 (RHBZ #1153986)
- Added additional non-PHP build dependencies