summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-03-11 17:32:03 +0100
committerRemi Collet <fedora@famillecollet.com>2013-03-11 17:32:03 +0100
commit0c1ae0b975c73ae815201ecfc2feda469ed488ee (patch)
tree896fb7e6a1a5891eb603dde71ae47767aa23227a
php-Assetic: import from rawhide
-rw-r--r--Makefile10
-rw-r--r--php-Assetic.spec95
2 files changed, 105 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-Assetic.spec b/php-Assetic.spec
new file mode 100644
index 0000000..f9d77cf
--- /dev/null
+++ b/php-Assetic.spec
@@ -0,0 +1,95 @@
+%global github_owner kriswallsmith
+%global github_name assetic
+%global github_version 1.1.0
+%global github_commit df03baa337ae1c87803a7b1a76a393f8a59813f3
+%global github_date 20130224
+
+%global github_release alpha4
+
+%global php_min_ver 5.3.1
+
+%global symfony_min_ver 2.1.0
+%global symfony_max_ver 2.3
+%global twig_min_ver 1.6.0
+%global twig_max_ver 2.0
+
+Name: php-Assetic
+Version: %{github_version}
+Release: 0.2.%{github_release}%{?dist}
+Summary: Asset Management for PHP
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+BuildArch: noarch
+
+Requires: php-common >= %{php_min_ver}
+Requires: php-pear(pear.symfony.com/Process) >= %{symfony_min_ver}
+Requires: php-pear(pear.symfony.com/Process) < %{symfony_max_ver}
+# phpci
+Requires: php-ctype
+Requires: php-curl
+Requires: php-date
+Requires: php-hash
+Requires: php-json
+Requires: php-pcre
+Requires: php-spl
+Requires: php-standard
+Requires: php-tokenizer
+# Optional
+Requires: php-pear(pear.twig-project.org/Twig) >= %{twig_min_ver}
+Requires: php-pear(pear.twig-project.org/Twig) < %{twig_max_ver}
+Requires: php-lessphp
+# TODO: leafo/scssphp
+# In progress, but waiting for upstream.
+# https://bugzilla.redhat.com/show_bug.cgi?id=880880
+
+%description
+Assetic is an asset management framework for PHP.
+
+Optional dependency: APC (php-pecl-apc)
+
+Optional packages:
+* https://github.com/leafo/scssphp
+* https://github.com/leafo/scssphp-compass
+* https://github.com/krichprollsch/phpCssEmbed
+
+
+%prep
+%setup -q -n %{github_name}-%{github_commit}
+
+# Move functions file
+mv src/functions.php src/Assetic/
+
+# Remove executable bit
+chmod a-x CHANGELOG-1.1.md
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+mkdir -p -m 755 %{buildroot}%{_datadir}/php
+cp -rp src/Assetic %{buildroot}%{_datadir}/php/
+
+
+%check
+# TODO: Work with upstream to figure out why tests are ignored for export
+# (and therefore not included in a GitHub archive)
+# https://github.com/kriswallsmith/assetic/blob/v1.1.0-alpha4/.gitattributes
+
+
+%files
+%doc LICENSE *.md composer.json
+%{_datadir}/php/Assetic
+
+
+%changelog
+* Sat Mar 09 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.0-0.2.alpha4
+- Updated to upstream pre-release version 1.1.0-alpha4
+
+* Wed Feb 27 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 1.1.0-0.1.alpha3
+- Initial package