summaryrefslogtreecommitdiffstats
path: root/php-pecl-zookeeper.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
committerRemi Collet <fedora@famillecollet.com>2014-04-17 18:05:45 +0200
commit4b653f0508b5f6d222ec12b94e5521713329f3c4 (patch)
tree7a62754ab989e2ec50bd2da92f26723a908ed1ab /php-pecl-zookeeper.spec
parent58ae3771e21eb3cfe3aca76e8fe9b0d44d57e9ec (diff)
php-pecl: add numerical prefix to extension configuration file (all done !)
Diffstat (limited to 'php-pecl-zookeeper.spec')
-rw-r--r--php-pecl-zookeeper.spec24
1 files changed, 16 insertions, 8 deletions
diff --git a/php-pecl-zookeeper.spec b/php-pecl-zookeeper.spec
index 7710299..497f9a1 100644
--- a/php-pecl-zookeeper.spec
+++ b/php-pecl-zookeeper.spec
@@ -10,13 +10,18 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global pecl_name zookeeper
-%global with_zts 0%{?__ztsphp:1}
+%global pecl_name zookeeper
+%global with_zts 0%{?__ztsphp:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
Summary: PHP extension for interfacing with Apache ZooKeeper
Name: php-pecl-%{pecl_name}
Version: 0.2.2
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://github.com/andreiz/php-zookeeper
@@ -89,7 +94,7 @@ cp -pr NTS ZTS
%endif
# Create configuration file
-cat > %{pecl_name}.ini << 'EOF'
+cat > %{ini_name} << 'EOF'
; Enable %{pecl_name} extension module
extension=%{pecl_name}.so
@@ -126,7 +131,7 @@ rm -rf %{buildroot}
make -C NTS install INSTALL_ROOT=%{buildroot}
# install config file
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_inidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -134,7 +139,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/%{pecl_name}.ini
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
# Test & Documentation
@@ -179,16 +184,19 @@ rm -rf %{buildroot}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
-%config(noreplace) %{php_inidir}/%{pecl_name}.ini
+%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{pecl_name}.so
%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{pecl_name}.ini
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
%{php_ztsextdir}/%{pecl_name}.so
%endif
%changelog
+* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 0.2.2-3
+- add numerical prefix to extension configuration file (php 5.6)
+
* Sat Mar 15 2014 Remi Collet <remi@fedoraproject.org> - 0.2.2-2
- install doc in pecl_docdir