summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-04 16:19:56 +0200
committerRemi Collet <remi@remirepo.net>2018-05-04 16:19:56 +0200
commit73944b9f7eff3a41472d5eed74c63c55eca37b19 (patch)
treef0b509f1af0fa35d9b5d4c67f0b511678b4f81fa
parente545787d2886eb5e3a167adf926d6badac28b0a1 (diff)
v0.4.1
-rw-r--r--REFLECTION98
-rw-r--r--php-pecl-zookeeper.spec21
2 files changed, 59 insertions, 60 deletions
diff --git a/REFLECTION b/REFLECTION
index f022007..91c7bf0 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #163 zookeeper version 0.4.0 ] {
+Extension [ <persistent> extension #178 zookeeper version 0.4.1 ] {
- INI {
Entry [ zookeeper.recv_timeout <ALL> ]
@@ -21,54 +21,54 @@ Extension [ <persistent> extension #163 zookeeper version 0.4.0 ] {
Class [ <internal:zookeeper> class Zookeeper ] {
- Constants [48] {
- Constant [ integer PERM_READ ] { 1 }
- Constant [ integer PERM_WRITE ] { 2 }
- Constant [ integer PERM_CREATE ] { 4 }
- Constant [ integer PERM_DELETE ] { 8 }
- Constant [ integer PERM_ALL ] { 31 }
- Constant [ integer PERM_ADMIN ] { 16 }
- Constant [ integer EPHEMERAL ] { 1 }
- Constant [ integer SEQUENCE ] { 2 }
- Constant [ integer EXPIRED_SESSION_STATE ] { -112 }
- Constant [ integer AUTH_FAILED_STATE ] { -113 }
- Constant [ integer CONNECTING_STATE ] { 1 }
- Constant [ integer ASSOCIATING_STATE ] { 2 }
- Constant [ integer CONNECTED_STATE ] { 3 }
- Constant [ integer NOTCONNECTED_STATE ] { 999 }
- Constant [ integer CREATED_EVENT ] { 1 }
- Constant [ integer DELETED_EVENT ] { 2 }
- Constant [ integer CHANGED_EVENT ] { 3 }
- Constant [ integer CHILD_EVENT ] { 4 }
- Constant [ integer SESSION_EVENT ] { -1 }
- Constant [ integer NOTWATCHING_EVENT ] { -2 }
- Constant [ integer LOG_LEVEL_ERROR ] { 1 }
- Constant [ integer LOG_LEVEL_WARN ] { 2 }
- Constant [ integer LOG_LEVEL_INFO ] { 3 }
- Constant [ integer LOG_LEVEL_DEBUG ] { 4 }
- Constant [ integer SYSTEMERROR ] { -1 }
- Constant [ integer RUNTIMEINCONSISTENCY ] { -2 }
- Constant [ integer DATAINCONSISTENCY ] { -3 }
- Constant [ integer CONNECTIONLOSS ] { -4 }
- Constant [ integer MARSHALLINGERROR ] { -5 }
- Constant [ integer UNIMPLEMENTED ] { -6 }
- Constant [ integer OPERATIONTIMEOUT ] { -7 }
- Constant [ integer BADARGUMENTS ] { -8 }
- Constant [ integer INVALIDSTATE ] { -9 }
- Constant [ integer OK ] { 0 }
- Constant [ integer APIERROR ] { -100 }
- Constant [ integer NONODE ] { -101 }
- Constant [ integer NOAUTH ] { -102 }
- Constant [ integer BADVERSION ] { -103 }
- Constant [ integer NOCHILDRENFOREPHEMERALS ] { -108 }
- Constant [ integer NODEEXISTS ] { -110 }
- Constant [ integer NOTEMPTY ] { -111 }
- Constant [ integer SESSIONEXPIRED ] { -112 }
- Constant [ integer INVALIDCALLBACK ] { -113 }
- Constant [ integer INVALIDACL ] { -114 }
- Constant [ integer AUTHFAILED ] { -115 }
- Constant [ integer CLOSING ] { -116 }
- Constant [ integer NOTHING ] { -117 }
- Constant [ integer SESSIONMOVED ] { -118 }
+ Constant [ public integer PERM_READ ] { 1 }
+ Constant [ public integer PERM_WRITE ] { 2 }
+ Constant [ public integer PERM_CREATE ] { 4 }
+ Constant [ public integer PERM_DELETE ] { 8 }
+ Constant [ public integer PERM_ALL ] { 31 }
+ Constant [ public integer PERM_ADMIN ] { 16 }
+ Constant [ public integer EPHEMERAL ] { 1 }
+ Constant [ public integer SEQUENCE ] { 2 }
+ Constant [ public integer EXPIRED_SESSION_STATE ] { -112 }
+ Constant [ public integer AUTH_FAILED_STATE ] { -113 }
+ Constant [ public integer CONNECTING_STATE ] { 1 }
+ Constant [ public integer ASSOCIATING_STATE ] { 2 }
+ Constant [ public integer CONNECTED_STATE ] { 3 }
+ Constant [ public integer NOTCONNECTED_STATE ] { 999 }
+ Constant [ public integer CREATED_EVENT ] { 1 }
+ Constant [ public integer DELETED_EVENT ] { 2 }
+ Constant [ public integer CHANGED_EVENT ] { 3 }
+ Constant [ public integer CHILD_EVENT ] { 4 }
+ Constant [ public integer SESSION_EVENT ] { -1 }
+ Constant [ public integer NOTWATCHING_EVENT ] { -2 }
+ Constant [ public integer LOG_LEVEL_ERROR ] { 1 }
+ Constant [ public integer LOG_LEVEL_WARN ] { 2 }
+ Constant [ public integer LOG_LEVEL_INFO ] { 3 }
+ Constant [ public integer LOG_LEVEL_DEBUG ] { 4 }
+ Constant [ public integer SYSTEMERROR ] { -1 }
+ Constant [ public integer RUNTIMEINCONSISTENCY ] { -2 }
+ Constant [ public integer DATAINCONSISTENCY ] { -3 }
+ Constant [ public integer CONNECTIONLOSS ] { -4 }
+ Constant [ public integer MARSHALLINGERROR ] { -5 }
+ Constant [ public integer UNIMPLEMENTED ] { -6 }
+ Constant [ public integer OPERATIONTIMEOUT ] { -7 }
+ Constant [ public integer BADARGUMENTS ] { -8 }
+ Constant [ public integer INVALIDSTATE ] { -9 }
+ Constant [ public integer OK ] { 0 }
+ Constant [ public integer APIERROR ] { -100 }
+ Constant [ public integer NONODE ] { -101 }
+ Constant [ public integer NOAUTH ] { -102 }
+ Constant [ public integer BADVERSION ] { -103 }
+ Constant [ public integer NOCHILDRENFOREPHEMERALS ] { -108 }
+ Constant [ public integer NODEEXISTS ] { -110 }
+ Constant [ public integer NOTEMPTY ] { -111 }
+ Constant [ public integer SESSIONEXPIRED ] { -112 }
+ Constant [ public integer INVALIDCALLBACK ] { -113 }
+ Constant [ public integer INVALIDACL ] { -114 }
+ Constant [ public integer AUTHFAILED ] { -115 }
+ Constant [ public integer CLOSING ] { -116 }
+ Constant [ public integer NOTHING ] { -117 }
+ Constant [ public integer SESSIONMOVED ] { -118 }
}
- Static properties [0] {
diff --git a/php-pecl-zookeeper.spec b/php-pecl-zookeeper.spec
index 50bd7ee..b5fbdff 100644
--- a/php-pecl-zookeeper.spec
+++ b/php-pecl-zookeeper.spec
@@ -8,6 +8,9 @@
#
%{?scl: %scl_package php-pecl-zookeeper}
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%global pecl_name zookeeper
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
@@ -18,13 +21,14 @@
Summary: PHP extension for interfacing with Apache ZooKeeper
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.4.0
-Release: 3%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 0.4.1
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
URL: http://github.com/andreiz/php-zookeeper
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: zookeeper-devel
@@ -43,14 +47,6 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "5.6"
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
@@ -161,7 +157,7 @@ do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -212,6 +208,9 @@ cd ../ZTS
%changelog
+* Fri May 4 2018 Remi Collet <remi@remirepo.net> - 0.4.1-1
+- update to 0.4.1
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 0.4.0-3
- rebuild for PHP 7.2.0beta1 new API