summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-31 08:47:31 +0200
committerRemi Collet <fedora@famillecollet.com>2017-03-31 08:47:31 +0200
commit34e19f9722dd57064a77465f5e953c0da92ce2d7 (patch)
tree4073beb2f79f0a48c0639a9caa9f964b087d9eac
parentb0cf727c7019e6f7aaf94bc534daf7be56b5310c (diff)
switch the specs
-rw-r--r--.gitignore6
-rw-r--r--REFLECTION-DEV627
-rw-r--r--php-pecl-zookeeper-dev.spec248
-rw-r--r--php-pecl-zookeeper.spec24
4 files changed, 28 insertions, 877 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..95b26a9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
deleted file mode 100644
index 1bc0b30..0000000
--- a/REFLECTION-DEV
+++ /dev/null
@@ -1,627 +0,0 @@
-Extension [ <persistent> extension #156 zookeeper version 0.3.1 ] {
-
- - INI {
- Entry [ zookeeper.recv_timeout <ALL> ]
- Current = '10000'
- }
- Entry [ zookeeper.session_lock <SYSTEM> ]
- Current = '1'
- }
- Entry [ zookeeper.sess_lock_wait <ALL> ]
- Current = '150000'
- }
- }
-
- - Classes [8] {
- Class [ <internal:zookeeper> class Zookeeper ] {
-
- - Constants [48] {
- Constant [ integer PERM_READ ] { 1 }
- Constant [ integer PERM_WRITE ] { 2 }
- Constant [ integer PERM_CREATE ] { 4 }
- Constant [ integer PERM_DELETE ] { 8 }
- Constant [ integer PERM_ALL ] { 31 }
- Constant [ integer PERM_ADMIN ] { 16 }
- Constant [ integer EPHEMERAL ] { 1 }
- Constant [ integer SEQUENCE ] { 2 }
- Constant [ integer EXPIRED_SESSION_STATE ] { -112 }
- Constant [ integer AUTH_FAILED_STATE ] { -113 }
- Constant [ integer CONNECTING_STATE ] { 1 }
- Constant [ integer ASSOCIATING_STATE ] { 2 }
- Constant [ integer CONNECTED_STATE ] { 3 }
- Constant [ integer NOTCONNECTED_STATE ] { 999 }
- Constant [ integer CREATED_EVENT ] { 1 }
- Constant [ integer DELETED_EVENT ] { 2 }
- Constant [ integer CHANGED_EVENT ] { 3 }
- Constant [ integer CHILD_EVENT ] { 4 }
- Constant [ integer SESSION_EVENT ] { -1 }
- Constant [ integer NOTWATCHING_EVENT ] { -2 }
- Constant [ integer LOG_LEVEL_ERROR ] { 1 }
- Constant [ integer LOG_LEVEL_WARN ] { 2 }
- Constant [ integer LOG_LEVEL_INFO ] { 3 }
- Constant [ integer LOG_LEVEL_DEBUG ] { 4 }
- Constant [ integer SYSTEMERROR ] { -1 }
- Constant [ integer RUNTIMEINCONSISTENCY ] { -2 }
- Constant [ integer DATAINCONSISTENCY ] { -3 }
- Constant [ integer CONNECTIONLOSS ] { -4 }
- Constant [ integer MARSHALLINGERROR ] { -5 }
- Constant [ integer UNIMPLEMENTED ] { -6 }
- Constant [ integer OPERATIONTIMEOUT ] { -7 }
- Constant [ integer BADARGUMENTS ] { -8 }
- Constant [ integer INVALIDSTATE ] { -9 }
- Constant [ integer OK ] { 0 }
- Constant [ integer APIERROR ] { -100 }
- Constant [ integer NONODE ] { -101 }
- Constant [ integer NOAUTH ] { -102 }
- Constant [ integer BADVERSION ] { -103 }
- Constant [ integer NOCHILDRENFOREPHEMERALS ] { -108 }
- Constant [ integer NODEEXISTS ] { -110 }
- Constant [ integer NOTEMPTY ] { -111 }
- Constant [ integer SESSIONEXPIRED ] { -112 }
- Constant [ integer INVALIDCALLBACK ] { -113 }
- Constant [ integer INVALIDACL ] { -114 }
- Constant [ integer AUTHFAILED ] { -115 }
- Constant [ integer CLOSING ] { -116 }
- Constant [ integer NOTHING ] { -117 }
- Constant [ integer SESSIONMOVED ] { -118 }
- }
-
- - Static properties [0] {
- }
-
- - Static methods [2] {
- Method [ <internal:zookeeper> static public method setDebugLevel ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $level ]
- }
- }
-
- Method [ <internal:zookeeper> static public method setDeterministicConnOrder ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $trueOrFalse ]
- }
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [17] {
- Method [ <internal:zookeeper, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <optional> $watcher_cb ]
- Parameter #2 [ <optional> $recv_timeout ]
- }
- }
-
- Method [ <internal:zookeeper> public method connect ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $host ]
- Parameter #1 [ <optional> $watcher_cb ]
- Parameter #2 [ <optional> $recv_timeout ]
- }
- }
-
- Method [ <internal:zookeeper> public method create ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $path ]
- Parameter #1 [ <optional> $value ]
- Parameter #2 [ <optional> array $acl ]
- Parameter #3 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zookeeper> public method delete ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $path ]
- Parameter #1 [ <optional> $version ]
- }
- }
-
- Method [ <internal:zookeeper> public method get ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $path ]
- Parameter #1 [ <optional> $watcher_cb ]
- Parameter #2 [ <optional> &$stat_info ]
- }
- }
-
- Method [ <internal:zookeeper> public method getChildren ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $path ]
- Parameter #1 [ <optional> $watcher_cb ]
- }
- }
-
- Method [ <internal:zookeeper> public method exists ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $path ]
- Parameter #1 [ <optional> $watcher_cb ]
- }
- }
-
- Method [ <internal:zookeeper> public method set ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $path ]
- Parameter #1 [ <optional> $value ]
- Parameter #2 [ <optional> $version ]
- Parameter #3 [ <optional> &$stat_info ]
- }
- }
-
- Method [ <internal:zookeeper> public method getAcl ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:zookeeper> public method setAcl ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $path ]
- Parameter #1 [ <required> $version ]
- Parameter #2 [ <required> $acl ]
- }
- }
-
- Method [ <internal:zookeeper> public method getClientId ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:zookeeper> public method getState ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:zookeeper> public method getRecvTimeout ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:zookeeper> public method isRecoverable ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:zookeeper> public method addAuth ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $scheme ]
- Parameter #1 [ <required> $cert ]
- Parameter #2 [ <optional> $completion_cb ]
- }
- }
-
- Method [ <internal:zookeeper> public method setWatcher ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $watcher_cb ]
- }
- }
-
- Method [ <internal:zookeeper> public method setLogStream ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $stream ]
- }
- }
- }
- }
-
- Class [ <internal:zookeeper> class ZookeeperException extends Exception implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
-
- Class [ <internal:zookeeper> class ZookeeperOperationTimeoutException extends ZookeeperException implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
-
- Class [ <internal:zookeeper> class ZookeeperConnectionException extends ZookeeperException implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
-
- Class [ <internal:zookeeper> class ZookeeperMarshallingException extends ZookeeperException implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
-
- Class [ <internal:zookeeper> class ZookeeperAuthenticationException extends ZookeeperException implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
-
- Class [ <internal:zookeeper> class ZookeeperSessionException extends ZookeeperException implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
-
- Class [ <internal:zookeeper> class ZookeeperNoNodeException extends ZookeeperException implements Throwable ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- }
-
- - Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
- }
- }
-
- Method [ <internal:Core, inherits Exception> public method __wakeup ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
- }
-
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-zookeeper-dev.spec b/php-pecl-zookeeper-dev.spec
deleted file mode 100644
index 689d272..0000000
--- a/php-pecl-zookeeper-dev.spec
+++ /dev/null
@@ -1,248 +0,0 @@
-# spec file for php-pecl-zookeeper
-#
-# Copyright (c) 2013-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%{?scl: %scl_package php-pecl-zookeeper}
-
-%global pecl_name zookeeper
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
-%global ini_name 40-%{pecl_name}.ini
-%endif
-
-Summary: PHP extension for interfacing with Apache ZooKeeper
-Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.3.1
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: PHP
-Group: Development/Languages
-URL: http://github.com/andreiz/php-zookeeper
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel
-BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: zookeeper-devel
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared object
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-This extension provides API for communicating with ZooKeeper service.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-
-
-%prep
-%setup -q -c
-mv %{pecl_name}-%{version} NTS
-
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
-
-cd NTS
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_ZOOKEEPER_VERSION/{s/.* "//;s/".*$//;p}' php_zookeeper.h)
-if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
- exit 1
-fi
-cd ..
-
-%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
-%endif
-
-# Create configuration file
-cat > %{ini_name} << 'EOF'
-; Enable %{pecl_name} extension module
-extension=%{pecl_name}.so
-
-; Extension configuration
-;zookeeper.recv_timeout = 10000
-;zookeeper.session_lock = 1
-;zookeeper.sess_lock_wait = 150000
-EOF
-
-
-%build
-%{?dtsenable}
-
-cd NTS
-%{_bindir}/phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
-
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
-
-make %{?_smp_mflags}
-%endif
-
-
-%install
-rm -rf %{buildroot}
-%{?dtsenable}
-
-make -C NTS install INSTALL_ROOT=%{buildroot}
-
-# install config file
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-cd NTS
-for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%check
-: Minimal load test for NTS extension
-cd NTS
-%{_bindir}/php --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-%if %{with_zts}
-: Minimal load test for ZTS extension
-cd ../ZTS
-%{__ztsphp} --no-php-ini \
- --define extension=modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-
-%files
-%defattr(-,root,root,-)
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Mon Jan 23 2017 Remi Collet <remi@fedoraproject.org> - 0.3.1-1
-- Update to 0.3.1 (alpha)
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.3.0-2
-- rebuild with PHP 7.1.0 GA
-
-* Fri Nov 18 2016 Remi Collet <remi@fedoraproject.org> - 0.3.0-1
-- Update to 0.3.0 alpha (for PHP 7)
-
-* Mon Nov 07 2016 Remi Collet <remi@fedoraproject.org> - 0.2.3-1
-- Update to 0.2.3
-
-* Wed Mar 9 2016 Remi Collet <remi@fedoraproject.org> - 0.2.2-6
-- adapt for F24
-- drop runtime dependency on pear, new scriptlets
-- fix license management
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.2.2-5
-- F21 have zookeeper-devel instead of zookeeper-lib-devel
-
-* Tue Aug 26 2014 Remi Collet <rcollet@redhat.com> - 0.2.2-4
-- allow SCL build
-
-* Thu Apr 17 2014 Remi Collet <remi@fedoraproject.org> - 0.2.2-3
-- add numerical prefix to extension configuration file (php 5.6)
-
-* Sat Mar 15 2014 Remi Collet <remi@fedoraproject.org> - 0.2.2-2
-- install doc in pecl_docdir
-
-* Sun Oct 6 2013 Remi Collet <remi@fedoraproject.org> - 0.2.2-1
-- initial package, version 0.2.2 (beta)
diff --git a/php-pecl-zookeeper.spec b/php-pecl-zookeeper.spec
index 3bcca41..689d272 100644
--- a/php-pecl-zookeeper.spec
+++ b/php-pecl-zookeeper.spec
@@ -18,7 +18,7 @@
Summary: PHP extension for interfacing with Apache ZooKeeper
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 0.2.3
+Version: 0.3.1
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
License: PHP
Group: Development/Languages
@@ -26,7 +26,7 @@ URL: http://github.com/andreiz/php-zookeeper
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel < 7
+BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: zookeeper-devel
@@ -56,6 +56,14 @@ Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -105,6 +113,8 @@ EOF
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -126,6 +136,7 @@ make %{?_smp_mflags}
%install
rm -rf %{buildroot}
+%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -204,6 +215,15 @@ rm -rf %{buildroot}
%changelog
+* Mon Jan 23 2017 Remi Collet <remi@fedoraproject.org> - 0.3.1-1
+- Update to 0.3.1 (alpha)
+
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.3.0-2
+- rebuild with PHP 7.1.0 GA
+
+* Fri Nov 18 2016 Remi Collet <remi@fedoraproject.org> - 0.3.0-1
+- Update to 0.3.0 alpha (for PHP 7)
+
* Mon Nov 07 2016 Remi Collet <remi@fedoraproject.org> - 0.2.3-1
- Update to 0.2.3