summaryrefslogtreecommitdiffstats
path: root/php-pecl-zmq.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-zmq.spec')
-rw-r--r--php-pecl-zmq.spec35
1 files changed, 15 insertions, 20 deletions
diff --git a/php-pecl-zmq.spec b/php-pecl-zmq.spec
index c428179..2b7c92c 100644
--- a/php-pecl-zmq.spec
+++ b/php-pecl-zmq.spec
@@ -26,11 +26,13 @@
Summary: ZeroMQ messaging
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.1.3
-Release: 11%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 12%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/zeromq/php-zmq/pull/216.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -49,9 +51,9 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
# Version 1.0.7 is the first pecl release
# Fedora/EPEL still provides php-zmq, not php-pecl-zmq
-Obsoletes: %{?scl_prefix}php-%{pecl_name} < %{version}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Obsoletes: %{?scl_prefix}php-%{pecl_name} < %{version}-99
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}-99
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}-99
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?scl_prefix}" != "%{?sub_prefix}"
@@ -59,31 +61,19 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
@@ -112,6 +102,8 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{version} NTS
cd NTS
+%patch0 -p1 -b .pr216
+
if pkg-config libzmq --atleast-version=4
then
# fix new default of MAX_SOCKETS
@@ -254,6 +246,9 @@ export TEST_PHP_EXECUTABLE=%{__ztsphp}
%changelog
+* Mon Aug 24 2020 Remi Collet <remi@remirepo.net> - 1.1.3-12
+- add patch for PHP 8 from https://github.com/zeromq/php-zmq/pull/216
+
* Wed Nov 27 2019 Remi Collet <remi@remirepo.net> - 1.1.3-11
- EL-8 rebuild