summaryrefslogtreecommitdiffstats
path: root/php-pecl-zmq.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-03 12:18:00 +0100
committerRemi Collet <remi@php.net>2021-11-03 12:18:00 +0100
commit753f689f3d6fad9c8bb48eb8417f608a3036fc22 (patch)
treea79d09bd610200dddcbb109dfb5fdfe338dfae83 /php-pecl-zmq.spec
parentcf4e65cfae87c7b8e7ad91d896871615d07c4276 (diff)
add patch for PHP 8.1 from https://github.com/zeromq/php-zmq/pull/222
Diffstat (limited to 'php-pecl-zmq.spec')
-rw-r--r--php-pecl-zmq.spec27
1 files changed, 12 insertions, 15 deletions
diff --git a/php-pecl-zmq.spec b/php-pecl-zmq.spec
index c82257d..bd79c65 100644
--- a/php-pecl-zmq.spec
+++ b/php-pecl-zmq.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-zmq
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -26,22 +26,19 @@
Summary: ZeroMQ messaging
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 1.1.3
-Release: 14%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 15%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Patch0: https://patch-diff.githubusercontent.com/raw/zeromq/php-zmq/pull/216.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/zeromq/php-zmq/pull/222.patch
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
-%if 0%{?fedora} >= 22 || 0%{?rhel} >= 7
-# v4 in Fedora22+, EPEL-7, EPEL-8
BuildRequires: zeromq-devel >= 2.0.7
-%else
-BuildRequires: zeromq3-devel
-%endif
BuildRequires: pkgconfig
# BuildRequires: gdb php-debuginfo php-cli-debuginfo php-debugsource
@@ -75,12 +72,9 @@ Obsoletes: php74-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.1"
+Obsoletes: php81-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -103,6 +97,7 @@ mv %{pecl_name}-%{version} NTS
cd NTS
%patch0 -p1 -b .pr216
+%patch1 -p1 -b .pr222
if pkg-config libzmq --atleast-version=4
then
@@ -210,9 +205,8 @@ cd NTS
: upstream test suite for NTS extension
export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
export REPORT_EXIT_STATUS=1
-export NO_INTERACTION=1
export TEST_PHP_EXECUTABLE=%{__php}
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
%endif
%if %{with_zts}
@@ -226,7 +220,7 @@ cd ../ZTS
: upstream test suite for ZTS extension
export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
export TEST_PHP_EXECUTABLE=%{__ztsphp}
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php -q --show-diff
%endif
%endif
@@ -246,6 +240,9 @@ export TEST_PHP_EXECUTABLE=%{__ztsphp}
%changelog
+* Wed Nov 3 2021 Remi Collet <remi@remirepo.net> - 1.1.3-15
+- add patch for PHP 8.1 from https://github.com/zeromq/php-zmq/pull/222
+
* Wed Sep 30 2020 Remi Collet <remi@remirepo.net> - 1.1.3-14
- rebuild for PHP 8.0.0RC1