summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-07-20 11:57:07 +0200
committerRemi Collet <remi@php.net>2023-07-20 11:57:07 +0200
commit9ba083c6792be9d1b69a5bac1745ad5b55899447 (patch)
treef64aaf273f4b219d311cbafa6605ec327fb9484a
parent62f772af1386cf85030174303b8de7ebc976e63a (diff)
build out of sources tree
-rw-r--r--REFLECTION645
-rw-r--r--php-pecl-zmq.spec78
2 files changed, 488 insertions, 235 deletions
diff --git a/REFLECTION b/REFLECTION
index 68cb732..6b7b740 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,98 +1,162 @@
-Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
+Extension [ <persistent> extension #124 zmq version 1.1.3 ] {
- Classes [10] {
Class [ <internal:zmq> class ZMQ ] {
- - Constants [78] {
- Constant [ integer SOCKET_PAIR ] { 0 }
- Constant [ integer SOCKET_PUB ] { 1 }
- Constant [ integer SOCKET_SUB ] { 2 }
- Constant [ integer SOCKET_XSUB ] { 10 }
- Constant [ integer SOCKET_XPUB ] { 9 }
- Constant [ integer SOCKET_REQ ] { 3 }
- Constant [ integer SOCKET_REP ] { 4 }
- Constant [ integer SOCKET_XREQ ] { 5 }
- Constant [ integer SOCKET_XREP ] { 6 }
- Constant [ integer SOCKET_PUSH ] { 8 }
- Constant [ integer SOCKET_PULL ] { 7 }
- Constant [ integer SOCKET_DEALER ] { 5 }
- Constant [ integer SOCKET_ROUTER ] { 6 }
- Constant [ integer SOCKET_STREAM ] { 11 }
- Constant [ integer SOCKET_UPSTREAM ] { 7 }
- Constant [ integer SOCKET_DOWNSTREAM ] { 8 }
- Constant [ integer POLL_IN ] { 1 }
- Constant [ integer POLL_OUT ] { 2 }
- Constant [ integer MODE_SNDMORE ] { 2 }
- Constant [ integer MODE_NOBLOCK ] { 1 }
- Constant [ integer MODE_DONTWAIT ] { 1 }
- Constant [ integer DEVICE_FORWARDER ] { 2 }
- Constant [ integer DEVICE_QUEUE ] { 3 }
- Constant [ integer DEVICE_STREAMER ] { 1 }
- Constant [ integer ERR_INTERNAL ] { -99 }
- Constant [ integer ERR_EAGAIN ] { 11 }
- Constant [ integer ERR_ENOTSUP ] { 95 }
- Constant [ integer ERR_EFSM ] { 156384763 }
- Constant [ integer ERR_ETERM ] { 156384765 }
- Constant [ string LIBZMQ_VER ] { 4.1.2 }
- Constant [ integer SOCKOPT_HWM ] { 201 }
- Constant [ integer SOCKOPT_SNDHWM ] { 23 }
- Constant [ integer SOCKOPT_RCVHWM ] { 24 }
- Constant [ integer SOCKOPT_AFFINITY ] { 4 }
- Constant [ integer SOCKOPT_IDENTITY ] { 5 }
- Constant [ integer SOCKOPT_RATE ] { 8 }
- Constant [ integer SOCKOPT_RECOVERY_IVL ] { 9 }
- Constant [ integer SOCKOPT_SNDBUF ] { 11 }
- Constant [ integer SOCKOPT_RCVBUF ] { 12 }
- Constant [ integer SOCKOPT_LINGER ] { 17 }
- Constant [ integer SOCKOPT_RECONNECT_IVL ] { 18 }
- Constant [ integer SOCKOPT_RECONNECT_IVL_MAX ] { 21 }
- Constant [ integer SOCKOPT_BACKLOG ] { 19 }
- Constant [ integer SOCKOPT_MAXMSGSIZE ] { 22 }
- Constant [ integer SOCKOPT_SUBSCRIBE ] { 6 }
- Constant [ integer SOCKOPT_UNSUBSCRIBE ] { 7 }
- Constant [ integer SOCKOPT_TYPE ] { 16 }
- Constant [ integer SOCKOPT_RCVMORE ] { 13 }
- Constant [ integer SOCKOPT_FD ] { 14 }
- Constant [ integer SOCKOPT_EVENTS ] { 15 }
- Constant [ integer SOCKOPT_SNDTIMEO ] { 28 }
- Constant [ integer SOCKOPT_RCVTIMEO ] { 27 }
- Constant [ integer SOCKOPT_IPV4ONLY ] { 31 }
- Constant [ integer SOCKOPT_LAST_ENDPOINT ] { 32 }
- Constant [ integer SOCKOPT_TCP_KEEPALIVE ] { 34 }
- Constant [ integer SOCKOPT_TCP_KEEPALIVE_IDLE ] { 36 }
- Constant [ integer SOCKOPT_TCP_KEEPALIVE_CNT ] { 35 }
- Constant [ integer SOCKOPT_TCP_KEEPALIVE_INTVL ] { 37 }
- Constant [ integer SOCKOPT_TCP_ACCEPT_FILTER ] { 38 }
- Constant [ integer SOCKOPT_DELAY_ATTACH_ON_CONNECT ] { 39 }
- Constant [ integer SOCKOPT_XPUB_VERBOSE ] { 40 }
- Constant [ integer SOCKOPT_ROUTER_MANDATORY ] { 33 }
- Constant [ integer SOCKOPT_ROUTER_RAW ] { 41 }
- Constant [ integer SOCKOPT_IPV6 ] { 42 }
- Constant [ integer SOCKOPT_PLAIN_SERVER ] { 44 }
- Constant [ integer SOCKOPT_PLAIN_USERNAME ] { 45 }
- Constant [ integer SOCKOPT_PLAIN_PASSWORD ] { 46 }
- Constant [ integer SOCKOPT_CURVE_SERVER ] { 47 }
- Constant [ integer SOCKOPT_CURVE_PUBLICKEY ] { 48 }
- Constant [ integer SOCKOPT_CURVE_SECRETKEY ] { 49 }
- Constant [ integer SOCKOPT_CURVE_SERVERKEY ] { 50 }
- Constant [ integer SOCKOPT_PROBE_ROUTER ] { 51 }
- Constant [ integer SOCKOPT_REQ_CORRELATE ] { 52 }
- Constant [ integer SOCKOPT_REQ_RELAXED ] { 53 }
- Constant [ integer SOCKOPT_CONFLATE ] { 54 }
- Constant [ integer SOCKOPT_ZAP_DOMAIN ] { 55 }
- Constant [ integer CTXOPT_MAX_SOCKETS ] { 2 }
- Constant [ integer CTXOPT_MAX_SOCKETS_DEFAULT ] { 1023 }
+ - Constants [122] {
+ Constant [ public int SOCKET_PAIR ] { 0 }
+ Constant [ public int SOCKET_PUB ] { 1 }
+ Constant [ public int SOCKET_SUB ] { 2 }
+ Constant [ public int SOCKET_REQ ] { 3 }
+ Constant [ public int SOCKET_REP ] { 4 }
+ Constant [ public int SOCKET_XREQ ] { 5 }
+ Constant [ public int SOCKET_XREP ] { 6 }
+ Constant [ public int SOCKET_PUSH ] { 8 }
+ Constant [ public int SOCKET_PULL ] { 7 }
+ Constant [ public int SOCKET_DEALER ] { 5 }
+ Constant [ public int SOCKET_ROUTER ] { 6 }
+ Constant [ public int SOCKET_XSUB ] { 10 }
+ Constant [ public int SOCKET_XPUB ] { 9 }
+ Constant [ public int SOCKET_STREAM ] { 11 }
+ Constant [ public int SOCKET_UPSTREAM ] { 7 }
+ Constant [ public int SOCKET_DOWNSTREAM ] { 8 }
+ Constant [ public int POLL_IN ] { 1 }
+ Constant [ public int POLL_OUT ] { 2 }
+ Constant [ public int MODE_SNDMORE ] { 2 }
+ Constant [ public int MODE_NOBLOCK ] { 1 }
+ Constant [ public int MODE_DONTWAIT ] { 1 }
+ Constant [ public int ERR_INTERNAL ] { -99 }
+ Constant [ public int ERR_EAGAIN ] { 11 }
+ Constant [ public int ERR_ENOTSUP ] { 95 }
+ Constant [ public int ERR_EFSM ] { 156384763 }
+ Constant [ public int ERR_ETERM ] { 156384765 }
+ Constant [ public string LIBZMQ_VER ] { 4.3.4 }
+ Constant [ public string LIBZMQ_VERSION ] { 4.3.4 }
+ Constant [ public int LIBZMQ_VERSION_ID ] { 40304 }
+ Constant [ public int LIBZMQ_VERSION_MAJOR ] { 4 }
+ Constant [ public int LIBZMQ_VERSION_MINOR ] { 3 }
+ Constant [ public int LIBZMQ_VERSION_PATCH ] { 4 }
+ Constant [ public int SOCKOPT_HEARTBEAT_IVL ] { 75 }
+ Constant [ public int SOCKOPT_HEARTBEAT_TTL ] { 76 }
+ Constant [ public int SOCKOPT_HEARTBEAT_TIMEOUT ] { 77 }
+ Constant [ public int SOCKOPT_USE_FD ] { 89 }
+ Constant [ public int SOCKOPT_XPUB_MANUAL ] { 71 }
+ Constant [ public int SOCKOPT_XPUB_WELCOME_MSG ] { 72 }
+ Constant [ public int SOCKOPT_STREAM_NOTIFY ] { 73 }
+ Constant [ public int SOCKOPT_INVERT_MATCHING ] { 74 }
+ Constant [ public int SOCKOPT_XPUB_VERBOSER ] { 78 }
+ Constant [ public int SOCKOPT_CONNECT_TIMEOUT ] { 79 }
+ Constant [ public int SOCKOPT_TCP_MAXRT ] { 80 }
+ Constant [ public int SOCKOPT_THREAD_SAFE ] { 81 }
+ Constant [ public int SOCKOPT_MULTICAST_MAXTPDU ] { 84 }
+ Constant [ public int SOCKOPT_VMCI_BUFFER_SIZE ] { 85 }
+ Constant [ public int SOCKOPT_VMCI_BUFFER_MIN_SIZE ] { 86 }
+ Constant [ public int SOCKOPT_VMCI_BUFFER_MAX_SIZE ] { 87 }
+ Constant [ public int SOCKOPT_VMCI_CONNECT_TIMEOUT ] { 88 }
+ Constant [ public int SOCKOPT_TOS ] { 57 }
+ Constant [ public int SOCKOPT_ROUTER_HANDOVER ] { 56 }
+ Constant [ public int SOCKOPT_CONNECT_RID ] { 61 }
+ Constant [ public int SOCKOPT_HANDSHAKE_IVL ] { 66 }
+ Constant [ public int SOCKOPT_SOCKS_PROXY ] { 68 }
+ Constant [ public int SOCKOPT_XPUB_NODROP ] { 69 }
+ Constant [ public int SOCKOPT_ROUTER_MANDATORY ] { 33 }
+ Constant [ public int SOCKOPT_PROBE_ROUTER ] { 51 }
+ Constant [ public int SOCKOPT_REQ_RELAXED ] { 53 }
+ Constant [ public int SOCKOPT_REQ_CORRELATE ] { 52 }
+ Constant [ public int SOCKOPT_CONFLATE ] { 54 }
+ Constant [ public int SOCKOPT_ZAP_DOMAIN ] { 55 }
+ Constant [ public int SOCKOPT_MECHANISM ] { 43 }
+ Constant [ public int SOCKOPT_PLAIN_SERVER ] { 44 }
+ Constant [ public int SOCKOPT_PLAIN_USERNAME ] { 45 }
+ Constant [ public int SOCKOPT_PLAIN_PASSWORD ] { 46 }
+ Constant [ public int SOCKOPT_CURVE_SERVER ] { 47 }
+ Constant [ public int SOCKOPT_CURVE_PUBLICKEY ] { 48 }
+ Constant [ public int SOCKOPT_CURVE_SECRETKEY ] { 49 }
+ Constant [ public int SOCKOPT_CURVE_SERVERKEY ] { 50 }
+ Constant [ public int SOCKOPT_GSSAPI_SERVER ] { 62 }
+ Constant [ public int SOCKOPT_GSSAPI_PLAINTEXT ] { 65 }
+ Constant [ public int SOCKOPT_GSSAPI_PRINCIPAL ] { 63 }
+ Constant [ public int SOCKOPT_GSSAPI_SERVICE_PRINCIPAL ] { 64 }
+ Constant [ public int SOCKOPT_IPV6 ] { 42 }
+ Constant [ public int SOCKOPT_IMMEDIATE ] { 39 }
+ Constant [ public int SOCKOPT_ROUTER_RAW ] { 41 }
+ Constant [ public int SOCKOPT_IPV4ONLY ] { 31 }
+ Constant [ public int SOCKOPT_DELAY_ATTACH_ON_CONNECT ] { 39 }
+ Constant [ public int SOCKOPT_TYPE ] { 16 }
+ Constant [ public int SOCKOPT_SNDHWM ] { 23 }
+ Constant [ public int SOCKOPT_RCVHWM ] { 24 }
+ Constant [ public int SOCKOPT_AFFINITY ] { 4 }
+ Constant [ public int SOCKOPT_SUBSCRIBE ] { 6 }
+ Constant [ public int SOCKOPT_UNSUBSCRIBE ] { 7 }
+ Constant [ public int SOCKOPT_IDENTITY ] { 5 }
+ Constant [ public int SOCKOPT_RATE ] { 8 }
+ Constant [ public int SOCKOPT_RECOVERY_IVL ] { 9 }
+ Constant [ public int SOCKOPT_SNDBUF ] { 11 }
+ Constant [ public int SOCKOPT_RCVBUF ] { 12 }
+ Constant [ public int SOCKOPT_LINGER ] { 17 }
+ Constant [ public int SOCKOPT_RECONNECT_IVL ] { 18 }
+ Constant [ public int SOCKOPT_RECONNECT_IVL_MAX ] { 21 }
+ Constant [ public int SOCKOPT_BACKLOG ] { 19 }
+ Constant [ public int SOCKOPT_MAXMSGSIZE ] { 22 }
+ Constant [ public int SOCKOPT_MULTICAST_HOPS ] { 25 }
+ Constant [ public int SOCKOPT_RCVTIMEO ] { 27 }
+ Constant [ public int SOCKOPT_SNDTIMEO ] { 28 }
+ Constant [ public int SOCKOPT_XPUB_VERBOSE ] { 40 }
+ Constant [ public int SOCKOPT_TCP_KEEPALIVE ] { 34 }
+ Constant [ public int SOCKOPT_TCP_KEEPALIVE_IDLE ] { 36 }
+ Constant [ public int SOCKOPT_TCP_KEEPALIVE_CNT ] { 35 }
+ Constant [ public int SOCKOPT_TCP_KEEPALIVE_INTVL ] { 37 }
+ Constant [ public int SOCKOPT_TCP_ACCEPT_FILTER ] { 38 }
+ Constant [ public int SOCKOPT_RCVMORE ] { 13 }
+ Constant [ public int SOCKOPT_FD ] { 14 }
+ Constant [ public int SOCKOPT_EVENTS ] { 15 }
+ Constant [ public int SOCKOPT_LAST_ENDPOINT ] { 32 }
+ Constant [ public int SOCKOPT_HWM ] { 2001 }
+ Constant [ public int CTXOPT_MAX_SOCKETS ] { 2 }
+ Constant [ public int CTXOPT_MAX_SOCKETS_DEFAULT ] { 1023 }
+ Constant [ public int EVENT_CONNECTED ] { 1 }
+ Constant [ public int EVENT_CONNECT_DELAYED ] { 2 }
+ Constant [ public int EVENT_CONNECT_RETRIED ] { 4 }
+ Constant [ public int EVENT_LISTENING ] { 8 }
+ Constant [ public int EVENT_BIND_FAILED ] { 16 }
+ Constant [ public int EVENT_ACCEPTED ] { 32 }
+ Constant [ public int EVENT_ACCEPT_FAILED ] { 64 }
+ Constant [ public int EVENT_CLOSED ] { 128 }
+ Constant [ public int EVENT_CLOSE_FAILED ] { 256 }
+ Constant [ public int EVENT_DISCONNECTED ] { 512 }
+ Constant [ public int EVENT_MONITOR_STOPPED ] { 1024 }
+ Constant [ public int EVENT_ALL ] { 65535 }
}
- Static properties [0] {
}
- - Static methods [1] {
+ - Static methods [4] {
Method [ <internal:zmq> static public method clock ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:zmq> static public method z85encode ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:zmq> static public method z85decode ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+
+ Method [ <internal:zmq> static public method curvekeypair ] {
+
+ - Parameters [0] {
+ }
+ }
}
- Properties [0] {
@@ -115,18 +179,29 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:zmq> static public method acquire ] {
+
+ - Parameters [0] {
+ }
+ }
}
- Properties [0] {
}
- - Methods [6] {
+ - Methods [7] {
Method [ <internal:zmq, ctor> final public method __construct ] {
- Parameters [2] {
- Parameter #0 [ <optional> $io_threads ]
- Parameter #1 [ <optional> $persistent ]
+ Parameter #0 [ <optional> $io_threads = <default> ]
+ Parameter #1 [ <optional> $persistent = <default> ]
+ }
+ }
+
+ Method [ <internal:zmq> public method getsocketcount ] {
+
+ - Parameters [0] {
}
}
@@ -135,7 +210,7 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [3] {
Parameter #0 [ <required> $type ]
Parameter #1 [ <required> $dsn ]
- Parameter #2 [ <optional> $on_new_socket ]
+ Parameter #2 [ <optional> $on_new_socket = <default> ]
}
}
@@ -182,14 +257,14 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Properties [0] {
}
- - Methods [18] {
+ - Methods [20] {
Method [ <internal:zmq, ctor> final public method __construct ] {
- Parameters [4] {
Parameter #0 [ <required> ZMQContext $ZMQContext ]
Parameter #1 [ <required> $type ]
- Parameter #2 [ <optional> $persistent_id ]
- Parameter #3 [ <optional> $on_new_socket ]
+ Parameter #2 [ <optional> $persistent_id = <default> ]
+ Parameter #3 [ <optional> $on_new_socket = <default> ]
}
}
@@ -197,14 +272,14 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [2] {
Parameter #0 [ <required> $message ]
- Parameter #1 [ <optional> $mode ]
+ Parameter #1 [ <optional> $mode = <default> ]
}
}
Method [ <internal:zmq> public method recv ] {
- Parameters [1] {
- Parameter #0 [ <optional> $mode ]
+ Parameter #0 [ <optional> $mode = <default> ]
}
}
@@ -212,14 +287,14 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [2] {
Parameter #0 [ <required> $message ]
- Parameter #1 [ <optional> $mode ]
+ Parameter #1 [ <optional> $mode = <default> ]
}
}
Method [ <internal:zmq> public method recvmulti ] {
- Parameters [1] {
- Parameter #0 [ <optional> $mode ]
+ Parameter #0 [ <optional> $mode = <default> ]
}
}
@@ -227,7 +302,7 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [2] {
Parameter #0 [ <required> $dsn ]
- Parameter #1 [ <optional> $force ]
+ Parameter #1 [ <optional> $force = <default> ]
}
}
@@ -235,7 +310,22 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [2] {
Parameter #0 [ <required> $dsn ]
- Parameter #1 [ <optional> $force ]
+ Parameter #1 [ <optional> $force = <default> ]
+ }
+ }
+
+ Method [ <internal:zmq> public method monitor ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $dsn ]
+ Parameter #1 [ <optional> $events = <default> ]
+ }
+ }
+
+ Method [ <internal:zmq> public method recvevent ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $flags = <default> ]
}
}
@@ -302,14 +392,14 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [2] {
Parameter #0 [ <required> $message ]
- Parameter #1 [ <optional> $mode ]
+ Parameter #1 [ <optional> $mode = <default> ]
}
}
Method [ <internal:zmq> public method recvmsg ] {
- Parameters [1] {
- Parameter #0 [ <optional> $mode ]
+ Parameter #0 [ <optional> $mode = <default> ]
}
}
}
@@ -329,7 +419,7 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Properties [0] {
}
- - Methods [7] {
+ - Methods [8] {
Method [ <internal:zmq> public method add ] {
- Parameters [2] {
@@ -343,7 +433,7 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [3] {
Parameter #0 [ <required> &$readable ]
Parameter #1 [ <required> &$writable ]
- Parameter #2 [ <optional> $timeout ]
+ Parameter #2 [ <optional> $timeout = <default> ]
}
}
@@ -372,6 +462,12 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
}
}
+ Method [ <internal:zmq> public method items ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:zmq> final private method __clone ] {
- Parameters [0] {
@@ -400,7 +496,7 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [3] {
Parameter #0 [ <required> ZMQSocket $frontend ]
Parameter #1 [ <required> ZMQSocket $backend ]
- Parameter #2 [ <optional> ZMQSocket $capture ]
+ Parameter #2 [ <optional> ZMQSocket $capture = <default> ]
}
}
@@ -415,7 +511,7 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [3] {
Parameter #0 [ <required> $idle_callback ]
Parameter #1 [ <required> $timeout ]
- Parameter #2 [ <optional> $user_data ]
+ Parameter #2 [ <optional> $user_data = <default> ]
}
}
@@ -437,7 +533,7 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
- Parameters [3] {
Parameter #0 [ <required> $idle_callback ]
Parameter #1 [ <required> $timeout ]
- Parameter #2 [ <optional> $user_data ]
+ Parameter #2 [ <optional> $user_data = <default> ]
}
}
@@ -462,7 +558,7 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
}
}
- Class [ <internal:zmq> class ZMQException extends Exception ] {
+ Class [ <internal:zmq> class ZMQException extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -474,52 +570,87 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:zmq> final class ZMQContextException extends ZMQException ] {
+ Class [ <internal:zmq> final class ZMQContextException extends ZMQException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -531,52 +662,87 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:zmq> final class ZMQSocketException extends ZMQException ] {
+ Class [ <internal:zmq> final class ZMQSocketException extends ZMQException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -588,52 +754,87 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:zmq> final class ZMQPollException extends ZMQException ] {
+ Class [ <internal:zmq> final class ZMQPollException extends ZMQException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -645,52 +846,87 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:zmq> final class ZMQDeviceException extends ZMQException ] {
+ Class [ <internal:zmq> final class ZMQDeviceException extends ZMQException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -702,47 +938,82 @@ Extension [ <persistent> extension #193 zmq version 1.1.3 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
- Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ void ]
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-zmq.spec b/php-pecl-zmq.spec
index e89a618..fac79c2 100644
--- a/php-pecl-zmq.spec
+++ b/php-pecl-zmq.spec
@@ -3,15 +3,13 @@
#
# Fedora spec file for php-pecl-zmq
#
-# Copyright (c) 2013-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2013-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%if 0%{?scl:1}
-%scl_package php-pecl-zmq
-%endif
+%{?scl:%scl_package php-pecl-zmq}
%bcond_without tests
@@ -22,12 +20,14 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Summary: ZeroMQ messaging
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.1.3
-Release: 16%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-License: BSD
+Release: 17%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: BSD-3-Clause
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
@@ -45,7 +45,6 @@ BuildRequires: pkgconfig
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
# Version 1.0.7 is the first pecl release
# Fedora/EPEL still provides php-zmq, not php-pecl-zmq
@@ -55,25 +54,6 @@ Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}-99
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
%description
ZeroMQ is a software library that lets you quickly design and implement
@@ -90,12 +70,10 @@ sed -e 's/role="test"/role="src"/' \
%{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
-mv %{pecl_name}-%{version} NTS
-
-cd NTS
-%patch0 -p1 -b .pr216
-%patch1 -p1 -b .pr222
-%patch2 -p1 -b .pr228
+cd %{sources}
+%patch -P0 -p1 -b .pr216
+%patch -P1 -p1 -b .pr222
+%patch -P2 -p1 -b .pr228
if pkg-config libzmq --atleast-version=4
then
@@ -113,9 +91,9 @@ if test "x${extver}" != "x%{version}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -128,21 +106,22 @@ EOF
%build
%{?dtsenable}
-cd NTS
-%{_bindir}/phpize
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
--with-zmq \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
+ --with-php-config=%{__phpconfig}
make %{?_smp_mflags}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
%configure \
--with-zmq \
--with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig}
make %{?_smp_mflags}
%endif
@@ -168,7 +147,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -193,30 +172,30 @@ fi
%check
-cd NTS
+cd %{sources}
+
: Minimal load test for NTS extension
%{__php} --no-php-ini \
- --define extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%if %{with tests}
: upstream test suite for NTS extension
-export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
+export TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so"
export REPORT_EXIT_STATUS=1
export TEST_PHP_EXECUTABLE=%{__php}
%{__php} -n run-tests.php -q --show-diff
%endif
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
- --define extension=%{buildroot}/%{php_ztsextdir}/%{pecl_name}.so \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
%if %{with tests}
: upstream test suite for ZTS extension
-export TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so"
+export TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so"
export TEST_PHP_EXECUTABLE=%{__ztsphp}
%{__ztsphp} -n run-tests.php -q --show-diff
%endif
@@ -224,7 +203,7 @@ export TEST_PHP_EXECUTABLE=%{__ztsphp}
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -238,6 +217,9 @@ export TEST_PHP_EXECUTABLE=%{__ztsphp}
%changelog
+* Thu Jul 20 2023 Remi Collet <remi@remirepo.net> - 1.1.3-17
+- build out of sources tree
+
* Fri Jun 17 2022 Remi Collet <remi@remirepo.net> - 1.1.3-16
- add patch for PHP 8.2 from https://github.com/zeromq/php-zmq/pull/228