summaryrefslogtreecommitdiffstats
path: root/php-pecl-zip.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-zip.spec')
-rw-r--r--php-pecl-zip.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index 04dc9fd..1baab90 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -42,7 +42,7 @@
Summary: A ZIP archive management extension
Name: %{?scl_prefix}php-pecl-zip
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
Group: Development/Languages
URL: https://pecl.php.net/package/zip
@@ -129,6 +129,8 @@ export PKG_CONFIG_PATH=/opt/%{?vendeur:%{vendeur}/}libzip/%{_lib}/pkgconfig
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
@@ -136,7 +138,7 @@ cd ../NTS
--with-libdir=%{_lib} \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
@@ -145,21 +147,21 @@ cd ../ZTS
--with-libdir=%{_lib} \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -221,6 +223,9 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
%changelog
+* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 1.22.3-5
+- rebuild for 8.4.0RC1
+
* Wed Aug 21 2024 Remi Collet <remi@remirepo.net> - 1.22.3-4
- fix previous patch (for 8.0)