summaryrefslogtreecommitdiffstats
path: root/php-pecl-zip.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-zip.spec')
-rw-r--r--php-pecl-zip.spec19
1 files changed, 9 insertions, 10 deletions
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index 60ef394..fcaec5d 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -18,11 +18,11 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name zip
-%global upstream_version 1.20.1
+%global upstream_version 1.21.0
#global upstream_prever dev
#global upstream_lower DEV
-%global libzip_version 1.8.0
+%global libzip_version 1.9.1
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -34,15 +34,13 @@
Summary: A ZIP archive management extension
Name: %{?scl_prefix}php-pecl-zip
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/zip
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: 0001-support-8.2.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -146,8 +144,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php7/php_zip.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}" -a "x${extver}" != "x%{upstream_version}-%{?upstream_prever}"; then
@@ -219,9 +215,6 @@ done
%check
OPT="-q --show-diff"
-%if "%{php_version}" > "8.0"
-OPT="$OPT %{?_smp_mflags}"
-%endif
cd NTS
: minimal load test of NTS extension
@@ -285,6 +278,12 @@ fi
%changelog
+* Tue Jun 28 2022 Remi Collet <remi@remirepo.net> - 1.21.0-1
+- update to 1.21.0
+
+* Mon Jun 13 2022 Remi Collet <remi@remirepo.net> - 1.20.1-3
+- more upstream patch for PHP 8.2
+
* Wed May 11 2022 Remi Collet <remi@remirepo.net> - 1.20.1-2
- add upstream patch for PHP 8.2