summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION35
-rw-r--r--php-pecl-zip.spec39
2 files changed, 38 insertions, 36 deletions
diff --git a/REFLECTION b/REFLECTION
index 691b222..a2d9aed 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #140 zip version 1.13.5 ] {
+Extension [ <persistent> extension #159 zip version 1.14.0 ] {
- Functions {
Function [ <internal:zip> function zip_open ] {
@@ -69,7 +69,7 @@ Extension [ <persistent> extension #140 zip version 1.13.5 ] {
- Classes [1] {
Class [ <internal:zip> class ZipArchive ] {
- - Constants [75] {
+ - Constants [79] {
Constant [ integer CREATE ] { 1 }
Constant [ integer EXCL ] { 2 }
Constant [ integer CHECKCONS ] { 4 }
@@ -145,6 +145,10 @@ Extension [ <persistent> extension #140 zip version 1.13.5 ] {
Constant [ integer OPSYS_OS_400 ] { 18 }
Constant [ integer OPSYS_OS_X ] { 19 }
Constant [ integer OPSYS_DEFAULT ] { 3 }
+ Constant [ integer EM_NONE ] { 0 }
+ Constant [ integer EM_AES_128 ] { 257 }
+ Constant [ integer EM_AES_192 ] { 258 }
+ Constant [ integer EM_AES_256 ] { 259 }
}
- Static properties [0] {
@@ -153,10 +157,15 @@ Extension [ <persistent> extension #140 zip version 1.13.5 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [5] {
+ Property [ <default> public $status ]
+ Property [ <default> public $statusSys ]
+ Property [ <default> public $numFiles ]
+ Property [ <default> public $filename ]
+ Property [ <default> public $comment ]
}
- - Methods [37] {
+ - Methods [39] {
Method [ <internal:zip> public method open ] {
- Parameters [2] {
@@ -451,6 +460,24 @@ Extension [ <persistent> extension #140 zip version 1.13.5 ] {
Parameter #2 [ <optional> $compflags ]
}
}
+
+ Method [ <internal:zip> public method setEncryptionName ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $method ]
+ Parameter #2 [ <optional> $password ]
+ }
+ }
+
+ Method [ <internal:zip> public method setEncryptionIndex ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $index ]
+ Parameter #1 [ <required> $method ]
+ Parameter #2 [ <optional> $password ]
+ }
+ }
}
}
}
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index cc5b230..29558d3 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -14,41 +14,27 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name zip
-%if 0%{?rhel} != 5
-%global with_libzip 1
-%else
-%global with_libzip 0
-%endif
-
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global prever dev
+#global prever dev
Summary: A ZIP archive management extension
Summary(fr): Une extension de gestion des ZIP
Name: %{?scl_prefix}php-pecl-zip
Version: 1.14.0
-Release: 0.2.20170301dev%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%if %{with_libzip}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
-%else
-# Zip extension is PHP, Libzip library is BSD
-License: PHP and BSD
-%endif
Group: Development/Languages
URL: http://pecl.php.net/package/zip
Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
-%if %{with_libzip}
# Version 1.2.0 for encryption support
BuildRequires: pkgconfig(libzip) >= 1.2.0
-%endif
BuildRequires: zlib-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -120,17 +106,11 @@ cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php5/php_zip.h)
-if test "x${extver}" != "x%{version}-%{?prever}"; then
+if test "x${extver}" != "x%{version}%{?prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
fi
-%if %{with_libzip}
-sed -e '/LICENSE_libzip/d' -i ../package.xml
-# delete bundled libzip to ensure it is not used
-rm -r lib
-%endif
-
cd ..
: Create the configuration file
cat >%{ini_name} << 'EOF'
@@ -150,9 +130,7 @@ cp -pr NTS ZTS
cd NTS
%{_bindir}/phpize
%configure \
-%if %{with_libzip}
--with-libzip \
-%endif
--with-libdir=%{_lib} \
--with-php-config=%{_bindir}/php-config
@@ -162,9 +140,7 @@ make %{?_smp_mflags}
cd ../ZTS
%{_bindir}/zts-phpize
%configure \
-%if %{with_libzip}
--with-libzip \
-%endif
--with-libdir=%{_lib} \
--with-php-config=%{_bindir}/zts-php-config
@@ -173,7 +149,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
@@ -228,9 +203,6 @@ TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
%endif
-%clean
-rm -rf %{buildroot}
-
%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
@@ -252,7 +224,6 @@ fi
%files
-%defattr(-, root, root, -)
%{?_licensedir:%license NTS/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -267,6 +238,10 @@ fi
%changelog
+* Wed Apr 5 2017 Remi Collet <remi@remirepo.net> - 1.14.1-1
+- update to 1.14.0 (stable)
+- always buid with system libzip (bundled lib dropped upstream)
+
* Wed Mar 1 2017 Remi Collet <remi@fedoraproject.org> - 1.14.0-0.2.20170301dev
- refresh with pasword support in stream wrapper