summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION14
-rw-r--r--php-pecl-zip.spec7
3 files changed, 19 insertions, 4 deletions
diff --git a/PHPINFO b/PHPINFO
index 07ccec0..236b8ae 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
zip
Zip => enabled
-Zip version => 1.16.0
+Zip version => 1.16.1
Libzip headers version => 1.6.0
Libzip library version => 1.6.0
diff --git a/REFLECTION b/REFLECTION
index a5d4f68..4ee2de8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #98 zip version 1.16.0 ] {
+Extension [ <persistent> extension #98 zip version 1.16.1 ] {
- Functions {
Function [ <internal:zip> function zip_open ] {
@@ -69,7 +69,7 @@ Extension [ <persistent> extension #98 zip version 1.16.0 ] {
- Classes [1] {
Class [ <internal:zip> class ZipArchive implements Countable ] {
- - Constants [82] {
+ - Constants [92] {
Constant [ public int CREATE ] { 1 }
Constant [ public int EXCL ] { 2 }
Constant [ public int CHECKCONS ] { 4 }
@@ -97,6 +97,7 @@ Extension [ <persistent> extension #98 zip version 1.16.0 ] {
Constant [ public int CM_BZIP2 ] { 12 }
Constant [ public int CM_LZMA ] { 14 }
Constant [ public int CM_LZMA2 ] { 33 }
+ Constant [ public int CM_XZ ] { 95 }
Constant [ public int CM_TERSE ] { 18 }
Constant [ public int CM_LZ77 ] { 19 }
Constant [ public int CM_WAVPACK ] { 97 }
@@ -125,6 +126,15 @@ Extension [ <persistent> extension #98 zip version 1.16.0 ] {
Constant [ public int ER_INCONS ] { 21 }
Constant [ public int ER_REMOVE ] { 22 }
Constant [ public int ER_DELETED ] { 23 }
+ Constant [ public int ER_ENCRNOTSUPP ] { 24 }
+ Constant [ public int ER_RDONLY ] { 25 }
+ Constant [ public int ER_NOPASSWD ] { 26 }
+ Constant [ public int ER_WRONGPASSWD ] { 27 }
+ Constant [ public int ER_OPNOTSUPP ] { 28 }
+ Constant [ public int ER_INUSE ] { 29 }
+ Constant [ public int ER_TELL ] { 30 }
+ Constant [ public int ER_COMPRESSED_DATA ] { 31 }
+ Constant [ public int ER_CANCELLED ] { 32 }
Constant [ public int OPSYS_DOS ] { 0 }
Constant [ public int OPSYS_AMIGA ] { 1 }
Constant [ public int OPSYS_OPENVMS ] { 2 }
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index b5ed698..4d69eea 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -31,7 +31,7 @@
Summary: A ZIP archive management extension
Summary(fr): Une extension de gestion des ZIP
Name: %{?scl_prefix}php-pecl-zip
-Version: 1.16.0
+Version: 1.16.1
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -258,7 +258,12 @@ fi
%endif
+#### TODO: SCLs on EL-8 still use libzip from default stream (7.2 => 1.5.1)
+
%changelog
+* Wed Jan 29 2020 Remi Collet <remi@remirepo.net> - 1.16.1-1
+- update to 1.16.1
+
* Mon Jan 27 2020 Remi Collet <remi@remirepo.net> - 1.16.0-1
- update to 1.16.0