summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION5
-rw-r--r--php-pecl-zip.spec15
3 files changed, 12 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index d39b37a..44000a6 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,10 +3,10 @@ zip
Zip => enabled
Zip version => 1.19.3
-Libzip version => 1.7.3
+Libzip version => 1.8.0
BZIP2 compression => Yes
XZ compression => Yes
-ZSTD compression => No
+ZSTD compression => Yes
AES-128 encryption => Yes
AES-192 encryption => Yes
AES-256 encryption => Yes
diff --git a/REFLECTION b/REFLECTION
index 3a17752..4d26c92 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -69,7 +69,7 @@ Extension [ <persistent> extension #107 zip version 1.19.3 ] {
- Classes [1] {
Class [ <internal:zip> class ZipArchive implements Countable ] {
- - Constants [100] {
+ - Constants [101] {
Constant [ public int CREATE ] { 1 }
Constant [ public int EXCL ] { 2 }
Constant [ public int CHECKCONS ] { 4 }
@@ -103,6 +103,7 @@ Extension [ <persistent> extension #107 zip version 1.19.3 ] {
Constant [ public int CM_BZIP2 ] { 12 }
Constant [ public int CM_LZMA ] { 14 }
Constant [ public int CM_LZMA2 ] { 33 }
+ Constant [ public int CM_ZSTD ] { 93 }
Constant [ public int CM_XZ ] { 95 }
Constant [ public int CM_TERSE ] { 18 }
Constant [ public int CM_LZ77 ] { 19 }
@@ -169,7 +170,7 @@ Extension [ <persistent> extension #107 zip version 1.19.3 ] {
Constant [ public int EM_AES_192 ] { 258 }
Constant [ public int EM_AES_256 ] { 259 }
Constant [ public int EM_UNKNOWN ] { 65535 }
- Constant [ public string LIBZIP_VERSION ] { 1.7.3 }
+ Constant [ public string LIBZIP_VERSION ] { 1.8.0 }
}
- Static properties [0] {
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index 0fc2c31..962abe7 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -22,7 +22,7 @@
#global upstream_prever dev
#global upstream_lower DEV
-%global libzip_version 1.7.3
+%global libzip_version 1.8.0
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -31,10 +31,9 @@
%endif
Summary: A ZIP archive management extension
-Summary(fr): Une extension de gestion des ZIP
Name: %{?scl_prefix}php-pecl-zip
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: https://pecl.php.net/package/zip
@@ -120,12 +119,9 @@ Obsoletes: %{?scl_prefix}php-zip <= 7.0.0
%description
Zip is an extension to create and read zip files.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
-
-%description -l fr
-Zip est une extension pour créer et lire les archives au format ZIP.
+Package built with libzip %{libzip_version}.
-Paquet construit pour PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: en Software Collection (%{scl} by %{scl_vendor})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
%prep
@@ -268,6 +264,9 @@ fi
%changelog
+* Sat Jun 19 2021 Remi Collet <remi@remirepo.net> - 1.19.3-2
+- rebuild with libzip 1.8.0 and zstd support
+
* Mon Jun 7 2021 Remi Collet <remi@remirepo.net> - 1.19.3-1
- update to 1.19.3