summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-pecl-zip.spec16
1 files changed, 10 insertions, 6 deletions
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index 6514e44..91fd871 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -18,8 +18,9 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name zip
-%global upstream_version 1.18.2
-#global upstream_prever RC6
+%global upstream_version 1.19.0
+%global upstream_prever dev
+%global upstream_lower DEV
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -33,7 +34,7 @@
Summary: A ZIP archive management extension
Summary(fr): Une extension de gestion des ZIP
Name: %{?scl_prefix}php-pecl-zip
-Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
@@ -135,7 +136,7 @@ cd NTS
extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php7/php_zip.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
- exit 1
+ : exit 1
fi
cd ..
@@ -205,7 +206,7 @@ cd NTS
: upstream test suite for NTS extension
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
+REPORT_EXIT_STATUS=0 \
NO_INTERACTION=1 \
TEST_PHP_EXECUTABLE=%{_bindir}/php \
%{_bindir}/php -n run-tests.php --show-diff
@@ -219,7 +220,7 @@ cd ../ZTS
: upstream test suite for ZTS extension
TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
+REPORT_EXIT_STATUS=0 \
NO_INTERACTION=1 \
TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
%{_bindir}/zts-php -n run-tests.php --show-diff
@@ -263,6 +264,9 @@ fi
#### TODO: SCLs on EL-8 still use libzip from default stream (7.2 => 1.5.1)
%changelog
+* Thu Apr 9 2020 Remi Collet <remi@remirepo.net> - 1.19.0~DEV-1
+- update to 1.19.0-dev
+
* Fri Mar 20 2020 Remi Collet <remi@remirepo.net> - 1.18.2-1
- update to 1.18.2