summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-02-19 19:27:51 +0100
committerRemi Collet <fedora@famillecollet.com>2017-02-19 19:27:51 +0100
commitfaf7f94cf4d68a429cd782bfc47c7950ca5d1b89 (patch)
tree1e770008f94b097c1a4a2aeb9ac9cb04447d3d7a
parent248cd569573ed6fe915392365227a75fa6bc9043 (diff)
php-pecl-zip: 1.4.0dev with encryption support from libzip 1.2.0
-rw-r--r--REFLECTION-DEV28
-rw-r--r--php-pecl-zip-dev.spec18
2 files changed, 38 insertions, 8 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index 691b222..5b09bb1 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #140 zip version 1.13.5 ] {
+Extension [ <persistent> extension #158 zip version 1.14.0-dev ] {
- Functions {
Function [ <internal:zip> function zip_open ] {
@@ -69,7 +69,7 @@ Extension [ <persistent> extension #140 zip version 1.13.5 ] {
- Classes [1] {
Class [ <internal:zip> class ZipArchive ] {
- - Constants [75] {
+ - Constants [79] {
Constant [ integer CREATE ] { 1 }
Constant [ integer EXCL ] { 2 }
Constant [ integer CHECKCONS ] { 4 }
@@ -145,6 +145,10 @@ Extension [ <persistent> extension #140 zip version 1.13.5 ] {
Constant [ integer OPSYS_OS_400 ] { 18 }
Constant [ integer OPSYS_OS_X ] { 19 }
Constant [ integer OPSYS_DEFAULT ] { 3 }
+ Constant [ integer EM_NONE ] { 0 }
+ Constant [ integer EM_AES_128 ] { 257 }
+ Constant [ integer EM_AES_192 ] { 258 }
+ Constant [ integer EM_AES_256 ] { 259 }
}
- Static properties [0] {
@@ -156,7 +160,7 @@ Extension [ <persistent> extension #140 zip version 1.13.5 ] {
- Properties [0] {
}
- - Methods [37] {
+ - Methods [39] {
Method [ <internal:zip> public method open ] {
- Parameters [2] {
@@ -451,6 +455,24 @@ Extension [ <persistent> extension #140 zip version 1.13.5 ] {
Parameter #2 [ <optional> $compflags ]
}
}
+
+ Method [ <internal:zip> public method setEncryptionName ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $method ]
+ Parameter #2 [ <optional> $password ]
+ }
+ }
+
+ Method [ <internal:zip> public method setEncryptionIndex ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $index ]
+ Parameter #1 [ <required> $method ]
+ Parameter #2 [ <optional> $password ]
+ }
+ }
}
}
}
diff --git a/php-pecl-zip-dev.spec b/php-pecl-zip-dev.spec
index 9222b78..0d2b7bc 100644
--- a/php-pecl-zip-dev.spec
+++ b/php-pecl-zip-dev.spec
@@ -25,13 +25,13 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-#global prever dev
+%global prever dev
Summary: A ZIP archive management extension
Summary(fr): Une extension de gestion des ZIP
Name: %{?scl_prefix}php-pecl-zip
-Version: 1.13.5
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.14.0
+Release: 0.1.20170219dev%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{with_libzip}
License: PHP
%else
@@ -46,7 +46,8 @@ Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
%if %{with_libzip}
-BuildRequires: pkgconfig(libzip) >= 1.0.0
+# Version 1.2.0 for encryption support
+BuildRequires: pkgconfig(libzip) >= 1.2.0
%endif
BuildRequires: zlib-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -119,7 +120,7 @@ cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php5/php_zip.h)
-if test "x${extver}" != "x%{version}%{?prever}"; then
+if test "x${extver}" != "x%{version}-%{?prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
fi
@@ -144,6 +145,8 @@ cp -pr NTS ZTS
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -171,6 +174,7 @@ make %{?_smp_mflags}
%install
rm -rf %{buildroot}
+%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -263,6 +267,10 @@ fi
%changelog
+* Sun Feb 19 2017 Remi Collet <remi@fedoraproject.org> - 1.14.0-0.1.20170219dev
+- update to 1.4.0-dev with encryption support
+- raise dependency on libzip 1.2.0
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 1.13.5-2
- rebuild with PHP 7.1.0 GA