summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-28 09:01:46 +0100
committerRemi Collet <remi@remirepo.net>2020-01-28 09:01:46 +0100
commitc9970e1938b8afd4cc68be8f739b40ccb89fa9f4 (patch)
treecb389577266e0c0f4604627757b7158caa54f25f
parente722b172d4522a64d897a07c2f5d6cba9f3ef27d (diff)
v1.16.0
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-zip.spec11
3 files changed, 32 insertions, 9 deletions
diff --git a/PHPINFO b/PHPINFO
index e96fd30..07ccec0 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,6 +2,6 @@
zip
Zip => enabled
-Zip version => 1.15.5
-Libzip headers version => 1.5.2
+Zip version => 1.16.0
+Libzip headers version => 1.6.0
Libzip library version => 1.6.0
diff --git a/REFLECTION b/REFLECTION
index 247403b..a5d4f68 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #98 zip version 1.15.5 ] {
+Extension [ <persistent> extension #98 zip version 1.16.0 ] {
- Functions {
Function [ <internal:zip> function zip_open ] {
@@ -69,7 +69,7 @@ Extension [ <persistent> extension #98 zip version 1.15.5 ] {
- Classes [1] {
Class [ <internal:zip> class ZipArchive implements Countable ] {
- - Constants [80] {
+ - Constants [82] {
Constant [ public int CREATE ] { 1 }
Constant [ public int EXCL ] { 2 }
Constant [ public int CHECKCONS ] { 4 }
@@ -96,6 +96,7 @@ Extension [ <persistent> extension #98 zip version 1.15.5 ] {
Constant [ public int CM_PKWARE_IMPLODE ] { 10 }
Constant [ public int CM_BZIP2 ] { 12 }
Constant [ public int CM_LZMA ] { 14 }
+ Constant [ public int CM_LZMA2 ] { 33 }
Constant [ public int CM_TERSE ] { 18 }
Constant [ public int CM_LZ77 ] { 19 }
Constant [ public int CM_WAVPACK ] { 97 }
@@ -150,6 +151,7 @@ Extension [ <persistent> extension #98 zip version 1.15.5 ] {
Constant [ public int EM_AES_128 ] { 257 }
Constant [ public int EM_AES_192 ] { 258 }
Constant [ public int EM_AES_256 ] { 259 }
+ Constant [ public string LIBZIP_VERSION ] { 1.6.0 }
}
- Static properties [0] {
@@ -166,7 +168,7 @@ Extension [ <persistent> extension #98 zip version 1.15.5 ] {
Property [ <default> public $comment ]
}
- - Methods [40] {
+ - Methods [42] {
Method [ <internal:zip> public method open ] {
- Parameters [2] {
@@ -450,6 +452,24 @@ Extension [ <persistent> extension #98 zip version 1.15.5 ] {
}
}
+ Method [ <internal:zip> public method setMtimeName ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $name ]
+ Parameter #1 [ <required> $timestamp ]
+ Parameter #2 [ <optional> $flags ]
+ }
+ }
+
+ Method [ <internal:zip> public method setMtimeIndex ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $index ]
+ Parameter #1 [ <required> $timestamp ]
+ Parameter #2 [ <optional> $flags ]
+ }
+ }
+
Method [ <internal:zip> public method setCompressionName ] {
- Parameters [3] {
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index b523080..b5ed698 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -3,7 +3,7 @@
#
# fedora spec file for php-pecl-zip
#
-# Copyright (c) 2013-2019 Remi Collet
+# Copyright (c) 2013-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -31,13 +31,13 @@
Summary: A ZIP archive management extension
Summary(fr): Une extension de gestion des ZIP
Name: %{?scl_prefix}php-pecl-zip
-Version: 1.15.5
+Version: 1.16.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
-URL: http://pecl.php.net/package/zip
+URL: https://pecl.php.net/package/zip
-Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -259,6 +259,9 @@ fi
%changelog
+* Mon Jan 27 2020 Remi Collet <remi@remirepo.net> - 1.16.0-1
+- update to 1.16.0
+
* Mon Sep 9 2019 Remi Collet <remi@remirepo.net> - 1.15.5-1
- update to 1.15.5