summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-23 17:52:11 +0200
committerRemi Collet <remi@php.net>2023-08-23 17:52:11 +0200
commit6c56a4f68b3d497c96f47191484d4e649a03e542 (patch)
tree5c9014a1cb9ad20eb8ca035ba53ccd5219a2c6fe
parentc1e7b4852aff1ee4f2692d18fa31922498e7783e (diff)
update to 1.22.2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION12
-rw-r--r--php-pecl-zip.spec8
3 files changed, 14 insertions, 10 deletions
diff --git a/PHPINFO b/PHPINFO
index 5991baf..84b866b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
zip
Zip => enabled
-Zip version => 1.22.1
-Libzip version => 1.10.0
+Zip version => 1.22.2
+Libzip version => 1.10.1
BZIP2 compression => Yes
XZ compression => Yes
ZSTD compression => Yes
diff --git a/REFLECTION b/REFLECTION
index b7c9982..d09d6f8 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #66 zip version 1.22.1 ] {
+Extension [ <persistent> extension #66 zip version 1.22.2 ] {
- Functions {
Function [ <internal, deprecated:zip> function zip_open ] {
@@ -77,7 +77,7 @@ Extension [ <persistent> extension #66 zip version 1.22.1 ] {
- Classes [1] {
Class [ <internal:zip> class ZipArchive implements Countable ] {
- - Constants [107] {
+ - Constants [109] {
Constant [ public int CREATE ] { 1 }
Constant [ public int EXCL ] { 2 }
Constant [ public int CHECKCONS ] { 4 }
@@ -184,7 +184,9 @@ Extension [ <persistent> extension #66 zip version 1.22.1 ] {
Constant [ public int EM_AES_192 ] { 258 }
Constant [ public int EM_AES_256 ] { 259 }
Constant [ public int EM_UNKNOWN ] { 65535 }
- Constant [ public string LIBZIP_VERSION ] { 1.10.0 }
+ Constant [ public string LIBZIP_VERSION ] { 1.10.1 }
+ Constant [ public int LENGTH_TO_END ] { 0 }
+ Constant [ public int LENGTH_UNCHECKED ] { -2 }
}
- Static properties [0] {
@@ -290,7 +292,7 @@ Extension [ <persistent> extension #66 zip version 1.22.1 ] {
Parameter #0 [ <required> string $filepath ]
Parameter #1 [ <optional> string $entryname = "" ]
Parameter #2 [ <optional> int $start = 0 ]
- Parameter #3 [ <optional> int $length = 0 ]
+ Parameter #3 [ <optional> int $length = ZipArchive::LENGTH_TO_END ]
Parameter #4 [ <optional> int $flags = ZipArchive::FL_OVERWRITE ]
}
- Tentative return [ bool ]
@@ -302,7 +304,7 @@ Extension [ <persistent> extension #66 zip version 1.22.1 ] {
Parameter #0 [ <required> string $filepath ]
Parameter #1 [ <required> int $index ]
Parameter #2 [ <optional> int $start = 0 ]
- Parameter #3 [ <optional> int $length = 0 ]
+ Parameter #3 [ <optional> int $length = ZipArchive::LENGTH_TO_END ]
Parameter #4 [ <optional> int $flags = 0 ]
}
- Tentative return [ bool ]
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index 8c9b7fa..03b5560 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -26,11 +26,11 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name zip
-%global upstream_version 1.22.1
+%global upstream_version 1.22.2
#global upstream_prever dev
#global upstream_lower DEV
-%global libzip_version 1.10
+%global libzip_version 1.10.1
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -72,7 +72,6 @@ Requires: libzip%{?_isa} >= %{libzip_version}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
@@ -279,6 +278,9 @@ fi
%changelog
+* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 1.22.2-1
+- update to 1.22.2
+
* Thu Jun 29 2023 Remi Collet <remi@remirepo.net> - 1.22.1-1
- update to 1.22.1