summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-05 06:24:40 +0200
committerRemi Collet <remi@remirepo.net>2017-04-05 06:24:40 +0200
commit42df1b85ce1abc5e743634178c24eb25ce2c7368 (patch)
tree1cf2f821fed9b9ac033b54b6d418c9dd4910ebc2
parent206234cec8aa0263588b0d895a7ad61791f65e30 (diff)
cleanup
-rw-r--r--.gitignore7
-rw-r--r--REFLECTION-DEV480
-rw-r--r--php-pecl-zip-dev.spec347
-rw-r--r--php-pecl-zip.spec21
4 files changed, 23 insertions, 832 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
deleted file mode 100644
index 5b09bb1..0000000
--- a/REFLECTION-DEV
+++ /dev/null
@@ -1,480 +0,0 @@
-Extension [ <persistent> extension #158 zip version 1.14.0-dev ] {
-
- - Functions {
- Function [ <internal:zip> function zip_open ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $filename ]
- }
- }
- Function [ <internal:zip> function zip_close ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $zip ]
- }
- }
- Function [ <internal:zip> function zip_read ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $zip ]
- }
- }
- Function [ <internal:zip> function zip_entry_open ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $zip_dp ]
- Parameter #1 [ <required> $zip_entry ]
- Parameter #2 [ <optional> $mode ]
- }
- }
- Function [ <internal:zip> function zip_entry_close ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $zip_ent ]
- }
- }
- Function [ <internal:zip> function zip_entry_read ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $zip_entry ]
- Parameter #1 [ <optional> $len ]
- }
- }
- Function [ <internal:zip> function zip_entry_filesize ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $zip_entry ]
- }
- }
- Function [ <internal:zip> function zip_entry_name ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $zip_entry ]
- }
- }
- Function [ <internal:zip> function zip_entry_compressedsize ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $zip_entry ]
- }
- }
- Function [ <internal:zip> function zip_entry_compressionmethod ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $zip_entry ]
- }
- }
- }
-
- - Classes [1] {
- Class [ <internal:zip> class ZipArchive ] {
-
- - Constants [79] {
- Constant [ integer CREATE ] { 1 }
- Constant [ integer EXCL ] { 2 }
- Constant [ integer CHECKCONS ] { 4 }
- Constant [ integer OVERWRITE ] { 8 }
- Constant [ integer FL_NOCASE ] { 1 }
- Constant [ integer FL_NODIR ] { 2 }
- Constant [ integer FL_COMPRESSED ] { 4 }
- Constant [ integer FL_UNCHANGED ] { 8 }
- Constant [ integer FL_ENC_GUESS ] { 0 }
- Constant [ integer FL_ENC_RAW ] { 64 }
- Constant [ integer FL_ENC_STRICT ] { 128 }
- Constant [ integer FL_ENC_UTF_8 ] { 2048 }
- Constant [ integer FL_ENC_CP437 ] { 4096 }
- Constant [ integer CM_DEFAULT ] { -1 }
- Constant [ integer CM_STORE ] { 0 }
- Constant [ integer CM_SHRINK ] { 1 }
- Constant [ integer CM_REDUCE_1 ] { 2 }
- Constant [ integer CM_REDUCE_2 ] { 3 }
- Constant [ integer CM_REDUCE_3 ] { 4 }
- Constant [ integer CM_REDUCE_4 ] { 5 }
- Constant [ integer CM_IMPLODE ] { 6 }
- Constant [ integer CM_DEFLATE ] { 8 }
- Constant [ integer CM_DEFLATE64 ] { 9 }
- Constant [ integer CM_PKWARE_IMPLODE ] { 10 }
- Constant [ integer CM_BZIP2 ] { 12 }
- Constant [ integer CM_LZMA ] { 14 }
- Constant [ integer CM_TERSE ] { 18 }
- Constant [ integer CM_LZ77 ] { 19 }
- Constant [ integer CM_WAVPACK ] { 97 }
- Constant [ integer CM_PPMD ] { 98 }
- Constant [ integer ER_OK ] { 0 }
- Constant [ integer ER_MULTIDISK ] { 1 }
- Constant [ integer ER_RENAME ] { 2 }
- Constant [ integer ER_CLOSE ] { 3 }
- Constant [ integer ER_SEEK ] { 4 }
- Constant [ integer ER_READ ] { 5 }
- Constant [ integer ER_WRITE ] { 6 }
- Constant [ integer ER_CRC ] { 7 }
- Constant [ integer ER_ZIPCLOSED ] { 8 }
- Constant [ integer ER_NOENT ] { 9 }
- Constant [ integer ER_EXISTS ] { 10 }
- Constant [ integer ER_OPEN ] { 11 }
- Constant [ integer ER_TMPOPEN ] { 12 }
- Constant [ integer ER_ZLIB ] { 13 }
- Constant [ integer ER_MEMORY ] { 14 }
- Constant [ integer ER_CHANGED ] { 15 }
- Constant [ integer ER_COMPNOTSUPP ] { 16 }
- Constant [ integer ER_EOF ] { 17 }
- Constant [ integer ER_INVAL ] { 18 }
- Constant [ integer ER_NOZIP ] { 19 }
- Constant [ integer ER_INTERNAL ] { 20 }
- Constant [ integer ER_INCONS ] { 21 }
- Constant [ integer ER_REMOVE ] { 22 }
- Constant [ integer ER_DELETED ] { 23 }
- Constant [ integer OPSYS_DOS ] { 0 }
- Constant [ integer OPSYS_AMIGA ] { 1 }
- Constant [ integer OPSYS_OPENVMS ] { 2 }
- Constant [ integer OPSYS_UNIX ] { 3 }
- Constant [ integer OPSYS_VM_CMS ] { 4 }
- Constant [ integer OPSYS_ATARI_ST ] { 5 }
- Constant [ integer OPSYS_OS_2 ] { 6 }
- Constant [ integer OPSYS_MACINTOSH ] { 7 }
- Constant [ integer OPSYS_Z_SYSTEM ] { 8 }
- Constant [ integer OPSYS_Z_CPM ] { 9 }
- Constant [ integer OPSYS_WINDOWS_NTFS ] { 10 }
- Constant [ integer OPSYS_MVS ] { 11 }
- Constant [ integer OPSYS_VSE ] { 12 }
- Constant [ integer OPSYS_ACORN_RISC ] { 13 }
- Constant [ integer OPSYS_VFAT ] { 14 }
- Constant [ integer OPSYS_ALTERNATE_MVS ] { 15 }
- Constant [ integer OPSYS_BEOS ] { 16 }
- Constant [ integer OPSYS_TANDEM ] { 17 }
- Constant [ integer OPSYS_OS_400 ] { 18 }
- Constant [ integer OPSYS_OS_X ] { 19 }
- Constant [ integer OPSYS_DEFAULT ] { 3 }
- Constant [ integer EM_NONE ] { 0 }
- Constant [ integer EM_AES_128 ] { 257 }
- Constant [ integer EM_AES_192 ] { 258 }
- Constant [ integer EM_AES_256 ] { 259 }
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [39] {
- Method [ <internal:zip> public method open ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method setPassword ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $password ]
- }
- }
-
- Method [ <internal:zip> public method close ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:zip> public method getStatusString ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:zip> public method addEmptyDir ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $dirname ]
- }
- }
-
- Method [ <internal:zip> public method addFromString ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $content ]
- }
- }
-
- Method [ <internal:zip> public method addFile ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $filepath ]
- Parameter #1 [ <optional> $entryname ]
- Parameter #2 [ <optional> $start ]
- Parameter #3 [ <optional> $length ]
- }
- }
-
- Method [ <internal:zip> public method addGlob ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $pattern ]
- Parameter #1 [ <optional> $flags ]
- Parameter #2 [ <optional> $options ]
- }
- }
-
- Method [ <internal:zip> public method addPattern ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $pattern ]
- Parameter #1 [ <optional> $path ]
- Parameter #2 [ <optional> $options ]
- }
- }
-
- Method [ <internal:zip> public method renameIndex ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <required> $new_name ]
- }
- }
-
- Method [ <internal:zip> public method renameName ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $new_name ]
- }
- }
-
- Method [ <internal:zip> public method setArchiveComment ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $comment ]
- }
- }
-
- Method [ <internal:zip> public method getArchiveComment ] {
-
- - Parameters [1] {
- Parameter #0 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method setCommentIndex ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <required> $comment ]
- }
- }
-
- Method [ <internal:zip> public method setCommentName ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $comment ]
- }
- }
-
- Method [ <internal:zip> public method getCommentIndex ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method getCommentName ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method deleteIndex ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $index ]
- }
- }
-
- Method [ <internal:zip> public method deleteName ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $name ]
- }
- }
-
- Method [ <internal:zip> public method statName ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method statIndex ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method locateName ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $filename ]
- Parameter #1 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method getNameIndex ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method unchangeArchive ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:zip> public method unchangeAll ] {
-
- - Parameters [0] {
- }
- }
-
- Method [ <internal:zip> public method unchangeIndex ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $index ]
- }
- }
-
- Method [ <internal:zip> public method unchangeName ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $name ]
- }
- }
-
- Method [ <internal:zip> public method extractTo ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> $pathto ]
- Parameter #1 [ <optional> $files ]
- }
- }
-
- Method [ <internal:zip> public method getFromName ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $entryname ]
- Parameter #1 [ <optional> $len ]
- Parameter #2 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method getFromIndex ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <optional> $len ]
- Parameter #2 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method getStream ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $entryname ]
- }
- }
-
- Method [ <internal:zip> public method setExternalAttributesName ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $opsys ]
- Parameter #2 [ <required> $attr ]
- Parameter #3 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method setExternalAttributesIndex ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <required> $opsys ]
- Parameter #2 [ <required> $attr ]
- Parameter #3 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method getExternalAttributesName ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> &$opsys ]
- Parameter #2 [ <required> &$attr ]
- Parameter #3 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method getExternalAttributesIndex ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <required> &$opsys ]
- Parameter #2 [ <required> &$attr ]
- Parameter #3 [ <optional> $flags ]
- }
- }
-
- Method [ <internal:zip> public method setCompressionName ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $method ]
- Parameter #2 [ <optional> $compflags ]
- }
- }
-
- Method [ <internal:zip> public method setCompressionIndex ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <required> $method ]
- Parameter #2 [ <optional> $compflags ]
- }
- }
-
- Method [ <internal:zip> public method setEncryptionName ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $name ]
- Parameter #1 [ <required> $method ]
- Parameter #2 [ <optional> $password ]
- }
- }
-
- Method [ <internal:zip> public method setEncryptionIndex ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <required> $method ]
- Parameter #2 [ <optional> $password ]
- }
- }
- }
- }
- }
-}
-
diff --git a/php-pecl-zip-dev.spec b/php-pecl-zip-dev.spec
deleted file mode 100644
index cc5b230..0000000
--- a/php-pecl-zip-dev.spec
+++ /dev/null
@@ -1,347 +0,0 @@
-# remirepo spec file for php-pecl-zip
-# with SCL compatibility, from:
-#
-# fedora spec file for php-pecl-zip
-#
-# Copyright (c) 2013-2017 Remi Collet
-# License: CC-BY-SA
-# http://creativecommons.org/licenses/by-sa/4.0/
-#
-# Please, preserve the changelog entries
-#
-%{?scl: %scl_package php-pecl-zip}
-
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global pecl_name zip
-
-%if 0%{?rhel} != 5
-%global with_libzip 1
-%else
-%global with_libzip 0
-%endif
-
-%if "%{php_version}" < "5.6"
-%global ini_name %{pecl_name}.ini
-%else
-%global ini_name 40-%{pecl_name}.ini
-%endif
-%global prever dev
-
-Summary: A ZIP archive management extension
-Summary(fr): Une extension de gestion des ZIP
-Name: %{?scl_prefix}php-pecl-zip
-Version: 1.14.0
-Release: 0.2.20170301dev%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-%if %{with_libzip}
-License: PHP
-%else
-# Zip extension is PHP, Libzip library is BSD
-License: PHP and BSD
-%endif
-Group: Development/Languages
-URL: http://pecl.php.net/package/zip
-
-Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel
-%if %{with_libzip}
-# Version 1.2.0 for encryption support
-BuildRequires: pkgconfig(libzip) >= 1.2.0
-%endif
-BuildRequires: zlib-devel
-BuildRequires: %{?scl_prefix}php-pear
-
-Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
-Requires: %{?scl_prefix}php(api) = %{php_core_api}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name} = 1:%{version}-%{release}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = 1:%{version}-%{release}
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if "%{php_version}" > "7.0"
-Obsoletes: %{?scl_prefix}php-zip <= 7.0.0
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter private shared
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
-
-%description
-Zip is an extension to create and read zip files.
-
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
-
-%description -l fr
-Zip est une extension pour créer et lire les archives au format ZIP.
-
-Paquet construit pour PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: en Software Collection (%{scl} by %{scl_vendor})}.
-
-
-%prep
-%setup -c -q
-
-# Don't install/register tests
-sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
- -i package.xml
-
-mv %{pecl_name}-%{version}%{?prever} NTS
-cd NTS
-
-# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php5/php_zip.h)
-if test "x${extver}" != "x%{version}-%{?prever}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
- exit 1
-fi
-
-%if %{with_libzip}
-sed -e '/LICENSE_libzip/d' -i ../package.xml
-# delete bundled libzip to ensure it is not used
-rm -r lib
-%endif
-
-cd ..
-: Create the configuration file
-cat >%{ini_name} << 'EOF'
-; Enable ZIP extension module
-extension=%{pecl_name}.so
-EOF
-
-%if %{with_zts}
-: Duplicate sources tree for ZTS build
-cp -pr NTS ZTS
-%endif
-
-
-%build
-%{?dtsenable}
-
-cd NTS
-%{_bindir}/phpize
-%configure \
-%if %{with_libzip}
- --with-libzip \
-%endif
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/php-config
-
-make %{?_smp_mflags}
-
-%if %{with_zts}
-cd ../ZTS
-%{_bindir}/zts-phpize
-%configure \
-%if %{with_libzip}
- --with-libzip \
-%endif
- --with-libdir=%{_lib} \
- --with-php-config=%{_bindir}/zts-php-config
-
-make %{?_smp_mflags}
-%endif
-
-
-%install
-rm -rf %{buildroot}
-%{?dtsenable}
-
-make -C NTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
-
-# Install XML package description
-install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
-
-%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
-install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
-%endif
-
-# Documentation
-cd NTS
-for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
-done
-
-
-%check
-cd NTS
-: minimal load test of NTS extension
-%{_bindir}/php --no-php-ini \
- --define extension_dir=modules \
- --define extension=%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: upstream test suite for NTS extension
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
-NO_INTERACTION=1 \
-TEST_PHP_EXECUTABLE=%{_bindir}/php \
-%{_bindir}/php -n \
- run-tests.php --show-diff
-
-%if %{with_zts}
-cd ../ZTS
-: minimal load test of ZTS extension
-%{_bindir}/zts-php --no-php-ini \
- --define extension_dir=modules \
- --define extension=%{pecl_name}.so \
- --modules | grep %{pecl_name}
-
-: upstream test suite for ZTS extension
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/modules -d extension=%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
-NO_INTERACTION=1 \
-TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
-%{_bindir}/zts-php -n \
- run-tests.php --show-diff
-%endif
-
-
-%clean
-rm -rf %{buildroot}
-
-%if 0%{?fedora} < 24
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
-%files
-%defattr(-, root, root, -)
-%{?_licensedir:%license NTS/LICENSE}
-%doc %{pecl_docdir}/%{pecl_name}
-%{pecl_xmldir}/%{name}.xml
-
-%config(noreplace) %{php_inidir}/%{ini_name}
-%{php_extdir}/%{pecl_name}.so
-
-%if %{with_zts}
-%config(noreplace) %{php_ztsinidir}/%{ini_name}
-%{php_ztsextdir}/%{pecl_name}.so
-%endif
-
-
-%changelog
-* Wed Mar 1 2017 Remi Collet <remi@fedoraproject.org> - 1.14.0-0.2.20170301dev
-- refresh with pasword support in stream wrapper
-
-* Sun Feb 19 2017 Remi Collet <remi@fedoraproject.org> - 1.14.0-0.1.20170219dev
-- update to 1.4.0-dev with encryption support
-- raise dependency on libzip 1.2.0
-
-* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 1.13.5-2
-- rebuild with PHP 7.1.0 GA
-
-* Fri Oct 14 2016 Remi Collet <remi@fedoraproject.org> - 1.13.5-1
-- Update to 1.13.5
-
-* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 1.13.4-2
-- rebuild for PHP 7.1 new API version
-
-* Thu Jul 21 2016 Remi Collet <remi@fedoraproject.org> - 1.13.4-1
-- Update to 1.13.4
-
-* Thu Jun 23 2016 Remi Collet <remi@fedoraproject.org> - 1.13.3-1
-- Update to 1.13.3
-
-* Tue Mar 1 2016 Remi Collet <remi@fedoraproject.org> - 1.13.2-1
-- Update to 1.13.2
-- fix license management
-
-* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 1.13.1-3
-- rebuild for PHP 7.0.0RC5 new API version
-
-* Fri Sep 18 2015 Remi Collet <remi@fedoraproject.org> - 1.13.1-2
-- F23 rebuild with rh_layout
-
-* Wed Sep 9 2015 Remi Collet <remi@fedoraproject.org> - 1.13.1-1
-- Update to 1.13.1
-
-* Mon Sep 7 2015 Remi Collet <remi@fedoraproject.org> - 1.13.0-1
-- Update to 1.13.0
-- raise dependency on libzip 1.0.0
-
-* Wed Apr 15 2015 Remi Collet <remi@fedoraproject.org> - 1.12.5-1
-- Update to 1.12.5
-- Don't install/register tests
-
-* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.12.1-3
-- new scriptlets
-
-* Sun Aug 24 2014 Remi Collet <rcollet@redhat.com> 1.12.1-2
-- allow SCL build
-
-* Wed Apr 9 2014 Remi Collet <remi@fedoraproject.org> - 1.12.4-2
-- add numerical prefix to extension configuration file
-
-* Wed Jan 29 2014 Remi Collet <remi@fedoraproject.org> - 1.12.4-1
-- Update to 1.12.4 (stable) for libzip 0.11.2
-
-* Thu Dec 12 2013 Remi Collet <remi@fedoraproject.org> - 1.12.3-1
-- Update to 1.12.3 (stable)
-- drop merged patch
-
-* Thu Oct 24 2013 Remi Collet <remi@fedoraproject.org> 1.12.2-2
-- upstream patch, don't use any libzip private struct
-- drop LICENSE_libzip when system version is used
-- always build ZTS extension
-
-* Wed Oct 23 2013 Remi Collet <remi@fedoraproject.org> 1.12.2-1
-- update to 1.12.2 (beta)
-- drop merged patches
-- install doc in pecl doc_dir
-- install tests in pecl test_dir
-
-* Tue Aug 20 2013 Remi Collet <remi@fedoraproject.org> 1.12.1-2.1
-- backport stuff
-
-* Tue Aug 20 2013 Remi Collet <rcollet@redhat.com> 1.12.1-2
-- refresh our merged patches from upstream git
-
-* Thu Aug 08 2013 Remi Collet <rcollet@redhat.com> 1.12.1-1
-- New spec for version 1.12.1
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index 9222b78..cc5b230 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -25,13 +25,13 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-#global prever dev
+%global prever dev
Summary: A ZIP archive management extension
Summary(fr): Une extension de gestion des ZIP
Name: %{?scl_prefix}php-pecl-zip
-Version: 1.13.5
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.14.0
+Release: 0.2.20170301dev%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{with_libzip}
License: PHP
%else
@@ -46,7 +46,8 @@ Source: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
%if %{with_libzip}
-BuildRequires: pkgconfig(libzip) >= 1.0.0
+# Version 1.2.0 for encryption support
+BuildRequires: pkgconfig(libzip) >= 1.2.0
%endif
BuildRequires: zlib-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -119,7 +120,7 @@ cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php5/php_zip.h)
-if test "x${extver}" != "x%{version}%{?prever}"; then
+if test "x${extver}" != "x%{version}-%{?prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever}.
exit 1
fi
@@ -144,6 +145,8 @@ cp -pr NTS ZTS
%build
+%{?dtsenable}
+
cd NTS
%{_bindir}/phpize
%configure \
@@ -171,6 +174,7 @@ make %{?_smp_mflags}
%install
rm -rf %{buildroot}
+%{?dtsenable}
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -263,6 +267,13 @@ fi
%changelog
+* Wed Mar 1 2017 Remi Collet <remi@fedoraproject.org> - 1.14.0-0.2.20170301dev
+- refresh with pasword support in stream wrapper
+
+* Sun Feb 19 2017 Remi Collet <remi@fedoraproject.org> - 1.14.0-0.1.20170219dev
+- update to 1.4.0-dev with encryption support
+- raise dependency on libzip 1.2.0
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 1.13.5-2
- rebuild with PHP 7.1.0 GA