summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-08-20 15:25:34 +0200
committerRemi Collet <fedora@famillecollet.com>2013-08-20 15:25:34 +0200
commit063eb97ba4c5b047a4a73234d589bd241f6950c9 (patch)
tree4d8e32e72e99e1c4edbacc03175696f09107a95f
parent56d68f3e35b05449b5c9bc012d375ff51199bf50 (diff)
php-pecl-zip: refresh our merged patches from upstream git
-rw-r--r--php-pecl-zip.spec5
-rw-r--r--zip-systemlibzip.patch46
2 files changed, 41 insertions, 10 deletions
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index a457c27..a48e44f 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -18,7 +18,7 @@ Summary: A ZIP archive management extension
Summary(fr): Une extension de gestion des ZIP
Name: php-pecl-zip
Version: 1.12.1
-Release: 1%{?dist}
+Release: 2%{?dist}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/zip
@@ -183,5 +183,8 @@ fi
%changelog
+* Tue Aug 20 2013 Remi Collet <remi@redhat.com> 1.12.1-2
+- refresh our merged patches from upstream git
+
* Thu Aug 08 2013 Remi Collet <remi@redhat.com> 1.12.1-1
- New spec for version 1.12.1
diff --git a/zip-systemlibzip.patch b/zip-systemlibzip.patch
index 0c9d7d1..87e1e06 100644
--- a/zip-systemlibzip.patch
+++ b/zip-systemlibzip.patch
@@ -1,6 +1,19 @@
-diff -up zip-1.12.1/config.m4.systemlibzip zip-1.12.1/config.m4
---- zip-1.12.1/config.m4.systemlibzip 2013-08-08 14:55:44.864556155 +0200
-+++ zip-1.12.1/config.m4 2013-08-08 14:55:44.868556168 +0200
+From 4265dac56d5c869163a66ceb85a07ebac4b46217 Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Tue, 20 Aug 2013 15:17:57 +0200
+Subject: [PATCH] allow to build using system libzip 0.11 (using --with-libzip
+ option)
+
+---
+ config.m4 | 53 +++++++++++++++++++++++++++++++++++++++++++++++++++++
+ php_zip.c | 1 +
+ php_zip.h | 4 ++++
+ 3 files changed, 58 insertions(+)
+
+diff --git a/config.m4 b/config.m4
+index aade73d..85b94cc 100755
+--- a/config.m4
++++ b/config.m4
@@ -13,8 +13,60 @@ fi
PHP_ARG_WITH(pcre-dir, pcre install prefix,
[ --with-pcre-dir ZIP: pcre install prefix], no, no)
@@ -53,7 +66,7 @@ diff -up zip-1.12.1/config.m4.systemlibzip zip-1.12.1/config.m4
+ -L$LIBZIP_LIBDIR
+ ])
+
-+ AC_DEFINE(HAVE_ZIP,1,[ ])
++ AC_DEFINE(HAVE_ZIP,1,[ ])
+ PHP_NEW_EXTENSION(zip, php_zip.c zip_stream.c, $ext_shared,, $LIBZIP_CFLAGS)
+ PHP_SUBST(ZIP_SHARED_LIBADD)
+ else
@@ -70,11 +83,23 @@ diff -up zip-1.12.1/config.m4.systemlibzip zip-1.12.1/config.m4
AC_CHECK_TYPES([int8_t])
-diff -up zip-1.12.1/php_zip.c.systemlibzip zip-1.12.1/php_zip.c
-diff -up zip-1.12.1/php_zip.h.systemlibzip zip-1.12.1/php_zip.h
---- zip-1.12.1/php_zip.h.systemlibzip 2013-04-29 11:18:17.000000000 +0200
-+++ zip-1.12.1/php_zip.h 2013-08-08 14:55:44.871556178 +0200
-@@ -28,7 +28,11 @@ extern zend_module_entry zip_module_entr
+diff --git a/php_zip.c b/php_zip.c
+index 2e97e84..d8cf7f2 100755
+--- a/php_zip.c
++++ b/php_zip.c
+@@ -30,6 +30,7 @@
+ #include "ext/pcre/php_pcre.h"
+ #include "ext/standard/php_filestat.h"
+ #include "php_zip.h"
++/* Private struct definition, always use bundled copy */
+ #include "lib/zipint.h"
+
+ /* zip_open is a macro for renaming libzip zipopen, so we need to use PHP_NAMED_FUNCTION */
+diff --git a/php_zip.h b/php_zip.h
+index d734284..deeb1b4 100755
+--- a/php_zip.h
++++ b/php_zip.h
+@@ -28,7 +28,11 @@
#include "TSRM.h"
#endif
@@ -86,3 +111,6 @@ diff -up zip-1.12.1/php_zip.h.systemlibzip zip-1.12.1/php_zip.h
#define PHP_ZIP_VERSION_STRING "1.12.1"
+--
+1.8.1.6
+