summaryrefslogtreecommitdiffstats
path: root/php-pecl-zendopcache.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-11 08:43:50 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-11 08:43:50 +0200
commita4e7231711e9dc9d060bc4a0830e84435d126018 (patch)
tree526923fda6f318a266d32003725c7cacb99298ff /php-pecl-zendopcache.spec
parent747e2868fe13a87893045ad4ade503040a5d988b (diff)
php-pecl-zendopcache: allow wildcard in blacklist filename and comments in blacklist content
Diffstat (limited to 'php-pecl-zendopcache.spec')
-rw-r--r--php-pecl-zendopcache.spec21
1 files changed, 19 insertions, 2 deletions
diff --git a/php-pecl-zendopcache.spec b/php-pecl-zendopcache.spec
index a26ed21..c09c252 100644
--- a/php-pecl-zendopcache.spec
+++ b/php-pecl-zendopcache.spec
@@ -8,7 +8,7 @@
Name: php-pecl-%{pecl_name}
Version: 7.0.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: The Zend OPcache
Group: Development/Libraries
@@ -18,6 +18,11 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# this extension must be loaded before XDebug
# So "opcache" if before "xdebug"
Source1: %{plug_name}.ini
+Source2: %{plug_name}-default.blacklist
+
+# Allow comments in blacklist content
+# Allow wildcard in blacklist filename
+Patch0: %{plug_name}-blacklist.patch
BuildRequires: php-devel >= 5.2.0
BuildRequires: php-pear
@@ -54,12 +59,16 @@ bytecode optimization patterns that make code execution faster.
%setup -q -c
mv %{pecl_name}-%{version} NTS
+cd NTS
+%patch0 -p1 -b .blacklist
+
# Sanity check, really often broken
-extver=$(sed -n '/#define ACCELERATOR_VERSION/{s/.* "//;s/".*$//;p}' NTS/ZendAccelerator.h)
+extver=$(sed -n '/#define ACCELERATOR_VERSION/{s/.* "//;s/".*$//;p}' ZendAccelerator.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
exit 1
fi
+cd ..
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
@@ -100,6 +109,9 @@ sed -e 's:@EXTPATH@:%{php_ztsextdir}:' \
make -C ZTS install INSTALL_ROOT=%{buildroot}
%endif
+# The default Zend OPcache blacklist file
+install -D -p -m 644 %{SOURCE2} %{buildroot}%{php_inidir}/%{plug_name}-default.blacklist
+
# Install XML package description
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
@@ -142,6 +154,7 @@ fi
%files
%doc NTS/{LICENSE,README}
+%config(noreplace) %{php_inidir}/%{plug_name}-default.blacklist
%config(noreplace) %{php_inidir}/%{plug_name}.ini
%{php_extdir}/%{plug_name}.so
@@ -154,6 +167,10 @@ fi
%changelog
+* Thu Apr 11 2013 Remi Collet <rcollet@redhat.com> - 7.0.1-2
+- allow wildcard in opcache.blacklist_filename and provide
+ default /etc/php.d/opcache-default.blacklist
+
* Mon Mar 25 2013 Remi Collet <remi@fedoraproject.org> - 7.0.1-1
- official PECL release, version 7.0.1 (beta)
- rename to php-pecl-zendopcache