summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-01-12 08:47:57 +0100
committerRemi Collet <fedora@famillecollet.com>2015-01-12 08:47:57 +0100
commit559223f7aaff97880e0d4cfb5684a4c5085d7a58 (patch)
tree935a7de473e3de69bac81505b53c2db919f28cde
parent05a9a89fb944ee2714a43b3a0d0bacd30cc55506 (diff)
php-pecl-zendopcache: 7.0.4
-rw-r--r--REFLECTION6
-rw-r--r--blacklist.inc3
-rw-r--r--opcache.ini2
-rw-r--r--php-pecl-zendopcache.spec27
-rw-r--r--php_cli_server.inc47
5 files changed, 21 insertions, 64 deletions
diff --git a/REFLECTION b/REFLECTION
index 8d021d9..f6bbbc4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #165 Zend OPcache version 7.0.4-devFE ] {
+Extension [ <persistent> extension #69 Zend OPcache version 7.0.4FE ] {
- INI {
Entry [ opcache.enable <ALL> ]
@@ -50,7 +50,7 @@ Extension [ <persistent> extension #165 Zend OPcache version 7.0.4-devFE ] {
Current = ''
}
Entry [ opcache.blacklist_filename <SYSTEM> ]
- Current = '/etc/php.d/opcache*.blacklist'
+ Current = '/opt/remi/php54/root/etc/php.d/opcache*.blacklist'
}
Entry [ opcache.max_file_size <SYSTEM> ]
Current = '0'
@@ -65,7 +65,7 @@ Extension [ <persistent> extension #165 Zend OPcache version 7.0.4-devFE ] {
Current = '1'
}
Entry [ opcache.fast_shutdown <SYSTEM> ]
- Current = '1'
+ Current = '0'
}
Entry [ opcache.optimization_level <SYSTEM> ]
Current = '0xFFFFFFFF'
diff --git a/blacklist.inc b/blacklist.inc
deleted file mode 100644
index a9db751..0000000
--- a/blacklist.inc
+++ /dev/null
@@ -1,3 +0,0 @@
-<?php
- echo "ok\n";
-?>
diff --git a/opcache.ini b/opcache.ini
index 4a9ac5c..c26c351 100644
--- a/opcache.ini
+++ b/opcache.ini
@@ -48,7 +48,7 @@ opcache.max_accelerated_files=4000
;opcache.load_comments=1
; If enabled, a fast shutdown sequence is used for the accelerated code
-opcache.fast_shutdown=1
+;opcache.fast_shutdown=0
; Allow file existence override (file_exists, etc.) performance feature.
;opcache.enable_file_override=0
diff --git a/php-pecl-zendopcache.spec b/php-pecl-zendopcache.spec
index ab7d986..5d1681f 100644
--- a/php-pecl-zendopcache.spec
+++ b/php-pecl-zendopcache.spec
@@ -14,8 +14,8 @@
%global plug_name opcache
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 7.0.3
-Release: 2%{?dist}.1
+Version: 7.0.4
+Release: 1%{?dist}
Summary: The Zend OPcache
Group: Development/Libraries
@@ -27,11 +27,6 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
Source1: %{plug_name}.ini
Source2: %{plug_name}-default.blacklist
-# Missing in archive
-# https://github.com/zendtech/ZendOptimizerPlus/issues/162
-Source3: https://raw2.github.com/zendtech/ZendOptimizerPlus/e8e28cd95c8aa660c28c2166da679b50deb50faa/tests/blacklist.inc
-Source4: https://raw2.github.com/zendtech/ZendOptimizerPlus/e8e28cd95c8aa660c28c2166da679b50deb50faa/tests/php_cli_server.inc
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel >= 5.2.0
BuildRequires: %{?scl_prefix}php-pear
@@ -79,7 +74,12 @@ bytecode optimization patterns that make code execution faster.
%setup -q -c
mv %{pecl_name}-%{version} NTS
-cp %{SOURCE3} %{SOURCE4} NTS/tests/
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_ZENDOPCACHE_VERSION/{s/.* "//;s/".*$//;p}' NTS/ZendAccelerator.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
%if %{with_zts}
# Duplicate source tree for NTS / ZTS build
@@ -91,7 +91,7 @@ cp -pr NTS ZTS
cd NTS
%{_bindir}/phpize
%configure \
- --enable-optimizer-plus \
+ --enable-opcache \
--with-php-config=%{_bindir}/php-config
make %{?_smp_mflags}
@@ -99,7 +99,7 @@ make %{?_smp_mflags}
cd ../ZTS
%{_bindir}/zts-phpize
%configure \
- --enable-optimizer-plus \
+ --enable-opcache \
--with-php-config=%{_bindir}/zts-php-config
make %{?_smp_mflags}
%endif
@@ -140,6 +140,9 @@ rm -rf %{buildroot}
%check
+# ignore this one, works manually, run-tests.php issue
+rm ?TS/tests/is_script_cached.phpt
+
cd NTS
%{__php} \
-n -d zend_extension=%{buildroot}%{php_extdir}/%{plug_name}.so \
@@ -192,6 +195,10 @@ fi
%changelog
+* Mon Jan 12 2015 Remi Collet <remi@fedoraproject.org> - 7.0.4-1
+- Update to 7.0.4
+- disable opcache.fast_shutdown in default configuration
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 7.0.3-2.1
- Fedora 21 SCL mass rebuild
diff --git a/php_cli_server.inc b/php_cli_server.inc
deleted file mode 100644
index 0878bfa..0000000
--- a/php_cli_server.inc
+++ /dev/null
@@ -1,47 +0,0 @@
-<?php
-define ("PHP_CLI_SERVER_HOSTNAME", "localhost");
-define ("PHP_CLI_SERVER_PORT", 8964);
-define ("PHP_CLI_SERVER_ADDRESS", PHP_CLI_SERVER_HOSTNAME.":".PHP_CLI_SERVER_PORT);
-
-function php_cli_server_start($ini = "") {
- $php_executable = getenv('TEST_PHP_EXECUTABLE');
- $doc_root = __DIR__;
-
- $descriptorspec = array(
- 0 => STDIN,
- 1 => STDOUT,
- 2 => STDERR,
- );
-
- if (substr(PHP_OS, 0, 3) == 'WIN') {
- $cmd = "{$php_executable} -t {$doc_root} $ini -S " . PHP_CLI_SERVER_ADDRESS;
- $handle = proc_open(addslashes($cmd), $descriptorspec, $pipes, $doc_root, NULL, array("bypass_shell" => true, "suppress_errors" => true));
- } else {
- $cmd = "exec {$php_executable} -t {$doc_root} $ini -S " . PHP_CLI_SERVER_ADDRESS . " 2>/dev/null";
- $handle = proc_open($cmd, $descriptorspec, $pipes, $doc_root);
- }
-
- // note: even when server prints 'Listening on localhost:8964...Press Ctrl-C to quit.'
- // it might not be listening yet...need to wait until fsockopen() call returns
- $i = 0;
- while (($i++ < 30) && !($fp = @fsockopen(PHP_CLI_SERVER_HOSTNAME, PHP_CLI_SERVER_PORT))) {
- usleep(10000);
- }
-
- if ($fp) {
- fclose($fp);
- }
-
- register_shutdown_function(
- function($handle) {
- proc_terminate($handle);
- },
- $handle
- );
- // don't bother sleeping, server is already up
- // server can take a variable amount of time to be up, so just sleeping a guessed amount of time
- // does not work. this is why tests sometimes pass and sometimes fail. to get a reliable pass
- // sleeping doesn't work.
-}
-?>
-