summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-02 18:36:27 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-02 18:36:27 +0100
commit162dcf22856fa439eb1c95bdb409ae71c93a88a0 (patch)
treec382ce1d985b626a073c9ab0a1ee21ee82b5f2e8
php-pecl-yaz: 1.1.8 (stable) - New package
-rw-r--r--Makefile4
-rw-r--r--REFLECTION114
-rw-r--r--php-pecl-yaz.spec199
3 files changed, 317 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..4f7d830
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,114 @@
+Extension [ <persistent> extension #163 yaz version 1.1.8 ] {
+
+ - INI {
+ Entry [ yaz.max_links <ALL> ]
+ Current = '100'
+ }
+ Entry [ yaz.keepalive <ALL> ]
+ Current = '120'
+ }
+ Entry [ yaz.log_file <ALL> ]
+ Current = ''
+ }
+ Entry [ yaz.log_mask <ALL> ]
+ Current = ''
+ }
+ }
+
+ - Constants [10] {
+ Constant [ integer ZOOM_EVENT_NONE ] { 0 }
+ Constant [ integer ZOOM_EVENT_CONNECT ] { 1 }
+ Constant [ integer ZOOM_EVENT_SEND_DATA ] { 2 }
+ Constant [ integer ZOOM_EVENT_RECV_DATA ] { 3 }
+ Constant [ integer ZOOM_EVENT_TIMEOUT ] { 4 }
+ Constant [ integer ZOOM_EVENT_UNKNOWN ] { 5 }
+ Constant [ integer ZOOM_EVENT_SEND_APDU ] { 6 }
+ Constant [ integer ZOOM_EVENT_RECV_APDU ] { 7 }
+ Constant [ integer ZOOM_EVENT_RECV_RECORD ] { 8 }
+ Constant [ integer ZOOM_EVENT_RECV_SEARCH ] { 9 }
+ }
+
+ - Functions {
+ Function [ <internal:yaz> function yaz_connect ] {
+ }
+ Function [ <internal:yaz> function yaz_close ] {
+ }
+ Function [ <internal:yaz> function yaz_search ] {
+ }
+ Function [ <internal:yaz> function yaz_wait ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> &$param0 ]
+ }
+ }
+ Function [ <internal:yaz> function yaz_errno ] {
+ }
+ Function [ <internal:yaz> function yaz_error ] {
+ }
+ Function [ <internal:yaz> function yaz_addinfo ] {
+ }
+ Function [ <internal:yaz> function yaz_hits ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $param0 ]
+ Parameter #1 [ <required> &$param1 ]
+ }
+ }
+ Function [ <internal:yaz> function yaz_record ] {
+ }
+ Function [ <internal:yaz> function yaz_syntax ] {
+ }
+ Function [ <internal:yaz> function yaz_element ] {
+ }
+ Function [ <internal:yaz> function yaz_range ] {
+ }
+ Function [ <internal:yaz> function yaz_itemorder ] {
+ }
+ Function [ <internal:yaz> function yaz_es_result ] {
+ }
+ Function [ <internal:yaz> function yaz_scan ] {
+ }
+ Function [ <internal:yaz> function yaz_scan_result ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $param0 ]
+ Parameter #1 [ <required> &$param1 ]
+ }
+ }
+ Function [ <internal:yaz> function yaz_present ] {
+ }
+ Function [ <internal:yaz> function yaz_ccl_conf ] {
+ }
+ Function [ <internal:yaz> function yaz_ccl_parse ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $param0 ]
+ Parameter #1 [ <required> $param1 ]
+ Parameter #2 [ <required> &$param2 ]
+ }
+ }
+ Function [ <internal:yaz> function yaz_cql_parse ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $param0 ]
+ Parameter #1 [ <required> $param1 ]
+ Parameter #2 [ <required> &$param2 ]
+ }
+ }
+ Function [ <internal:yaz> function yaz_cql_conf ] {
+ }
+ Function [ <internal:yaz> function yaz_database ] {
+ }
+ Function [ <internal:yaz> function yaz_sort ] {
+ }
+ Function [ <internal:yaz> function yaz_schema ] {
+ }
+ Function [ <internal:yaz> function yaz_set_option ] {
+ }
+ Function [ <internal:yaz> function yaz_get_option ] {
+ }
+ Function [ <internal:yaz> function yaz_es ] {
+ }
+ }
+}
+
diff --git a/php-pecl-yaz.spec b/php-pecl-yaz.spec
new file mode 100644
index 0000000..e6b1e20
--- /dev/null
+++ b/php-pecl-yaz.spec
@@ -0,0 +1,199 @@
+# spec file for php-pecl-yaz
+#
+# Copyright (c) 2014 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/3.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-yaz}
+%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
+%{!?__pecl: %global __pecl %{_bindir}/pecl}
+%{!?__php: %global __php %{_bindir}/php}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name yaz
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+
+Summary: Z39.50/SRU client
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.1.8
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: BSD
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel > 5.3
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: libyaz-devel >= 3.0.2
+
+
+Requires(post): %{__pecl}
+Requires(postun): %{__pecl}
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This extension implements a Z39.50/SRU client for PHP using the
+YAZ toolkit and the ZOOM framework.
+
+Find more information at:
+- http://www.indexdata.com/phpyaz
+- http://www.indexdata.com/yaz
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+cd NTS
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_YAZ_VERSION/{s/.* "//;s/".*$//;p}' php_yaz.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable %{summary} extension module
+extension=%{pecl_name}.so
+
+; Configuration
+;yaz.max_links = 100
+;yaz.keepalive = 120
+;yaz.log_file = ''
+;yaz.log_mask = ''
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%post
+%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_docdir}/%{pecl_name}
+%{?_licensedir:%license NTS/LICENSE}
+
+%{pecl_xmldir}/%{name}.xml
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Fri Oct 31 2014 Remi Collet <remi@fedoraproject.org> - 1.1.8-1
+- initial package, version 1.1.8 (stable) \ No newline at end of file