summaryrefslogtreecommitdiffstats
path: root/php-pecl-yar-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-yar-dev.spec')
-rw-r--r--php-pecl-yar-dev.spec32
1 files changed, 12 insertions, 20 deletions
diff --git a/php-pecl-yar-dev.spec b/php-pecl-yar-dev.spec
index bf69fb8..1ea3353 100644
--- a/php-pecl-yar-dev.spec
+++ b/php-pecl-yar-dev.spec
@@ -11,11 +11,11 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global gh_commit 3b43b26f28a615ee1a1dda36f0081dd67785d78c
+%global gh_commit 410ca7a3f1d633050000ee2ec233366d73e3fda3
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laruence
%global gh_project yar
-%global gh_date 20150612
+%global gh_date 20150615
%global with_zts 0%{?__ztsphp:1}
%global pecl_name yar
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
@@ -31,7 +31,7 @@ Summary: Light, concurrent RPC framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: 1.2.5
%if 0%{?gh_date:1}
-Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
%else
Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
%endif
@@ -40,6 +40,8 @@ Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
+Patch0: %{pecl_name}-pr51.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: curl-devel
BuildRequires: %{?scl_prefix}php-devel
@@ -109,6 +111,7 @@ sed -e 's/role="test"/role="src"/' \
-i package2.xml
cd NTS
+%patch0 -p1
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
@@ -236,29 +239,15 @@ export TEST_PHP_EXECUTABLE=%{__php}
export TEST_PHP_ARGS="-n -d extension=json.so -d extension=msgpack.so -d extension=$PWD/modules/%{pecl_name}.so"
export NO_INTERACTION=1
export REPORT_EXIT_STATUS=1
-RET=0
%ifarch x86_64
-PORT=8088
+export YAR_API_PORT=8968
%else
-PORT=8084
+export YAR_API_PORT=8964
%endif
-sed -e "/YAR_API_HOST/s|localhost:8090|127.0.0.1:$PORT|" \
- -e "/YAR_API_URI/s|/yar/|/|" \
- -i tests/yar.inc
-
-: launch the server
-%{__php} $TEST_PHP_ARGS -S 127.0.0.1:$PORT -t tests/htdocs &>serv.log &
-PID=$!
-
: Run the upstream test suite
-%{__php} -n run-tests.php --show-diff || RET=1
-
-: Cleanup
-kill $PID
-
-exit $RET
+%{__php} -n run-tests.php --show-diff
%else
: upstream test suite disabled
%endif
@@ -284,6 +273,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 17 2015 Remi Collet <remi@fedoraproject.org> - 1.2.5-0.3.20150615git410ca7a
+- rebuild
+
* Fri Jun 12 2015 Remi Collet <remi@fedoraproject.org> - 1.2.5-0.2.20150612git3b43b26
- enable test suite during the build