summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO3
-rw-r--r--REFLECTION50
-rw-r--r--php-pecl-yar.spec8
3 files changed, 28 insertions, 33 deletions
diff --git a/PHPINFO b/PHPINFO
index 8667a7e..fe268fe 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,11 +2,10 @@
yar
yar support => enabled
-Version => 2.2.1
+Version => 2.3.0
Directive => Local Value => Master Value
yar.packager => msgpack => msgpack
-yar.transport => curl => curl
yar.debug => Off => Off
yar.expose_info => On => On
yar.connect_timeout => 1000 => 1000
diff --git a/REFLECTION b/REFLECTION
index 40a6613..dbc76d4 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 yar version 2.2.1 ] {
+Extension [ <persistent> extension #119 yar version 2.3.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -9,9 +9,6 @@ Extension [ <persistent> extension #120 yar version 2.2.1 ] {
Entry [ yar.packager <PERDIR> ]
Current = 'msgpack'
}
- Entry [ yar.transport <PERDIR> ]
- Current = 'curl'
- }
Entry [ yar.debug <ALL> ]
Current = 'Off'
}
@@ -29,15 +26,18 @@ Extension [ <persistent> extension #120 yar version 2.2.1 ] {
}
}
- - Constants [21] {
- Constant [ string YAR_VERSION ] { 2.2.1 }
- Constant [ int YAR_OPT_PACKAGER ] { 1 }
- Constant [ int YAR_OPT_PERSISTENT ] { 2 }
- Constant [ int YAR_OPT_TIMEOUT ] { 4 }
- Constant [ int YAR_OPT_CONNECT_TIMEOUT ] { 8 }
- Constant [ int YAR_OPT_HEADER ] { 16 }
- Constant [ int YAR_OPT_RESOLVE ] { 32 }
- Constant [ int YAR_OPT_PROXY ] { 64 }
+ - Constants [24] {
+ Constant [ string YAR_VERSION ] { 2.3.0 }
+ Constant [ int YAR_HAS_MSGPACK ] { 1 }
+ Constant [ int YAR_OPT_PACKAGER ] { 0 }
+ Constant [ int YAR_OPT_PERSISTENT ] { 1 }
+ Constant [ int YAR_OPT_TIMEOUT ] { 2 }
+ Constant [ int YAR_OPT_CONNECT_TIMEOUT ] { 3 }
+ Constant [ int YAR_OPT_HEADER ] { 4 }
+ Constant [ int YAR_OPT_RESOLVE ] { 5 }
+ Constant [ int YAR_OPT_PROXY ] { 6 }
+ Constant [ int YAR_OPT_PROVIDER ] { 8 }
+ Constant [ int YAR_OPT_TOKEN ] { 7 }
Constant [ int YAR_CLIENT_PROTOCOL_HTTP ] { 1 }
Constant [ int YAR_CLIENT_PROTOCOL_TCP ] { 2 }
Constant [ int YAR_CLIENT_PROTOCOL_UNIX ] { 4 }
@@ -97,11 +97,7 @@ Extension [ <persistent> extension #120 yar version 2.2.1 ] {
- Static methods [0] {
}
- - Properties [4] {
- Property [ protected $_protocol = 1 ]
- Property [ protected $_uri = NULL ]
- Property [ protected $_options = NULL ]
- Property [ protected $_running = NULL ]
+ - Properties [0] {
}
- Methods [5] {
@@ -155,11 +151,7 @@ Extension [ <persistent> extension #120 yar version 2.2.1 ] {
- Constants [0] {
}
- - Static properties [4] {
- Property [ protected static $_callstack = NULL ]
- Property [ protected static $_callback = NULL ]
- Property [ protected static $_error_callback = NULL ]
- Property [ protected static $_start = false ]
+ - Static properties [0] {
}
- Static methods [3] {
@@ -168,10 +160,10 @@ Extension [ <persistent> extension #120 yar version 2.2.1 ] {
- Parameters [6] {
Parameter #0 [ <required> string $uri ]
Parameter #1 [ <required> string $method ]
- Parameter #2 [ <optional> array $arguments = NULL ]
- Parameter #3 [ <optional> callable $callback = NULL ]
- Parameter #4 [ <optional> callable $error_callback = NULL ]
- Parameter #5 [ <optional> array $options = NULL ]
+ Parameter #2 [ <optional> ?array $arguments = NULL ]
+ Parameter #3 [ <optional> ?callable $callback = NULL ]
+ Parameter #4 [ <optional> ?callable $error_callback = NULL ]
+ Parameter #5 [ <optional> ?array $options = NULL ]
}
- Return [ int|bool|null ]
}
@@ -179,8 +171,8 @@ Extension [ <persistent> extension #120 yar version 2.2.1 ] {
Method [ <internal:yar> static public method loop ] {
- Parameters [2] {
- Parameter #0 [ <optional> callable $callback = NULL ]
- Parameter #1 [ <optional> callable $error_callback = NULL ]
+ Parameter #0 [ <optional> ?callable $callback = NULL ]
+ Parameter #1 [ <optional> ?callable $error_callback = NULL ]
}
- Return [ ?bool ]
}
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index 3a00c7c..3576c5f 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -25,7 +25,7 @@
Summary: Light, concurrent RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.2.1
+Version: 2.3.0
%if 0%{?gh_date:1}
Release: 0.14.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -125,7 +125,6 @@ extension=%{pecl_name}.so
;yar.expose_info=On
;yar.packager=msgpack
;yar.timeout=5000
-;yar.transport=curl
EOF
@@ -223,6 +222,8 @@ rm ?TS/tests/022.phpt
%if %{with tests}
cd NTS
+: erratic results
+#rm tests/047.phpt
: Create test configuration
export TEST_PHP_EXECUTABLE=%{__php}
@@ -254,6 +255,9 @@ export YAR_API_PORT=$(%{__php} -r 'echo 8960 + PHP_MAJOR_VERSION*100 + PHP_MINOR
%changelog
+* Mon Apr 25 2022 Remi Collet <remi@remirepo.net> - 2.3.0-1
+- update to 2.3.0
+
* Mon Dec 20 2021 Remi Collet <remi@remirepo.net> - 2.2.1-1
- update to 2.2.1