summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO3
-rw-r--r--REFLECTION598
-rw-r--r--php-pecl-yar.spec111
-rw-r--r--yar-php82.patch68
5 files changed, 601 insertions, 181 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index 9717705..7419894 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,11 +2,10 @@
yar
yar support => enabled
-Version => 2.1.1
+Version => 2.3.2
Directive => Local Value => Master Value
yar.packager => msgpack => msgpack
-yar.transport => curl => curl
yar.debug => Off => Off
yar.expose_info => On => On
yar.connect_timeout => 1000 => 1000
diff --git a/REFLECTION b/REFLECTION
index f6dba11..00bdecd 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #112 yar version 2.1.1 ] {
+Extension [ <persistent> extension #119 yar version 2.3.2 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -9,9 +9,6 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
Entry [ yar.packager <PERDIR> ]
Current = 'msgpack'
}
- Entry [ yar.transport <PERDIR> ]
- Current = 'curl'
- }
Entry [ yar.debug <ALL> ]
Current = 'Off'
}
@@ -29,14 +26,18 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
}
- - Constants [20] {
- Constant [ string YAR_VERSION ] { 2.1.1 }
- Constant [ int YAR_OPT_PACKAGER ] { 1 }
- Constant [ int YAR_OPT_PERSISTENT ] { 2 }
- Constant [ int YAR_OPT_TIMEOUT ] { 4 }
- Constant [ int YAR_OPT_CONNECT_TIMEOUT ] { 8 }
- Constant [ int YAR_OPT_HEADER ] { 16 }
- Constant [ int YAR_OPT_RESOLVE ] { 32 }
+ - Constants [24] {
+ Constant [ string YAR_VERSION ] { 2.3.2 }
+ Constant [ int YAR_HAS_MSGPACK ] { 1 }
+ Constant [ int YAR_OPT_PACKAGER ] { 0 }
+ Constant [ int YAR_OPT_PERSISTENT ] { 1 }
+ Constant [ int YAR_OPT_TIMEOUT ] { 2 }
+ Constant [ int YAR_OPT_CONNECT_TIMEOUT ] { 3 }
+ Constant [ int YAR_OPT_HEADER ] { 4 }
+ Constant [ int YAR_OPT_RESOLVE ] { 5 }
+ Constant [ int YAR_OPT_PROXY ] { 6 }
+ Constant [ int YAR_OPT_PROVIDER ] { 8 }
+ Constant [ int YAR_OPT_TOKEN ] { 7 }
Constant [ int YAR_CLIENT_PROTOCOL_HTTP ] { 1 }
Constant [ int YAR_CLIENT_PROTOCOL_TCP ] { 2 }
Constant [ int YAR_CLIENT_PROTOCOL_UNIX ] { 4 }
@@ -65,15 +66,14 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [1] {
- Property [ <default> protected $_executor ]
+ Property [ protected $_executor = NULL ]
}
- Methods [2] {
Method [ <internal:yar, ctor> final public method __construct ] {
- - Parameters [2] {
- Parameter #0 [ <required> $obj ]
- Parameter #1 [ <optional> $protocol ]
+ - Parameters [1] {
+ Parameter #0 [ <required> object $executor ]
}
}
@@ -81,6 +81,7 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
- Parameters [0] {
}
+ - Return [ bool ]
}
}
}
@@ -96,51 +97,51 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
- Static methods [0] {
}
- - Properties [4] {
- Property [ <default> protected $_protocol ]
- Property [ <default> protected $_uri ]
- Property [ <default> protected $_options ]
- Property [ <default> protected $_running ]
+ - Properties [0] {
}
- Methods [5] {
Method [ <internal:yar, ctor> final public method __construct ] {
- Parameters [2] {
- Parameter #0 [ <required> $url ]
- Parameter #1 [ <optional> $async ]
+ Parameter #0 [ <required> string $uri ]
+ Parameter #1 [ <optional> array $options = NULL ]
}
}
Method [ <internal:yar> public method call ] {
- Parameters [2] {
- Parameter #0 [ <required> $method ]
- Parameter #1 [ <required> $parameters ]
+ Parameter #0 [ <required> string $method ]
+ Parameter #1 [ <required> array $arguments ]
}
+ - Return [ mixed ]
}
Method [ <internal:yar> public method __call ] {
- Parameters [2] {
- Parameter #0 [ <required> $method ]
- Parameter #1 [ <required> $parameters ]
+ Parameter #0 [ <required> string $method ]
+ Parameter #1 [ <required> array $arguments ]
}
+ - Return [ mixed ]
}
Method [ <internal:yar> public method getOpt ] {
- Parameters [1] {
- Parameter #0 [ <required> $type ]
+ Parameter #0 [ <required> int $type ]
}
+ - Return [ mixed ]
}
Method [ <internal:yar> public method setOpt ] {
- Parameters [2] {
- Parameter #0 [ <required> $type ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> int $type ]
+ Parameter #1 [ <required> mixed $value ]
}
+ - Return [ Yar_Client|bool ]
}
}
}
@@ -150,33 +151,38 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
- Constants [0] {
}
- - Static properties [4] {
- Property [ protected static $_callstack ]
- Property [ protected static $_callback ]
- Property [ protected static $_error_callback ]
- Property [ protected static $_start ]
+ - Static properties [0] {
}
- Static methods [3] {
Method [ <internal:yar> static public method call ] {
- - Parameters [4] {
- Parameter #0 [ <required> $uri ]
- Parameter #1 [ <required> $method ]
- Parameter #2 [ <required> $parameters ]
- Parameter #3 [ <optional> $callback ]
+ - Parameters [6] {
+ Parameter #0 [ <required> string $uri ]
+ Parameter #1 [ <required> string $method ]
+ Parameter #2 [ <optional> ?array $arguments = NULL ]
+ Parameter #3 [ <optional> ?callable $callback = NULL ]
+ Parameter #4 [ <optional> ?callable $error_callback = NULL ]
+ Parameter #5 [ <optional> ?array $options = NULL ]
}
+ - Return [ int|bool|null ]
}
Method [ <internal:yar> static public method loop ] {
- - Parameters [2] {
- Parameter #0 [ <optional> $callback ]
- Parameter #1 [ <optional> $error_callback ]
+ - Parameters [3] {
+ Parameter #0 [ <optional> ?callable $callback = NULL ]
+ Parameter #1 [ <optional> ?callable $error_callback = NULL ]
+ Parameter #2 [ <optional> ?array $options = NULL ]
}
+ - Return [ ?bool ]
}
Method [ <internal:yar> static public method reset ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
}
}
@@ -187,7 +193,7 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
}
- Class [ <internal:yar> class Yar_Server_Exception extends Exception implements Throwable ] {
+ Class [ <internal:yar> class Yar_Server_Exception extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -199,56 +205,94 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [5] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
- Property [ <default> protected $_type ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
+ Property [ protected $_type = 'Yar_Exception_S...' ]
}
- Methods [11] {
Method [ <internal:yar> public method getType ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:yar> class Yar_Server_Request_Exception extends Yar_Server_Exception implements Throwable ] {
+ Class [ <internal:yar> class Yar_Server_Request_Exception extends Yar_Server_Exception implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -260,55 +304,93 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [11] {
Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:yar> class Yar_Server_Protocol_Exception extends Yar_Server_Exception implements Throwable ] {
+ Class [ <internal:yar> class Yar_Server_Protocol_Exception extends Yar_Server_Exception implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -320,55 +402,93 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [11] {
Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:yar> class Yar_Server_Packager_Exception extends Yar_Server_Exception implements Throwable ] {
+ Class [ <internal:yar> class Yar_Server_Packager_Exception extends Yar_Server_Exception implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -380,55 +500,93 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [11] {
Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:yar> class Yar_Server_Output_Exception extends Yar_Server_Exception implements Throwable ] {
+ Class [ <internal:yar> class Yar_Server_Output_Exception extends Yar_Server_Exception implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -440,55 +598,93 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [11] {
Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string|int ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:yar> class Yar_Client_Exception extends Exception implements Throwable ] {
+ Class [ <internal:yar> class Yar_Client_Exception extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -500,55 +696,93 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [11] {
Method [ <internal:yar> public method getType ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:yar> class Yar_Client_Transport_Exception extends Yar_Client_Exception implements Throwable ] {
+ Class [ <internal:yar> class Yar_Client_Transport_Exception extends Yar_Client_Exception implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -560,55 +794,93 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [11] {
Method [ <internal:yar, inherits Yar_Client_Exception> public method getType ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:yar> class Yar_Client_Packager_Exception extends Yar_Client_Exception implements Throwable ] {
+ Class [ <internal:yar> class Yar_Client_Packager_Exception extends Yar_Client_Exception implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -620,55 +892,93 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [11] {
Method [ <internal:yar, inherits Yar_Client_Exception> public method getType ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:yar> class Yar_Client_Protocol_Exception extends Yar_Client_Exception implements Throwable ] {
+ Class [ <internal:yar> class Yar_Client_Protocol_Exception extends Yar_Client_Exception implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -680,50 +990,88 @@ Extension [ <persistent> extension #112 yar version 2.1.1 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [11] {
Method [ <internal:yar, inherits Yar_Client_Exception> public method getType ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index d661529..07a8b8d 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -1,16 +1,17 @@
# remirepo spec file for php-pecl-yar
#
-# Copyright (c) 2013-2020 Remi Collet
+# Copyright (c) 2013-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-yar
%endif
+%bcond_without tests
+
%global gh_commit 0e04a6a92347f7e95c9ddf8bbbad36b6286ed87f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laruence
@@ -18,34 +19,31 @@
#global gh_date 20150914
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name yar
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-%if "%{php_version}" < "5.6"
-# After json, msgpack
-%global ini_name %{pecl_name}.ini
-%else
# After 40-json, 40-msgpack
%global ini_name 50-%{pecl_name}.ini
-%endif
Summary: Light, concurrent RPC framework
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.1.1
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 2.3.2
%if 0%{?gh_date:1}
Release: 0.14.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
+Patch0: %{pecl_name}-php82.patch
+
BuildRequires: %{?dtsprefix}gcc
+BuildRequires: make
BuildRequires: curl-devel
-BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
-BuildRequires: %{?sub_prefix}php-pecl-msgpack-devel
+BuildRequires: %{?scl_prefix}php-pecl-msgpack-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -58,32 +56,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.2"
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
%description
@@ -108,6 +80,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .pr177
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}%{?gh_date:-dev}"; then
@@ -137,7 +111,6 @@ extension=%{pecl_name}.so
;yar.expose_info=On
;yar.packager=msgpack
;yar.timeout=5000
-;yar.transport=curl
EOF
@@ -210,37 +183,40 @@ fi
%check
+DEPS="-n"
+if [ -f %{php_extdir}/json.so ]; then
+DEPS="$DEPS -d extension=json.so"
+fi
+if [ -f %{php_extdir}/msgpack.so ]; then
+DEPS="$DEPS -d extension=msgpack.so"
+fi
+
# fails in mock with: curl exec failed 'Couldn't connect to server'
rm ?TS/tests/022.phpt
: Minimal load test for NTS extension
-%{__php} --no-php-ini \
- --define extension=json.so \
- --define extension=msgpack.so \
- --define extension=NTS/modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+%{__php} $DEPS \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
%if %{with_zts}
: Minimal load test for ZTS extension
-%{__ztsphp} --no-php-ini \
- --define extension=json.so \
- --define extension=msgpack.so \
- --define extension=ZTS/modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+%{__ztsphp} $DEPS \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
%endif
-%if %{with_tests}
+%if %{with tests}
cd NTS
: Create test configuration
export TEST_PHP_EXECUTABLE=%{__php}
-export TEST_PHP_ARGS="-n -d extension=json.so -d extension=msgpack.so -d extension=$PWD/modules/%{pecl_name}.so"
-export NO_INTERACTION=1
+export TEST_PHP_ARGS="$DEPS -d extension=$PWD/modules/%{pecl_name}.so"
export REPORT_EXIT_STATUS=1
export YAR_API_PORT=$(%{__php} -r 'echo 8960 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + PHP_INT_SIZE + 0%{?scl:1};')
: Run the upstream test suite
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php -q --show-diff
%else
: upstream test suite disabled
%endif
@@ -263,6 +239,33 @@ export YAR_API_PORT=$(%{__php} -r 'echo 8960 + PHP_MAJOR_VERSION*100 + PHP_MINOR
%changelog
+* Mon Oct 3 2022 Remi Collet <remi@remirepo.net> - 2.3.2-2
+- add patch for PHP 8.2 from
+ https://github.com/laruence/yar/pull/177
+
+* Wed May 18 2022 Remi Collet <remi@remirepo.net> - 2.3.2-1
+- update to 2.3.2
+
+* Mon May 9 2022 Remi Collet <remi@remirepo.net> - 2.3.1-1
+- update to 2.3.1
+- drop patch merged upstream
+
+* Thu May 5 2022 Remi Collet <remi@remirepo.net> - 2.3.0-2
+- add fix for https://github.com/laruence/yar/issues/172
+ using patch from https://github.com/laruence/yar/pull/174
+
+* Mon Apr 25 2022 Remi Collet <remi@remirepo.net> - 2.3.0-1
+- update to 2.3.0
+
+* Mon Dec 20 2021 Remi Collet <remi@remirepo.net> - 2.2.1-1
+- update to 2.2.1
+
+* Tue Jan 5 2021 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+
+* Tue Mar 31 2020 Remi Collet <remi@remirepo.net> - 2.1.2-1
+- update to 2.1.2
+
* Mon Mar 16 2020 Remi Collet <remi@remirepo.net> - 2.1.1-1
- update to 2.1.1
- drop patches merged upstream
diff --git a/yar-php82.patch b/yar-php82.patch
new file mode 100644
index 0000000..514acff
--- /dev/null
+++ b/yar-php82.patch
@@ -0,0 +1,68 @@
+From 15ece2444d614bac545b5d1cd7ea86a2881a9ddd Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 19 Sep 2022 13:12:47 +0200
+Subject: [PATCH 1/2] fix random seed check for PHP 8
+
+---
+ yar_request.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/yar_request.c b/yar_request.c
+index be6a41b..59f527e 100644
+--- a/yar_request.c
++++ b/yar_request.c
+@@ -34,7 +34,11 @@
+ yar_request_t *php_yar_request_instance(zend_string *method, zend_array *parameters, void **options) /* {{{ */ {
+ yar_request_t *request = emalloc(sizeof(yar_request_t));
+
++#if PHP_VERSION_ID < 80200
+ if (!BG(mt_rand_is_seeded)) {
++#else
++ if (!RANDOM_G(mt19937_seeded)) {
++#endif
+ php_mt_srand(GENERATE_SEED());
+ }
+
+
+From 865d2e0615fcfb969db87f254792ec3844600280 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 19 Sep 2022 13:13:01 +0200
+Subject: [PATCH 2/2] fix tests for PHP 8.2
+
+---
+ tests/yar.inc | 20 +++++++++++---------
+ 1 file changed, 11 insertions(+), 9 deletions(-)
+
+diff --git a/tests/yar.inc b/tests/yar.inc
+index d5c3693..d096f88 100644
+--- a/tests/yar.inc
++++ b/tests/yar.inc
+@@ -105,17 +105,19 @@ PHP;
+
+ function yar_server_cleanup() {
+ $dir = dirname(__FILE__) . DIRECTORY_SEPARATOR . "htdocs";
+- $dp = opendir($dir);
+- while (($f = readdir($dp))) {
+- if (in_array($f, array('.', '..'))) {
+- continue;
+- }
+- $path = $dir . DIRECTORY_SEPARATOR . $f;
+- if (is_file($path)) {
+- unlink($path);
++ if (is_dir($dir)) {
++ $dp = opendir($dir);
++ while (($f = readdir($dp))) {
++ if (in_array($f, array('.', '..'))) {
++ continue;
++ }
++ $path = $dir . DIRECTORY_SEPARATOR . $f;
++ if (is_file($path)) {
++ unlink($path);
++ }
+ }
++ rmdir($dir);
+ }
+- rmdir($dir);
+ }
+
+ /* For TCP */