summaryrefslogtreecommitdiffstats
path: root/php-pecl-yar.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-16 08:21:45 +0100
committerRemi Collet <remi@remirepo.net>2020-03-16 08:21:45 +0100
commit422b2ff6f1437043483cf3f304ddf47e9f15a70e (patch)
tree322a5b5b29e37a158b5523cbc44a01ca4a8a7b4e /php-pecl-yar.spec
parent989e32ff2ae1c3725519ab5d6118d0cc6eda9a11 (diff)
update to 2.1.0
fix build with msgpack using patch from https://github.com/laruence/yar/pull/151 add missing file from upstream git repo and open https://github.com/laruence/yar/pull/152
Diffstat (limited to 'php-pecl-yar.spec')
-rw-r--r--php-pecl-yar.spec19
1 files changed, 17 insertions, 2 deletions
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index 9cf0801..22ac9f5 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -29,7 +29,7 @@
Summary: Light, concurrent RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.7
+Version: 2.1.0
%if 0%{?gh_date:1}
Release: 0.14.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
@@ -40,6 +40,9 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
License: PHP
URL: https://pecl.php.net/package/%{pecl_name}
+Source1: https://raw.githubusercontent.com/laruence/yar/yar-2.1.0/tests/htdocs/internal.php
+Patch0: https://patch-diff.githubusercontent.com/raw/laruence/yar/pull/151.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: curl-devel
BuildRequires: %{?scl_prefix}php-devel > 7
@@ -114,6 +117,9 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+cp %{SOURCE1} tests/htdocs/internal.php
+%patch0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}%{?gh_date:-dev}"; then
@@ -137,7 +143,6 @@ cat > %{ini_name} << 'EOF'
extension=%{pecl_name}.so
; Configuration
-;yar.allow_persistent=0
;yar.connect_timeout=1000
;yar.content_type=application/octet-stream
;yar.debug=Off
@@ -217,6 +222,9 @@ fi
%check
+# fails in mock with: curl exec failed 'Couldn't connect to server'
+rm ?TS/tests/022.phpt
+
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=json.so \
@@ -267,6 +275,13 @@ export YAR_API_PORT=$(%{__php} -r 'echo 8960 + PHP_MAJOR_VERSION*100 + PHP_MINOR
%changelog
+* Mon Mar 16 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- update to 2.1.0
+- fix build with msgpack using patch from
+ https://github.com/laruence/yar/pull/151
+- add missing file from upstream git repo and
+ open https://github.com/laruence/yar/pull/152
+
* Mon Jan 6 2020 Remi Collet <remi@remirepo.net> - 2.0.7-1
- update to 2.0.7