summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-26 08:49:27 +0100
committerRemi Collet <remi@remirepo.net>2019-12-26 08:49:27 +0100
commitefaaa3fe707f4069206144a9c98d266e0289f07e (patch)
tree809028d32b8fab92d8a9f2804410040cf412aaa4
parentbaaab152da851815eaed2b4ed60cf67e59112cc3 (diff)
v2.0.6
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION34
-rw-r--r--a3be2c6972479ea32fedc4f87b5ebdf3aeccd5f7.patch22
-rw-r--r--php-pecl-yar.spec41
4 files changed, 56 insertions, 43 deletions
diff --git a/PHPINFO b/PHPINFO
index f6947c9..cbc9527 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
yar
yar support => enabled
-Version => 2.0.5
+Version => 2.0.6
Directive => Local Value => Master Value
yar.packager => msgpack => msgpack
diff --git a/REFLECTION b/REFLECTION
index b9371c3..f743d7e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #195 yar version 2.0.5 ] {
+Extension [ <persistent> extension #108 yar version 2.0.6 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -33,25 +33,25 @@ Extension [ <persistent> extension #195 yar version 2.0.5 ] {
}
- Constants [19] {
- Constant [ string YAR_VERSION ] { 2.0.5 }
- Constant [ integer YAR_OPT_PACKAGER ] { 1 }
- Constant [ integer YAR_OPT_PERSISTENT ] { 2 }
- Constant [ integer YAR_OPT_TIMEOUT ] { 4 }
- Constant [ integer YAR_OPT_CONNECT_TIMEOUT ] { 8 }
- Constant [ integer YAR_OPT_HEADER ] { 16 }
- Constant [ integer YAR_CLIENT_PROTOCOL_HTTP ] { 1 }
- Constant [ integer YAR_CLIENT_PROTOCOL_TCP ] { 2 }
- Constant [ integer YAR_CLIENT_PROTOCOL_UNIX ] { 4 }
+ Constant [ string YAR_VERSION ] { 2.0.6 }
+ Constant [ int YAR_OPT_PACKAGER ] { 1 }
+ Constant [ int YAR_OPT_PERSISTENT ] { 2 }
+ Constant [ int YAR_OPT_TIMEOUT ] { 4 }
+ Constant [ int YAR_OPT_CONNECT_TIMEOUT ] { 8 }
+ Constant [ int YAR_OPT_HEADER ] { 16 }
+ Constant [ int YAR_CLIENT_PROTOCOL_HTTP ] { 1 }
+ Constant [ int YAR_CLIENT_PROTOCOL_TCP ] { 2 }
+ Constant [ int YAR_CLIENT_PROTOCOL_UNIX ] { 4 }
Constant [ string YAR_PACKAGER_PHP ] { PHP }
Constant [ string YAR_PACKAGER_JSON ] { JSON }
Constant [ string YAR_PACKAGER_MSGPACK ] { MSGPACK }
- Constant [ integer YAR_ERR_OKEY ] { 0 }
- Constant [ integer YAR_ERR_OUTPUT ] { 8 }
- Constant [ integer YAR_ERR_TRANSPORT ] { 16 }
- Constant [ integer YAR_ERR_REQUEST ] { 4 }
- Constant [ integer YAR_ERR_PROTOCOL ] { 2 }
- Constant [ integer YAR_ERR_PACKAGER ] { 1 }
- Constant [ integer YAR_ERR_EXCEPTION ] { 64 }
+ Constant [ int YAR_ERR_OKEY ] { 0 }
+ Constant [ int YAR_ERR_OUTPUT ] { 8 }
+ Constant [ int YAR_ERR_TRANSPORT ] { 16 }
+ Constant [ int YAR_ERR_REQUEST ] { 4 }
+ Constant [ int YAR_ERR_PROTOCOL ] { 2 }
+ Constant [ int YAR_ERR_PACKAGER ] { 1 }
+ Constant [ int YAR_ERR_EXCEPTION ] { 64 }
}
- Classes [12] {
diff --git a/a3be2c6972479ea32fedc4f87b5ebdf3aeccd5f7.patch b/a3be2c6972479ea32fedc4f87b5ebdf3aeccd5f7.patch
new file mode 100644
index 0000000..91e9b29
--- /dev/null
+++ b/a3be2c6972479ea32fedc4f87b5ebdf3aeccd5f7.patch
@@ -0,0 +1,22 @@
+From a3be2c6972479ea32fedc4f87b5ebdf3aeccd5f7 Mon Sep 17 00:00:00 2001
+From: Xinchen Hui <laruence@gmail.com>
+Date: Wed, 25 Dec 2019 18:16:26 +0800
+Subject: [PATCH] Attempt to fix test in travis
+
+---
+ tests/yar.inc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/yar.inc b/tests/yar.inc
+index 23d0944..b79e3c1 100644
+--- a/tests/yar.inc
++++ b/tests/yar.inc
+@@ -13,7 +13,7 @@ function yar_server_start($doc_root = __DIR__ . "/htdocs", $cmd_args = "-dextens
+ $php_executable = (getenv('TEST_PHP_EXECUTABLE')?:PHP_BINARY);
+ $tmp = getenv('TEST_PHP_ARGS');
+ if ($tmp) {
+- $cmd_args .= $tmp;
++ //$cmd_args .= $tmp;
+ }
+
+ $descriptorspec = array(
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index 8574684..a613226 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-yar
#
-# Copyright (c) 2013-2018 Remi Collet
+# Copyright (c) 2013-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -29,16 +29,18 @@
Summary: Light, concurrent RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.5
+Version: 2.0.6
%if 0%{?gh_date:1}
Release: 0.14.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
-URL: http://pecl.php.net/package/%{pecl_name}
+URL: https://pecl.php.net/package/%{pecl_name}
+
+Patch0: https://github.com/laruence/yar/commit/a3be2c6972479ea32fedc4f87b5ebdf3aeccd5f7.patch
BuildRequires: %{?dtsprefix}gcc
BuildRequires: curl-devel
@@ -71,28 +73,18 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{rele
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "7.2"
Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.3"
-Obsoletes: php73u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php73-pecl-%{pecl_name} <= %{version}
Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.4"
+Obsoletes: php74-pecl-%{pecl_name} <= %{version}
+Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -124,6 +116,7 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -R -b .rev
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
@@ -252,12 +245,7 @@ export TEST_PHP_EXECUTABLE=%{__php}
export TEST_PHP_ARGS="-n -d extension=json.so -d extension=msgpack.so -d extension=$PWD/modules/%{pecl_name}.so"
export NO_INTERACTION=1
export REPORT_EXIT_STATUS=1
-
-%ifarch x86_64
-export YAR_API_PORT=8968
-%else
-export YAR_API_PORT=8964
-%endif
+export YAR_API_PORT=$(%{__php} -r 'echo 8960 + PHP_MAJOR_VERSION*100 + PHP_MINOR_VERSION*10 + PHP_INT_SIZE + 0%{?scl:1};')
: Run the upstream test suite
%{__php} -n run-tests.php --show-diff
@@ -283,6 +271,9 @@ export YAR_API_PORT=8964
%changelog
+* Thu Dec 26 2019 Remi Collet <remi@remirepo.net> - 2.0.6-1
+- update to 2.0.6
+
* Fri Dec 21 2018 Remi Collet <remi@remirepo.net> - 2.0.5-1
- update to 2.0.5