summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-12 13:46:40 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-12 13:46:40 +0200
commitd77ecf9c54b7f7bfb5fefe73f7d8fb22df717bc7 (patch)
treee600b631818d9129bfeafb660d661579004011aa
parentdb5c3b1da8e071984eee80756d1d736366f324e0 (diff)
php-pecl-yar: 1.2.5dev for PHP 7
-rw-r--r--REFLECTION-DEV706
-rw-r--r--php-pecl-yar-dev.spec57
-rw-r--r--php-pecl-yar.spec2
3 files changed, 749 insertions, 16 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
new file mode 100644
index 0000000..db0f5af
--- /dev/null
+++ b/REFLECTION-DEV
@@ -0,0 +1,706 @@
+Extension [ <persistent> extension #92 yar version 1.2.5-dev ] {
+
+ - Dependencies {
+ Dependency [ json (Required) ]
+ Dependency [ msgpack (Required) ]
+ }
+
+ - INI {
+ Entry [ yar.packager <PERDIR> ]
+ Current = 'msgpack'
+ }
+ Entry [ yar.transport <PERDIR> ]
+ Current = 'curl'
+ }
+ Entry [ yar.debug <ALL> ]
+ Current = 'Off'
+ }
+ Entry [ yar.expose_info <PERDIR> ]
+ Current = 'On'
+ }
+ Entry [ yar.connect_timeout <ALL> ]
+ Current = '1000'
+ }
+ Entry [ yar.timeout <ALL> ]
+ Current = '5000'
+ }
+ Entry [ yar.content_type <ALL> ]
+ Current = 'application/octet-stream'
+ }
+ Entry [ yar.allow_persistent <ALL> ]
+ Current = '0'
+ }
+ }
+
+ - Constants [18] {
+ Constant [ string YAR_VERSION ] { 1.2.5-dev }
+ Constant [ integer YAR_OPT_PACKAGER ] { 1 }
+ Constant [ integer YAR_OPT_PERSISTENT ] { 2 }
+ Constant [ integer YAR_OPT_TIMEOUT ] { 4 }
+ Constant [ integer YAR_OPT_CONNECT_TIMEOUT ] { 8 }
+ Constant [ integer YAR_CLIENT_PROTOCOL_HTTP ] { 1 }
+ Constant [ integer YAR_CLIENT_PROTOCOL_TCP ] { 2 }
+ Constant [ integer YAR_CLIENT_PROTOCOL_UNIX ] { 4 }
+ Constant [ string YAR_PACKAGER_PHP ] { PHP }
+ Constant [ string YAR_PACKAGER_JSON ] { JSON }
+ Constant [ string YAR_PACKAGER_MSGPACK ] { MSGPACK }
+ Constant [ integer YAR_ERR_OKEY ] { 0 }
+ Constant [ integer YAR_ERR_OUTPUT ] { 8 }
+ Constant [ integer YAR_ERR_TRANSPORT ] { 16 }
+ Constant [ integer YAR_ERR_REQUEST ] { 4 }
+ Constant [ integer YAR_ERR_PROTOCOL ] { 2 }
+ Constant [ integer YAR_ERR_PACKAGER ] { 64 }
+ Constant [ integer YAR_ERR_EXCEPTION ] { 64 }
+ }
+
+ - Classes [12] {
+ Class [ <internal:yar> class Yar_Server ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ <default> protected $_executor ]
+ }
+
+ - Methods [2] {
+ Method [ <internal:yar, ctor> final public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $obj ]
+ Parameter #1 [ <optional> $protocol ]
+ }
+ }
+
+ Method [ <internal:yar> public method handle ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Client ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $_protocol ]
+ Property [ <default> protected $_uri ]
+ Property [ <default> protected $_options ]
+ Property [ <default> protected $_running ]
+ }
+
+ - Methods [5] {
+ Method [ <internal:yar, ctor> final public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $url ]
+ Parameter #1 [ <optional> $async ]
+ }
+ }
+
+ Method [ <internal:yar> public method call ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $method ]
+ Parameter #1 [ <required> $parameters ]
+ }
+ }
+
+ Method [ <internal:yar> public method __call ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $method ]
+ Parameter #1 [ <required> $parameters ]
+ }
+ }
+
+ Method [ <internal:yar> public method getOpt ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $type ]
+ }
+ }
+
+ Method [ <internal:yar> public method setOpt ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $type ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Concurrent_Client ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [4] {
+ Property [ protected static $_callstack ]
+ Property [ protected static $_callback ]
+ Property [ protected static $_error_callback ]
+ Property [ protected static $_start ]
+ }
+
+ - Static methods [3] {
+ Method [ <internal:yar> static public method call ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $uri ]
+ Parameter #1 [ <required> $method ]
+ Parameter #2 [ <required> $parameters ]
+ Parameter #3 [ <optional> $callback ]
+ }
+ }
+
+ Method [ <internal:yar> static public method loop ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $callback ]
+ Parameter #1 [ <optional> $error_callback ]
+ }
+ }
+
+ Method [ <internal:yar> static public method reset ] {
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Server_Exception extends Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $_type ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:yar> public method getType ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Server_Request_Exception extends Yar_Server_Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Server_Protocol_Exception extends Yar_Server_Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Server_Packager_Exception extends Yar_Server_Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Server_Output_Exception extends Yar_Server_Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:yar, inherits Yar_Server_Exception> public method getType ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Client_Exception extends Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:yar> public method getType ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Client_Transport_Exception extends Yar_Client_Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:yar, inherits Yar_Client_Exception> public method getType ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Client_Packager_Exception extends Yar_Client_Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:yar, inherits Yar_Client_Exception> public method getType ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:yar> class Yar_Client_Protocol_Exception extends Yar_Client_Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:yar, inherits Yar_Client_Exception> public method getType ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits BaseException> public method __toString ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-yar-dev.spec b/php-pecl-yar-dev.spec
index 7bde1ee..73eeab2 100644
--- a/php-pecl-yar-dev.spec
+++ b/php-pecl-yar-dev.spec
@@ -1,4 +1,4 @@
-# spec file for php-pecl-yar
+# remirepo spec file for php-pecl-yar
#
# Copyright (c) 2013-2015 Remi Collet
# License: CC-BY-SA
@@ -11,6 +11,11 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
+%global gh_commit 7aca9e671815d884206e8fc47c789ab76c2865f2
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner laruence
+%global gh_project yar
+%global gh_date 20150612
%global with_zts 0%{?__ztsphp:1}
%global pecl_name yar
%if "%{php_version}" < "5.6"
@@ -23,12 +28,16 @@
Summary: Light, concurrent RPC framework
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.2.4
-Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}.1
-License: BSD
+Version: 1.2.5
+%if 0%{?gh_date:1}
+Release: 0.2.%{gh_date}git%{gh_short}%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+%else
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+%endif
+License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: curl-devel
@@ -36,8 +45,6 @@ BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-pecl-msgpack-devel
-Requires(post): %{__pecl}
-Requires(postun): %{__pecl}
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%if "%{php_version}" < "5.4"
@@ -70,6 +77,10 @@ Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -87,11 +98,14 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
-%setup -q -c
-mv %{pecl_name}-%{version} NTS
+%setup -qc
+mv %{gh_project}-%{gh_commit} NTS
+mv NTS/package2.xml .
# Don't install/register tests
-sed -e 's/role="test"/role="src"/' -i package2.xml
+sed -e 's/role="test"/role="src"/' \
+ -e '/README/s/role="doc"/role="test"/' \
+ -i package2.xml
cd NTS
@@ -101,8 +115,8 @@ sed -e 's:<?php:#!%{_bindir}/php\n<?php:' \
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
-if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}%{?gh_date:-dev}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}%{?gh_date:-dev}.
exit 1
fi
cd ..
@@ -181,12 +195,20 @@ do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%post
-%{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
%postun
-if [ $1 -eq 0 ] ; then
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
@@ -230,6 +252,11 @@ rm -rf %{buildroot}
%changelog
+* Fri Jun 12 2015 Remi Collet <remi@fedoraproject.org> - 1.2.5-0.1.20150612git7aca9e6
+- Update to 1.2.5-dev for PHP 7
+- sources from github
+- drop runtime dependency on pear, new scriptlets
+
* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 1.2.4-1.1
- Fedora 21 SCL mass rebuild
diff --git a/php-pecl-yar.spec b/php-pecl-yar.spec
index 7bde1ee..b042f1f 100644
--- a/php-pecl-yar.spec
+++ b/php-pecl-yar.spec
@@ -1,4 +1,4 @@
-# spec file for php-pecl-yar
+# remirepo spec file for php-pecl-yar
#
# Copyright (c) 2013-2015 Remi Collet
# License: CC-BY-SA