summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-17 15:51:52 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-17 15:51:52 +0200
commit7ca894ff6fc2ff8fe04d45dc2dc909e622a9bf46 (patch)
treef99803b8dda5a7ac6d8cc28d9800640bf75151f5
parent77e15afe59789a94afdd4b4d2aa65f81b5f8f817 (diff)
php-pecl-yar: rebuild again (patch merged upstream)
-rw-r--r--php-pecl-yar-dev.spec11
-rw-r--r--yar-pr51.patch53
2 files changed, 6 insertions, 58 deletions
diff --git a/php-pecl-yar-dev.spec b/php-pecl-yar-dev.spec
index 1ea3353..32aba6c 100644
--- a/php-pecl-yar-dev.spec
+++ b/php-pecl-yar-dev.spec
@@ -11,11 +11,11 @@
%{!?__pecl: %global __pecl %{_bindir}/pecl}
%{!?__php: %global __php %{_bindir}/php}
-%global gh_commit 410ca7a3f1d633050000ee2ec233366d73e3fda3
+%global gh_commit d1fb4b5e2c669e1a09dcc2cd5a11597b79b423ab
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner laruence
%global gh_project yar
-%global gh_date 20150615
+%global gh_date 20150617
%global with_zts 0%{?__ztsphp:1}
%global pecl_name yar
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
@@ -40,8 +40,6 @@ Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-Patch0: %{pecl_name}-pr51.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: curl-devel
BuildRequires: %{?scl_prefix}php-devel
@@ -111,7 +109,6 @@ sed -e 's/role="test"/role="src"/' \
-i package2.xml
cd NTS
-%patch0 -p1
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
@@ -273,8 +270,12 @@ rm -rf %{buildroot}
%changelog
+* Wed Jun 17 2015 Remi Collet <remi@fedoraproject.org> - 1.2.5-0.3.20150617gitd1fb4b5
+- rebuild
+
* Wed Jun 17 2015 Remi Collet <remi@fedoraproject.org> - 1.2.5-0.3.20150615git410ca7a
- rebuild
+- open https://github.com/laruence/yar/pull/51
* Fri Jun 12 2015 Remi Collet <remi@fedoraproject.org> - 1.2.5-0.2.20150612git3b43b26
- enable test suite during the build
diff --git a/yar-pr51.patch b/yar-pr51.patch
deleted file mode 100644
index 6023440..0000000
--- a/yar-pr51.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 7fc722c993ca01038dbfd52439891dd6f21b34e9 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Wed, 17 Jun 2015 14:06:52 +0200
-Subject: [PATCH 1/2] honours TEST_PHP_ARGS (which can include other extension,
- json, msgpack, ...)
-
----
- tests/yar.inc | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/tests/yar.inc b/tests/yar.inc
-index 467efe3..bd76ac1 100644
---- a/tests/yar.inc
-+++ b/tests/yar.inc
-@@ -10,7 +10,11 @@ define("YAR_API_URI", "/");
- define("YAR_API_ADDRESS", "http://" . YAR_API_HOST . YAR_API_URI);
-
- function yar_server_start($doc_root = __DIR__ . "/htdocs", $cmd_args = "-dextension=" . __DIR__ . "/../modules/yar.so") {
-- $php_executable = getenv('TEST_PHP_EXECUTABLE');
-+ $php_executable = (getenv('TEST_PHP_EXECUTABLE')?:PHP_BINARY);
-+ $tmp = getenv('TEST_PHP_ARGS');
-+ if ($tmp) {
-+ $cmd_args = $tmp;
-+ }
-
- $descriptorspec = array(
- 0 => STDIN,
-
-From a2b79d399a6eb666f4873a42ce8cbf0cfb3b86b0 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Wed, 17 Jun 2015 14:09:34 +0200
-Subject: [PATCH 2/2] use ENV if defined for hostname and port (make
- downstream)
-
----
- tests/yar.inc | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/yar.inc b/tests/yar.inc
-index bd76ac1..e7161e2 100644
---- a/tests/yar.inc
-+++ b/tests/yar.inc
-@@ -3,8 +3,8 @@
- define("YAR_API_USER", "dummy");
- define("YAR_API_PASS", "foo");
-
--define("YAR_API_HOSTNAME", "localhost");
--define("YAR_API_PORT", "8964");
-+define("YAR_API_HOSTNAME", (getenv('YAR_API_HOSTNAME') ?: "localhost"));
-+define("YAR_API_PORT", (getenv('YAR_API_PORT') ?: "8964"));
- define("YAR_API_HOST", YAR_API_HOSTNAME . ":" . YAR_API_PORT);
- define("YAR_API_URI", "/");
- define("YAR_API_ADDRESS", "http://" . YAR_API_HOST . YAR_API_URI);