summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-02 10:07:57 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-02 10:07:57 +0200
commit73cf5b5f54336adc7d8ba4e8a0f8a31a26748489 (patch)
tree6b013933a02bb6d6208730f359d2568360e9d658
parent2bd1461ad0f61a96794239fa96a4b74ef307a8a2 (diff)
php-pecl-yar: 2.0.1
-rw-r--r--REFLECTION-PHP76
-rw-r--r--php-pecl-yar-php7.spec20
-rw-r--r--yar-php71.patch25
3 files changed, 16 insertions, 35 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index 923eec0..9289a66 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #106 yar version 2.0.0 ] {
+Extension [ <persistent> extension #141 yar version 2.0.1 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -33,7 +33,7 @@ Extension [ <persistent> extension #106 yar version 2.0.0 ] {
}
- Constants [18] {
- Constant [ string YAR_VERSION ] { 2.0.0 }
+ Constant [ string YAR_VERSION ] { 2.0.1 }
Constant [ integer YAR_OPT_PACKAGER ] { 1 }
Constant [ integer YAR_OPT_PERSISTENT ] { 2 }
Constant [ integer YAR_OPT_TIMEOUT ] { 4 }
@@ -49,7 +49,7 @@ Extension [ <persistent> extension #106 yar version 2.0.0 ] {
Constant [ integer YAR_ERR_TRANSPORT ] { 16 }
Constant [ integer YAR_ERR_REQUEST ] { 4 }
Constant [ integer YAR_ERR_PROTOCOL ] { 2 }
- Constant [ integer YAR_ERR_PACKAGER ] { 64 }
+ Constant [ integer YAR_ERR_PACKAGER ] { 1 }
Constant [ integer YAR_ERR_EXCEPTION ] { 64 }
}
diff --git a/php-pecl-yar-php7.spec b/php-pecl-yar-php7.spec
index 86f5bb8..00fbf7d 100644
--- a/php-pecl-yar-php7.spec
+++ b/php-pecl-yar-php7.spec
@@ -29,19 +29,17 @@
Summary: Light, concurrent RPC framework
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 2.0.0
+Version: 2.0.1
%if 0%{?gh_date:1}
Release: 0.10.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
%endif
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-
-# https://github.com/laruence/yar/pull/83
-Patch0: %{pecl_name}-php71.patch
BuildRequires: curl-devel
BuildRequires: %{?scl_prefix}php-devel > 7
@@ -105,8 +103,12 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
+%if 0%{?gh_date:1}
mv %{gh_project}-%{gh_commit} NTS
mv NTS/package2.xml .
+%else
+mv %{pecl_name}-%{version} NTS
+%endif
# Don't install/register tests
sed -e 's/role="test"/role="src"/' \
@@ -114,7 +116,6 @@ sed -e 's/role="test"/role="src"/' \
-i package2.xml
cd NTS
-%patch0 -p1 -b .php71
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_YAR_VERSION/{s/.* "//;s/".*$//;p}' php_yar.h)
@@ -269,6 +270,11 @@ export YAR_API_PORT=8964
%changelog
+* Sat Jul 2 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
+- update to 2.0.1 (php 7)
+- sources from pecl
+- drop patch merged upstream
+
* Sat Jun 11 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-3
- add patch for PHP 7.1
open https://github.com/laruence/yar/pull/83
diff --git a/yar-php71.patch b/yar-php71.patch
deleted file mode 100644
index af4ccd7..0000000
--- a/yar-php71.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 603689fe268d9178c4180b46f676b7d5abef696e Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Sat, 11 Jun 2016 07:05:55 +0200
-Subject: [PATCH] fix for PHP 7.1
-
----
- yar_server.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/yar_server.c b/yar_server.c
-index d46bd72..fac921b 100644
---- a/yar_server.c
-+++ b/yar_server.c
-@@ -219,7 +219,11 @@ static char * php_yar_get_function_declaration(zend_function *fptr) /* {{{ */ {
- zval zv, zv_copy;
- int use_copy;
- ZVAL_DUP(&zv, RT_CONSTANT(&fptr->op_array, precv->op2));
-+#if PHP_VERSION_ID < 70100
- zval_update_constant_ex(&zv, 1, fptr->common.scope);
-+#else
-+ zval_update_constant_ex(&zv, fptr->common.scope);
-+#endif
- if (Z_TYPE(zv) == IS_TRUE) {
- memcpy(offset, "true", 4);
- offset += 4;